Results 1 to 5 of 5

Thread: Phonon crashes when advancing a track in Amarol

  1. #1
    Join Date
    Dec 2007
    Location
    Boise, ID
    Beans
    43
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Question Phonon crashes when advancing a track in Amarol

    I have experienced that Phonon will crash occasionally when I advance to the next track in Amarok. After Phonon crashes, Amarok can't play sound. The only remedy appears to be restarting.

    I would like to avoid the crashing. I have heard that Phonon and PulseAudio do not work well together. I would like to know how to disable PulseAudio when using Amarok. Any hints?

    I am using the Xine backend in Amarok. In the Config Phonon window, I have configured Phonon's hardware preferences to work directly with the sound hardware on the MoBo first. I have deprioritized PulseAudio to the bottom of the hardware list. Unfortunately the "remove" button is grayed out in the Phonon config window.

    I am running Ubuntu 9.10 - the Karmic Koala w/ Gnome so I don't want to uninstall PulseAudio.

    Thanks,
    Dave

  2. #2
    Join Date
    Jun 2010
    Location
    Argentina
    Beans
    40
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Phonon crashes when advancing a track in Amarol

    Same problem here. Laptop with Kubuntu 10.04 and Amarok 2.3.
    I recently installed pulseaudio to solve my mic-in problem. Now Amarok crashes my sound card (I get a phonon message saying it's no longer working). In my case it doesn't happen every time I advance a track, but apparently having a youtube video playing at the same time always makes it crash.
    The only solution I found is rebooting.

  3. #3
    Join Date
    Dec 2007
    Location
    Boise, ID
    Beans
    43
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    Re: Phonon crashes when advancing a track in Amarol

    I suspect that the issues have to do with the backend you are using. I have switched from Xine to GStreamer. I still get segmentation fault crashes that randomly occur. But at least I can just restart the app instead of having to restart the OS.

    People have said that version Phonon 4.4.4 resolves the crashing issue. I can't figure out how to compile it though.
    http://apachelog.wordpress.com/2011/...-family-4-4-4/

    I think that version is coming with Natty.
    http://packages.ubuntu.com/natty/sou...kend-gstreamer

  4. #4
    Join Date
    Jun 2010
    Location
    Argentina
    Beans
    40
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Phonon crashes when advancing a track in Amarol

    Oh, thanks for shedding some light on this noob
    I think I'll wait for kubuntu 11.04 and see, compiling is a bit out of my league for now.

  5. #5
    Join Date
    Apr 2007
    Location
    Hill Billy-ville,Missouri
    Beans
    6
    Distro
    Kubuntu

    Re: Phonon crashes when advancing a track in Amarol

    I'm currently running the Kubuntu 11.04 beta, and Phonon goobered up during the install, now when I play any format of video my system crashes enough to log me out. I don't want to uninstall/reinstall Phonon because it looks like the entire media playback system rides on it. My audio is working fine. Amarok is working great. Is there a way to have apt-get re-install Phonon?

    Thanks for any help.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •