Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Monitor goes to sleep during installation

  1. #1
    Join Date
    Jun 2010
    Beans
    8

    Exclamation Monitor goes to sleep during installation

    I am trying to install Ubuntu 10.04 on my PC using NVIDIA GeForce 9150LE graphics and HP w2207h monitor. After using the Wubi installer and rebooting my computer, i select the ubuntu boot menu option and it says it is preparing to continue with the installation. after a countdown before it begins, my monitor goes to sleep. i used an eMachine monitor that i used in a previous installation of 9.10 that worked fine and reached the exact same problem. When booting from a live CD and selecting try without installing the screen comes up with a blinking underscore, and both monitors went to sleep. I believe its a problem with the graphics chip, but i dont know how to fix it. Any help would be greatly appreciated.

  2. #2
    Join Date
    Nov 2009
    Location
    North Vancouver
    Beans
    Hidden!
    Distro
    Edubuntu 14.04 Trusty Tahr

    Re: Monitor goes to sleep during installation

    From the wubiguide, you can hit ESC when you see that first countdown and then you will 'see a menu with more boot options'.

    I haven't done this myself and the guide doesn't say, so not sure what it offers. But if there is something where you can add 'nomodeset' to the boot options, or choose 'safe graphics', that might get you in at least, and then you can look for a driver for your graphics card.

    It seems like nvidia drivers are a bit of a pain in 10.04. Here's a link https://help.ubuntu.com/community/Bi...erHowto/Nvidia that might shed more info.

  3. #3
    Join Date
    Jun 2010
    Beans
    8

    Re: Monitor goes to sleep during installation

    i believe there is a nomodeset option when booting from the live CD. I'll try it and see if it works.

  4. #4
    Join Date
    Jun 2010
    Beans
    8

    Re: Monitor goes to sleep during installation

    used nomodeset when booting from live CD, installed correctly. Could not install drivers while using live CD due to missing drivers for my wireless card. Will copy setup files for driver to a usb and try it again. there is not a nomodeset option using wubi installation process, so i have abandoned it. the safe graphics option didn't work either.

  5. #5
    Join Date
    Nov 2009
    Location
    North Vancouver
    Beans
    Hidden!
    Distro
    Edubuntu 14.04 Trusty Tahr

    Re: Monitor goes to sleep during installation

    I'll play around with the wubi install when I have a moment and see what can be done.
    However, if you are able to do a proper install (direct to partition) this is definitely better for long term use. So go that route.

    For one of my computers that needed ndiswrapper to get the wireless working, I downloaded the drivers on windows, and then mounted the windows partition to get them from ubuntu. USB works too.

  6. #6
    Join Date
    Nov 2009
    Location
    North Vancouver
    Beans
    Hidden!
    Distro
    Edubuntu 14.04 Trusty Tahr

    Re: Monitor goes to sleep during installation

    I did a wubi install. You're right there's no nomodeset option. If you hit 'e' on the normal option, you could probably insert "nomodeset" right after where it says "quiet splash".

    But it's not a very user friendly workaround.

  7. #7
    Join Date
    Jun 2010
    Beans
    8

    Re: Monitor goes to sleep during installation

    ok. i will try that. the drivers that Ubuntu showed me were for broadcomm, and it couldn't install it.

  8. #8
    Join Date
    Nov 2009
    Location
    North Vancouver
    Beans
    Hidden!
    Distro
    Edubuntu 14.04 Trusty Tahr

    Re: Monitor goes to sleep during installation

    OK don't forget to hit CTRL+X to boot once you've edited in place. Hitting ESC will lose the changes.

    For your wireless, check out the Networking & Wireless subforum. They have some stickies and knowledgeable users to help out.

  9. #9
    Join Date
    Jun 2010
    Beans
    8

    Re: Monitor goes to sleep during installation

    this works great, except i always have to enter nomodeset after quiet splash every single time i boot up until i get the graphics and wireless under control.

  10. #10
    Join Date
    Nov 2009
    Location
    North Vancouver
    Beans
    Hidden!
    Distro
    Edubuntu 14.04 Trusty Tahr

    Re: Monitor goes to sleep during installation

    Quote Originally Posted by ty10r View Post
    this works great, except i always have to enter nomodeset after quiet splash every single time i boot up until i get the graphics and wireless under control.
    You can make it permanent until you resolve your graphics...
    Code:
    sudo cp /etc/default/grub /etc/default/grub_backup
    gksudo gedit /etc/default/grub
    Add nomodeset after quiet splash as follows:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"
    Update your grub menu to pull in the new default:
    Code:
    sudo update-grub
    Just do the reverse to remove it.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •