Page 3 of 115 FirstFirst 123451353103 ... LastLast
Results 21 to 30 of 1141

Thread: HOW TO Set Up the Bamboo Pen & Touch in Lucid

  1. #21
    Join Date
    Nov 2007
    Location
    New Zealand
    Beans
    1,224
    Distro
    Ubuntu Development Release

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Right,Progress.... 1 & 2 now run with no errors and the tablet is recognised and has some functionality.

    I am a little confused by... '3)configuration.'

    Here is what I think I am being asked to do, please correct me otherwise.

    1)replace 10-wacom.conf with the 50-wacom.conf from http://linuxwacom.git.sourceforge.ne...m.conf;hb=HEAD

    2)download and extract your script, rename, move and chmod it. etc etc.

    and from there,after a reboot, I should have enhanced functionality ?

    do I need to edit the script before using it or do I play with it later (if at all ?) ?

    I have a Bamboo Fun (CTH661) and xinput --list seems to match the script for id's though not the lines in blue.(yeah, no experience with scripts at all)

    Cheers, Bob.

  2. #22
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    1)replace 10-wacom.conf with the 50-wacom.conf from http://linuxwacom.git.sourceforge.ne...m.conf;hb=HEAD
    No, you shouldn't have to do anything. I'm just showing what's going on and where it's at. And also showing you you could use xorg.conf if you wanted to. You should be able to skip III. and go onto the script.

    You want to run 'xinput --list' in a terminal and from the output get your "Device names" and ID numbers (if they are different) and substitute one or the other for the ID numbers in the xsetwacom commands. Blue lines are lines commented out (#). Usually because they are comments.

  3. #23
    Join Date
    Apr 2007
    Beans
    170

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    This is getting me down

    I have a Bamboo Pen and it was working fine until the most recent kernel update. Now, I have Lucid with Linux version 2.6.32-23-generic and X.Org X Server 1.7.6

    I rebuilt my linuxwacom-0.8.7-2 and rebooted. the table light didn't light up. So, got the newer linuxwacom-0.8.8-4 and built that. Again, no light. And lsmod shows no wacom module. Doing a lsmod wacom doesn't help

    I'd like to get this working again ... help, please.

    Pity this can't be automagically updated somehow along with the kernel updates.

    Thanks. ... and yes, I'm appreciative and thank you for the work which as been done!

  4. #24
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    First try 'sudo depmod -a' and rebooting. If that doesn't work add 'wacom' without the quotes to the bottom of the modules file list in /etc/:
    Code:
    gksudo gedit /etc/modules
    and reboot.

  5. #25
    Join Date
    Nov 2007
    Location
    New Zealand
    Beans
    1,224
    Distro
    Ubuntu Development Release

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    O.K all done, seems most things are working though I have to agree with earlier posters about touch being poor.
    It is laggy and stops after a moment or two. Any fast action stops it immediately.

    Interestingly after I had run step 1 I tried touch and it was fine for movement.

    After step 2 it became slow/erratic and has not improved.

    I ran all the commands in step 2 from top to bottom.
    Were some for other options, should I have not run all of them ?

    Cheers, Bob

  6. #26
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Hi Bob,

    Let me know how touch is after a few reboots. Out of curiousity did you run:
    Code:
    sudo apt-get build-dep xf86-input-wacom
    when you did II.?

  7. #27
    Join Date
    Apr 2007
    Beans
    170

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Not sure if the "depmod -a" was directed at me ... but I tried that and adding wacom to the /etc/modules.

    Neither helped.

    I did re-plug the tablet and that brought the light back on. Also, I see (after the replug) that the light goes off/on during boot.

    But, still, it doesn't work. Oh, and it is found:

    lsusb
    Bus 002 Device 002: ID 04b8:011d Seiko Epson Corp. Perfection 1260 Photo
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 006: ID 056a:00d4 Wacom Co., Ltd

    ....

    Any other ideas/suggestion or what I can do?

  8. #28
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Hi BobvanderPoel,

    Yes, the depmod was for you. Delete linuxwacom 0.8.8-4 and redo I. You may have the "bad" version of 0.8.8-4, fixed this afternoon.

  9. #29
    Join Date
    Nov 2007
    Location
    New Zealand
    Beans
    1,224
    Distro
    Ubuntu Development Release

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Quote Originally Posted by Favux View Post
    Hi Bob,

    Let me know how touch is after a few reboots.
    OK will check in tomorrow and report.

    Out of curiousity did you run:
    Code:
    sudo apt-get build-dep xf86-input-wacom
    when you did II.?
    Yes.

    a whole heap of thanks for your continued and unstinting efforts !

    Such dedication in the face of our general noobish and grumpy ways deserves a medal.

  10. #30
    Join Date
    Apr 2007
    Beans
    170

    Re: HOW TO Set Up the Bamboo Pen & Touch in Lucid

    Quote Originally Posted by Favux View Post
    Hi BobvanderPoel,

    Yes, the depmod was for you. Delete linuxwacom 0.8.8-4 and redo I. You may have the "bad" version of 0.8.8-4, fixed this afternoon.
    Yeah, too many "bobs" around

    I grabbed 0.8.8-4 again and did the dance:

    ./configure --enable-wacom
    sudo make install

    But, I think the problem is that the kernel module is not being installed. Checked my directory /lib/modules/2.6.32-23-generic/kernel/drivers/input/tablet and it has drivers with old timestamps:

    -rw-r--r-- 1 root root 8516 2010-06-11 05:54 acecad.ko
    -rw-r--r-- 1 root root 25384 2010-06-11 05:54 aiptek.ko
    -rw-r--r-- 1 root root 12964 2010-06-11 05:54 gtco.ko
    -rw-r--r-- 1 root root 8424 2010-06-11 05:54 kbtab.ko
    -rw-r--r-- 1 root root 38496 2010-06-11 05:54 wacom.ko

    So, I went back to the tarball dir and decided to hit things with a brick:

    [09:51 AM ~/Downloads/linuxwacom-0.8.8-4/src/2.6.30] bob$ make clean
    rm -rf *.o *.ko *.mod.* .[a-z]* core *.i


    [09:51 AM ~/Downloads/linuxwacom-0.8.8-4/src/2.6.30] bob$ make
    Building linuxwacom drivers for 2.6 kernel.
    ***Note: Drivers not enabled as modules in your kernel config but requested through configure are NOT built
    make -C /lib/modules/2.6.32-23-generic/build M=/home/bob/Downloads/linuxwacom-0.8.8-4/src/2.6.30
    make[1]: Entering directory `/usr/src/linux-headers-2.6.32-23-generic'
    LD /home/bob/Downloads/linuxwacom-0.8.8-4/src/2.6.30/built-in.o
    CC [M] /home/bob/Downloads/linuxwacom-0.8.8-4/src/2.6.30/wacom_wac.o
    CC [M] /home/bob/Downloads/linuxwacom-0.8.8-4/src/2.6.30/wacom_sys.o
    LD [M] /home/bob/Downloads/linuxwacom-0.8.8-4/src/2.6.30/wacom.o
    Building modules, stage 2.
    MODPOST 1 modules
    CC /home/bob/Downloads/linuxwacom-0.8.8-4/src/2.6.30/wacom.mod.o
    LD [M] /home/bob/Downloads/linuxwacom-0.8.8-4/src/2.6.30/wacom.ko
    make[1]: Leaving directory `/usr/src/linux-headers-2.6.32-23-generic'

    [09:51 AM ~/Downloads/linuxwacom-0.8.8-4/src/2.6.30] bob$ sudo make install
    make: Nothing to be done for `install'.

    So ... for some reason the modules are being created, but not installed????

    Did I do my original configure incorrectly?

Page 3 of 115 FirstFirst 123451353103 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •