I apologize in advance if this has been covered elsewhere. Sometimes I'm good at google, sometimes not so much.

I have a Macbook 5,1 and I run funtoo on it. I like to tweak things, which means that I break them on occasion. I've found that the Ubuntu Live CDs are pretty good for going in and fixing what I broke. This last time, I found out that gcc4.5 and grub2 don't get along. I could have discovered this via the gentoo forums, but I have to do things the hard way on occasion.

(To make it relevant to the forums, I am posting from the Ubuntu LiveCD, that I'll only get to use once before it is fodder for the trash compactor )

Anyway, here's the problem that I ran into, and it is not unique to the Ubuntu LiveCD, this happens for *any* LInux live cd: I can burn a bootable CD-ROM, from OS X, restart while holding down the 'C' key and it boots from the CD. After that, once I shut down, I cannot get the darned thing to recognize anything on the CD again. I can start up in OSX and insert the CD and it complains about a blank CD being inserted. I can reboot while holding down the 'C' key and it hangs for a while, then goes to the rEFIt menu like the CD is useless. I get one and exactly one boot from the CD, then the (^(&(&*)*&%$$* computer flat out refuses to recognize it. It makes me want to punt a kitten.