Results 1 to 6 of 6

Thread: gtk-recordMyDesktop not recording system sound

  1. #1
    Join Date
    Oct 2007
    Location
    wrong planet
    Beans
    746
    Distro
    Ubuntu 9.10 Karmic Koala

    gtk-recordMyDesktop not recording system sound

    I've been trying to make screencast, but I also want it to capture the sound coming from the computer; In other words, I do not mean the microphone. I tried changing the sound device from DEFAULT to pulse with no avail. Please somebody tell me how I can do it.
    Linux Advanced Guides and News!
    http://linuxinnovations.blogspot.com/

    Green means go, Yellow means faster, Red means don't stop.

  2. #2
    Join Date
    Sep 2006
    Beans
    548

    Re: gtk-recordMyDesktop not recording system sound

    Use this instead http://ubuntuforums.org/showthread.php?t=1392026

    I haven't touched recordmydesktop ever again.

  3. #3
    Join Date
    Nov 2007
    Location
    Homo cave
    Beans
    88
    Distro
    Ubuntu Studio 10.10 Maverick Meerkat

    Re: gtk-recordMyDesktop not recording system sound

    ALSA doesn't have the right kind of loopback stuff (without additional config files) as far as I'm aware of, but if you have PulseAudio you can fidget the recording source from the PulseAudio Volume Control from "Foo" to "Monitor of Foo" from some dropdown menu.

  4. #4
    Join Date
    Jan 2006
    Location
    At Home
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: gtk-recordMyDesktop not recording system sound

    You can record everything that comes out of the speaker using recordmydesktop and pulse.

    In recordmydesktop I changed the Advanced>Sound>Device name from 'DEFAULT' to 'default'.
    Then I installed pavucontrol using
    Code:
    sudo apt-get install pavucontrol
    Run pavucontrol and go to the recording tab while recordmydesktop is actively recording something, you will see an item called
    "ALSA plug-in[recordmydesktop]:ALSA capture from"
    You must change this to Monitor of Internal Audio Analog Stereo

    Best Regards,
    Will

  5. #5
    Join Date
    Feb 2006
    Location
    Kentucky
    Beans
    571
    Distro
    Ubuntu

    Re: gtk-recordMyDesktop not recording system sound

    Quote Originally Posted by williamts99 View Post
    You can record everything that comes out of the speaker using recordmydesktop and pulse.

    In recordmydesktop I changed the Advanced>Sound>Device name from 'DEFAULT' to 'default'.
    Then I installed pavucontrol using
    Code:
    sudo apt-get install pavucontrol
    Run pavucontrol and go to the recording tab while recordmydesktop is actively recording something, you will see an item called
    "ALSA plug-in[recordmydesktop]:ALSA capture from"
    You must change this to Monitor of Internal Audio Analog Stereo

    Best Regards,
    Will
    Thanks, this really helped me out with my issue.
    "Civilization is the limitless multiplication of unnecessary necessities."
    -- Mark Twain

  6. #6
    Join Date
    Dec 2010
    Beans
    35

    Re: gtk-recordMyDesktop not recording system sound

    Quote Originally Posted by williamts99 View Post
    You can record everything that comes out of the speaker using recordmydesktop and pulse.

    In recordmydesktop I changed the Advanced>Sound>Device name from 'DEFAULT' to 'default'.
    Then I installed pavucontrol using
    Code:
    sudo apt-get install pavucontrol
    Run pavucontrol and go to the recording tab while recordmydesktop is actively recording something, you will see an item called
    "ALSA plug-in[recordmydesktop]:ALSA capture from"
    You must change this to Monitor of Internal Audio Analog Stereo

    Best Regards,
    Will
    YES, This fixed my issue too, i noticed using kazam there were two options for sound recording and i was looking for this option with gtk-RMD, I did not know about PavControl, Excellent fix and i am running 12.04 64bit. RMD is working again, Thanks Will

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •