Results 1 to 6 of 6

Thread: USB Flashdrive not mounted

  1. #1
    Join Date
    Mar 2007
    Beans
    52

    USB Flashdrive not mounted

    Hi,

    I've installed Ubuntu 10.04 on my dad's computer, to prove Linux is ****ing awesome. He's quite happy, there's only thing that annoys him a lot: USB harddrives/flashsticks don't work properly. In some rare occasions an USB stick mounts itself automaticly, but in most cases it just doesn't do anything. They do show up when using the lsusb command, they don't show up in nautlis under locations.

    When using the fdisk -l, it shows the partition table of the main harddisk, then the program takes a coffeebreak, and after a few minutes he finally gives /dev/sdb1 as the USB flashdrive.

    When trying to mount it manually, using mount /dev/sdb1 it takes a few minutes and after a while it gives the error:
    Error mounting: mount: /dev/sdb1: can't read superblock

    Things I tried:
    Installing pmount and libpmount0.0, I think this actually did improve the situation a bit, as it now actually gives an error message, and sometimes a usb flashdrive actually does get mounted.

    I also removed HAL, but nothing changed. I've also checked if floppy drive was enabled in BIOS, but couldn't find anything that would lead to such setting..

    And now, I'm stuck. Is it a hardware problem? I've connected an USB mouse and keyboard, and they both work properly, and my USB connected printer also.. What could be the problem?

  2. #2
    Join Date
    Feb 2006
    Beans
    16

    Re: USB Flashdrive not mounted

    i have the same problem except i'm trying a USB drive in my laptop. my usb mouse works fine also.

  3. #3
    Join Date
    Aug 2009
    Location
    United States
    Beans
    4,460
    Distro
    Ubuntu Development Release

    Re: USB Flashdrive not mounted

    Give the drive a label in disk utility or gparted and lets say karmic for a label, use what you want. And the partition is sdb1. Use your own again.

    last letter small L
    Code:
    sudo fdisk -l
    second letter small L gives you label names
    Code:
    sudo blkid
    Code:
    sudo mkdir /media/karmic
    Code:
    sudo mount /dev/sdb1 /media/karmic
    Code:
    sudo umount /media/karmic
    Should now mount after mount command, to automount. Make sure in Configuration editor.
    Go to apps to nautilus to preferences and make sure media auto mount is checked.
    If cannot find. Will be Under Applications/System Tools
    Code:
    sudo apt-get install gconf-editor
    Hope this helps you.
    Last edited by garvinrick4; June 11th, 2010 at 11:56 PM.
    Remember hence where you come and pass it down.
    Ubuntu Forums member #899097 and Ubuntu Member:
    http://www.ubuntupocketguide.com/index_main.html
    Main Page -

  4. #4
    Join Date
    Mar 2007
    Beans
    52

    Re: USB Flashdrive not mounted

    Quote Originally Posted by garvinrick4 View Post
    Give the drive a label in disk utility or gparted and lets say karmic for a label, use what you want. And the partition is sdb1. Use your own again.

    last letter small L
    Code:
    sudo fdisk -l
    second letter small L gives you label names
    Code:
    sudo blkid
    Code:
    sudo mkdir /media/karmic
    Code:
    sudo mount /dev/sdb1 /media/karmic
    Code:
    sudo umount /media/karmic
    Should now mount after mount command, to automount. Make sure in Configuration editor.
    Go to apps to nautilus to preferences and make sure media auto mount is checked.
    If cannot find. Will be Under Applications/System Tools
    Code:
    sudo apt-get install gconf-editor
    Hope this helps you.
    I already tried most of these things, mounting doesn't work, it takes some time, and then gives an error, although there's one USB stick I formatted with ubuntu, which actually does get recognized by nautilus (it shows up under locations), and when I click on it, it mounts. But all other USB disks don't work. And I don't want to format all USB sticks first.

    The configuration of nautilus is also OK.

  5. #5
    Join Date
    Aug 2009
    Location
    United States
    Beans
    4,460
    Distro
    Ubuntu Development Release

    Re: USB Flashdrive not mounted

    All my USB flash drives are formatted in Fat32. Windows and Linux can read them both.
    If you even want a partition that both can read use Fat32 will show up in windows as a F: drive or some letter and will show up as what you label it in Linux say DATA or something like that. If you dual boot between the two nice to have a partition to hold items you want to have in both installs. Can exist as logical inside of a extended so do not have to take up a primary.
    Remember hence where you come and pass it down.
    Ubuntu Forums member #899097 and Ubuntu Member:
    http://www.ubuntupocketguide.com/index_main.html
    Main Page -

  6. #6
    Join Date
    Mar 2007
    Beans
    52

    Re: USB Flashdrive not mounted

    Yeah I know, fat32 is supported by ubuntu, but somehow they don't want to mount, they do show up at fdisk -l, lsusb, but mounting: not a chance. When I connect my HTC Hero Phone (the sd card partitioned as ext2 + fat32 (used for apps2sd)), nothing happens. It shows up at lsusb, but this time, even fdisk -l doesn't show the sd card partitions. And nautilus doesn't show any location to the phone..

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •