Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: nm-applet icon missing from panel

  1. #1
    Join Date
    Jul 2006
    Beans
    Hidden!

    nm-applet icon missing from panel

    The nm-applet icon is missing from the panel. Right-clicking on System->Preferences->Network Connections, then adding that to the panel gives a workaround, but it's not nearly as informative or easy to use. The command "killall nm-applet && nm-applet &" runs without error, but does not restore the icon. Calling "nm-applet --sm-disable" doesn't help, either. The workaround suggested in this bug report does not restore it, nor do any of the other icons appear confused, so I don't think it's that bug. This is happening after a reinstall (but /home was unchanged) and is happening with freshly-created accounts. Any other suggestions?
    Last edited by fivebells; June 10th, 2010 at 10:12 PM.

  2. #2
    Join Date
    Aug 2006
    Beans
    12,973
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: nm-applet icon missing from panel

    Try adding the notification area to the panel.

  3. #3
    Join Date
    Jul 2006
    Beans
    Hidden!

    Re: nm-applet icon missing from panel

    Thank you; that worked.

  4. #4
    Join Date
    Dec 2008
    Beans
    46
    Distro
    Kubuntu Development Release

    Re: nm-applet icon missing from panel

    I got in my hands one system where this didn't worked. For it, restarting the NetworkManager service did work.

    $ sudo service network-manager stop
    $ sudo service network-manager start

    The icon is there, it only doesn't display anything. These commands force the nm-applet icon to update itself.

  5. #5
    Join Date
    Sep 2009
    Location
    Monterrey, México
    Beans
    7
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Lightbulb Re: nm-applet icon missing from panel

    I had apparently the same problem, I tryed everithigng you've suggested with no luck.

    I have a bunch of users in this machine.

    I've prevoiusly checked the "Available to all users" checkbox for all the wireless networks I use.

    After 2 months I've got my problem solved:

    All I need to do to fix the missing nm-applet was1.- Login as your first user
    2.- Go to Edit Network Connections-
    3.- Select your first network
    4.- Click the Edit button
    5.- Unckeck the "Available to all users"
    6.- Click Apply
    7.- Repeat for all connections
    8.- Repeat for all users
    Hope this can save you some time!


    Fernando Murrieta

  6. #6
    Join Date
    Jun 2005
    Beans
    77

    Exclamation Re: nm-applet icon missing from panel

    Alejandro & Fernando:

    I've tried both of your suggestions - neither of them work for me. I also tried completely uninstalling and re-installing network-manager and network-manager-gnome.

    None of this changed the fact that there is no icon to pick to add to the top Panel. And running `nm-applet` doesn't cause any graphical configuration screen to come up nor appear on the panel.

    As far as this thread is concerned it should be marked NOT solved.

    I continue to try to resolve this...

  7. #7
    Join Date
    Sep 2010
    Beans
    1

    Smile Re: nm-applet icon missing from panel

    I also encountered this problem, and troubled me several months, but today I found the solution
    so simple, and it works.
    I wish it will help you.

    Here is the steps :
    1 : just right click on your panel.
    2 : choose " Add to Panel..."
    3 : select " Notification Area"
    4 : add it.
    5 : and magic comes.

    Try it !
    God bless you !

  8. #8
    Join Date
    Feb 2009
    Beans
    2

    Re: nm-applet icon missing from panel

    Thank you, dsw1007... this did the trick!

  9. #9
    Join Date
    May 2011
    Beans
    1

    Re: nm-applet icon missing from panel

    Quote Originally Posted by fmurrieta View Post
    I had apparently the same problem, I tryed everithigng you've suggested with no luck.

    I have a bunch of users in this machine.

    I've prevoiusly checked the "Available to all users" checkbox for all the wireless networks I use.

    After 2 months I've got my problem solved:

    All I need to do to fix the missing nm-applet was1.- Login as your first user
    2.- Go to Edit Network Connections-
    3.- Select your first network
    4.- Click the Edit button
    5.- Unckeck the "Available to all users"
    6.- Click Apply
    7.- Repeat for all connections
    8.- Repeat for all users
    Hope this can save you some time!


    Fernando Murrieta
    many thanks to fmurrieta.
    my problem is the same thing, some "Available to all users" network made the nm-applet icon missing.
    I cant see the network in network setting dialog, so I can't Unckeck the "Available to all users", but I find the setting config file in /etc/NetworkManager/system-connections/ , I removed all the config file in this directory and reboot, then the nm-applet icon go back.

  10. #10
    Join Date
    Oct 2010
    Location
    Izumi,Japan
    Beans
    77
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: nm-applet icon missing from panel

    Quote Originally Posted by dsw1007 View Post
    I also encountered this problem, and troubled me several months, but today I found the solution
    so simple, and it works.
    I wish it will help you.

    Here is the steps :
    1 : just right click on your panel.
    2 : choose " Add to Panel..."
    3 : select " Notification Area"
    4 : add it.
    5 : and magic comes.

    Try it !
    God bless you !
    Thank you,it worked.....

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •