Results 1 to 2 of 2

Thread: VIA/S3 Graphics issues - Anyone have it working?

  1. #1
    Join Date
    Mar 2006
    United Kingdom
    Ubuntu 10.04 Lucid Lynx

    VIA/S3 Graphics issues - Anyone have it working?

    Hello Everyone,

    Well, I have yet another convert to Linux, but he has presented me with challenge.

    He has asked me to install Ubuntu 10.04 on his laptop this weekend. I looked at his laptop at lunch the other day, and found that this laptop is a 4 or 5 year old Packard Bell with a Celeron M 1.4Ghz and 1GB ram. This is plenty to run 10.04, but I tried a live CD and graphics was garbled and it never arrived at a desktop. Turns out the graphics in this laptop have a VIA/S3 graphics chipset which I have never been confronted with. I tried Knoppix with the Vesa driver and it did get to a desktop, but obviously graphics were terrible.

    I have done some preliminary research before I attempt this and it seems that this chipset uses the openchrome open source driver.

    My question is for anyone who has ever attempted Ubuntu with this graphics chipset. What were your results and what can I expect? Can someone offer me a solution in advance of trying this?

    Thanks in advance for any replies
    I used to be very indecisive, but now I am not so sure.

  2. #2
    Join Date
    Nov 2012

    Post Re: VIA/S3 Graphics issues - Anyone have it working?

    I experience the same problem. But i get solve installing ubuntu 8.0 LTS using safe graphics mode.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts