Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: cannot move to trash on auto mounted NTFS partition?

  1. #1
    Join Date
    Jun 2009
    Location
    Edinburgh, Scotland
    Beans
    545
    Distro
    Ubuntu 12.04 Precise Pangolin

    cannot move to trash on auto mounted NTFS partition?

    How can I set it so I can move files to trash (not completely delete) on my automatically mounted NTFS partition? It's a shared partition between Windows and Linux, and I don't understand why I can move files to the trash on my external NTFS drives, but not my internal, automatically mounted one. Here's the relevant entry from /etc/fstab:
    Code:
    /dev/sda3 /home/user/shared    ntfs    defauls,noatime 0 0
    /home/user/shared exists, I have sudo rights, etc.

  2. #2
    Join Date
    Jan 2007
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: cannot move to trash on auto mounted NTFS partition?

    Try adding this option to the line, "uid=1000", assuming you are the original user. If not, use the "id" command to find your uid number.
    /dev/sda3 /home/user/shared ntfs defauls,uid=1000,noatime 0 0

    This will make you the owner and should create a .Trash-1000 folder where deleted files will be placed. I've not placed a mountpoint where you have but I assume it would work the same way there.

    Once you have saved the fstab file, umount and remount the partition.
    Code:
    sudo umount /dev/sda3 && sudo mount -a
    Back to Xorg...

    Retired.

  3. #3
    Join Date
    Jun 2009
    Location
    Edinburgh, Scotland
    Beans
    545
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: cannot move to trash on auto mounted NTFS partition?

    That worked flawlessly. Thank you!

  4. #4
    Join Date
    Jun 2008
    Beans
    29

    Re: cannot move to trash on auto mounted NTFS partition?

    Hi, I have a huge problem, I just tried this fix, but accidentally lost my NTFS drives UUID, and now am unable to mount the drive altogether! I am pretty sure I copied the UUID before I replaced it with 1000, but apparently didn't.

    HOW DO I FIX IT!? Any help would be amazing, this is probably the worst I've messed up my system, because my desktop is located on the other partition that I don't have access to, I cannot open ANY file or folder with nautilus.

    I opened Gparted and got the UUID from there, and posted it back into my fstab with gedit, but it didnt work! and im afraid to shut down just in case it wont boot up again or something...

    here is my fstab file contents.

    Code:
    # /etc/fstab: static file system information.
    #
    # <file system> <mount point>   <type>  <options>       <dump>  <pass>
    
    proc	/proc	proc	nodev,noexec,nosuid	0	0
    #Entry for /dev/sda3 :
    UUID=052a5338-47c3-4224-9120-9c078962c42e	/	ext3	errors=remount-ro	0	1
    #Entry for /dev/sda4 :
    UUID=116F76BF59B32A05	/media/Storage	ntfs-3g	defaults,nosuid,nodev,locale=en_US.utf8	0	0
    
    
    /dev/sda1     /mnt/mypartition    ntfs-3g	defaults,nosuid,nodev,locale=en_US.utf8	0	0
    
    /dev/sda2     /mnt/mypartition    ntfs-3g	defaults,nosuid,nodev,locale=en_US.utf8	0	0

    P.S. it is for my drive sd4, the one labelled "storage"

  5. #5
    Join Date
    Jun 2009
    Location
    Edinburgh, Scotland
    Beans
    545
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: cannot move to trash on auto mounted NTFS partition?

    Try posting this in a new thread; since I've marked this thread Solved (since the original post is solved) a lot of people will pass over it. I would highly recommend starting a new thread with the same description of the problem. Since your post isn't completely related either it's also a good idea.

    You can see the UUIDs of all your partitions by running
    Code:
    sudo blkid
    from the terminal. Its output should set you in the right direction for getting the UUIDs.

  6. #6
    Join Date
    Jun 2008
    Beans
    29

    Re: cannot move to trash on auto mounted NTFS partition?

    you know what, thank you so much! after getting the UUID from gparted, all and pasting it back into fstab, all i had to do was restart... whew. i was just scared of doing that a bit, i freaked out haha, but yeah, thanks for the really quick response, its nice to know that we have some good support here in the forums.

  7. #7
    Join Date
    Sep 2010
    Beans
    1

    Re: cannot move to trash on auto mounted NTFS partition?

    HI
    I had the same problem, could not move files to trash on my ntfs partition. Now this is solved but only partially. I can move files I want tot delete to trash but they do not appear in the Trash from the panel, only in .Trash-1000 folder from the ntfs partition. Anybody knows why ?

  8. #8
    Join Date
    Dec 2010
    Beans
    5

    uid=1000 is good for me !

    Quote Originally Posted by drs305 View Post
    Try adding this option to the line, "uid=1000", assuming you are the original user. If not, use the "id" command to find your uid number.



    This will make you the owner and should create a .Trash-1000 folder where deleted files will be placed. I've not placed a mountpoint where you have but I assume it would work the same way there.

    Once you have saved the fstab file, umount and remount the partition.
    Code:
    sudo umount /dev/sda3 && sudo mount -a

    Excellent !!! adding uid=1000 solved my problem.

  9. #9
    Join Date
    Jun 2007
    Location
    Perth - OZ
    Beans
    101
    Distro
    Ubuntu 18.04 Bionic Beaver

    Re: cannot move to trash on auto mounted NTFS partition?

    that was not enough for me to be able to move files to trash.
    I had also to add the group id
    Code:
    UUID=0A046CF41C7164C6 /media/Data ntfs defauls,uid=1000,gid=1000,noatime 0 0
    because when I was checking the files properties with ls -ls I had that the group was still root, by mounting with the gid as well also the group was at my username.

    Note: in my fstab line I use the mounting of the drive by UUID that seems to be more robust than mounting by location like /dev/sda#

    hope it helps
    Ubuntu 18.04 64 bit -> transitioning to 20.04

  10. #10
    Join Date
    Oct 2006
    Beans
    4

    Re: cannot move to trash on auto mounted NTFS partition?

    Quote Originally Posted by drs305 View Post
    Try adding this option to the line, "uid=1000", assuming you are the original user. If not, use the "id" command to find your uid number.



    This will make you the owner and should create a .Trash-1000 folder where deleted files will be placed. I've not placed a mountpoint where you have but I assume it would work the same way there.

    Once you have saved the fstab file, umount and remount the partition.
    Code:
    sudo umount /dev/sda3 && sudo mount -a
    thank you very mouch...
    its works now...

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •