Page 2 of 2 FirstFirst 12
Results 11 to 20 of 20

Thread: Your preferences can not be read

  1. #11
    Join Date
    Aug 2010
    Beans
    4

    Re: Your preferences can not be read

    Just resetting all of the ownership might be simpler and safe.
    cd ~/.config
    chown -R <user>:<user> google-chrome

    This way file names are not a problem and in the future other files effected will be changed.

    For me it looks like I had somehow run chrome as a root process but without changing my environment so chrome touched my files as a root process changing the ownership to root.

  2. #12
    Join Date
    Nov 2010
    Location
    London, WWW, Universe.
    Beans
    5
    Distro
    Ubuntu 11.04 Natty Narwhal

    Smile Re: Your preferences can not be read

    A HUGE Thank you to the contributors to this thread

    I had also run google-chrome as root

    In my case I found that a slight variation of the above post was needed as I got...

    chown: changing ownership of `./google-chrome/Local State': Operation not permitted
    chown: changing ownership of `./google-chrome/Default/Preferences': Operation not permitted

    Code:
    myusername@homer-laptop:~$ cd .config
    myusername@homer-laptop:~/.config$ sudo chown -cR myusername:myusername .
    [sudo] password for myusername: 
    changed ownership of `./google-chrome/Local State' to myusername:myusername
    changed ownership of `./google-chrome/Default/Preferences' to myusername:myusername
    It worked for me

    I hope that helps somebody else.

  3. #13
    Join Date
    Nov 2010
    Beans
    1

    Re: Your preferences can not be read

    Code:

    cd .config
    sudo chown -cR username:username .

    Worked for me! Thank you! My problem is solved

  4. #14
    Join Date
    Aug 2007
    Location
    Barbacena, Brazil
    Beans
    5
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Exclamation Re: Your preferences can not be read

    I had the same problem...this worked for me.

    Code:
    cd ~
    cd .config/google-chrome
    sudo chown <your user name>:<your user name> 'Local State'
    sudo chown <your user name>:<your user name> Default/Preferences
    Thanks

  5. #15
    Join Date
    Feb 2009
    Beans
    114

    Re: Your preferences can not be read

    Thanks this fixed the problem
    but what I want to know what 'CAUSED' the problem to happen in the first place?

    any ideas - ive been having lots of problems with google chrome randomly crashing and wonder if this is related?

  6. #16
    Join Date
    Oct 2007
    Location
    Syracuse
    Beans
    502
    Distro
    Ubuntu Studio 13.10 Saucy Salamander

    Re: Your preferences can not be read

    Quote Originally Posted by complience View Post
    Thanks this fixed the problem
    but what I want to know what 'CAUSED' the problem to happen in the first place?

    any ideas - ive been having lots of problems with google chrome randomly crashing and wonder if this is related?
    I just ran into this problem again I don't remember what happened last time. However, this time I'm almost positive it happened because I ran Chromium (the open source version of Chrome) as root. I ran Chromium as root because I was doing some trouble shooting the other day and I needed root privileges to get a full bug report from Bug Buddy. I have been having problems with watching flash videos on youtube but not videos using WebM. However, I'm not having any problems playing flash videos on Hulu or Fancast.

    I just tried running Chromium as root again to make sure it was the cause and I got some interesting errors I just wish I knew what they meant.
    Code:
    ~/.config$ sudo chromium-browser %U
    [8304:8304:23331825319:ERROR:extension_prefs.cc(734)] Bad or missing pref 'state' for extension 'hpibmhghjndideebpackbdlpncgkcppp'
    [8304:8304:23331825395:ERROR:extension_prefs.cc(734)] Bad or missing pref 'state' for extension 'lncjcfkpannmofmpgdfoonkniofdnaba'
    I then opened Chromium and got the "Your preferences can not be read" message again. So for me at least this problem was caused by running Chromium as root.

    To fix it I used
    Code:
    ~/.config$ sudo chown -cR myusername:myusername chromium 
    changed ownership of `chromium/Default/Preferences' to myusername:myusername
    changed ownership of `chromium/Default/Last Session' to myusername:myusername
    changed ownership of `chromium/Default/Last Tabs' to myusername:myusername
    changed ownership of `chromium/Local State' to myusername:myusername
    What's interesting is that I had not seen the following output when I used the same command a few minuets again.
    Code:
    changed ownership of `chromium/Default/Last Session' to myusername:myusername
    changed ownership of `chromium/Default/Last Tabs' to myusername:myusername
    This should confirm
    Quote Originally Posted by esoniat View Post
    For me it looks like I had somehow run chrome as a root process but without changing my environment so chrome touched my files as a root process changing the ownership to root.

  7. #17
    Join Date
    Dec 2007
    Beans
    2

    Re: Your preferences can not be read

    I had a very similar problem. I got the same error pop-up, but twice in a row. In my case, for some reason, trying the chown solution didn't work, but purging google-chrome (and replacing it with google-chrome-stable) did. I also did do an:

    rm -R -f /home/<your user name>/.config/google-chrome

  8. #18
    Join Date
    Apr 2011
    Beans
    1

    Re: Your preferences can not be read

    The following error shows up when I first start Chromium 10.0.648.133 (77742) under Ubuntu 10.04.

    "Your preferences can not be read.

    Some features may be unavailable and changes to preferences won't be saved."



    Many thanks to metalf8801 and his post above. This solved my problem, and just in the nick of time. I was about to jump ship on the Chromium browser altogether, but happened to cross this thread as a last ditch attempt. I had tried many other posts and used their syntax, but none of them worked for me. Here is what I used and it worked for me:

    cd ~/.config$
    sudo chown -cR myusername:myusername chromium

    *Of course you must substitute <yourusername> above.

    Sorry if I'm making this child proof, but you know how it is.

    Again, all the credit goes to metalf8801 for this one. This experience has renewed my faith in the Ubuntu forum and its community of users. Thanks again.
    Last edited by platanofrito; April 6th, 2011 at 06:10 PM.

  9. #19
    Join Date
    Jan 2010
    Location
    India
    Beans
    42
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Smile Re: Your preferences can not be read

    Quote Originally Posted by dexlavis View Post
    As explained here: http://ahmadzz.wordpress.com/2010/05...-chrome-error/, you might not have to delete files to fix this, because the files

    /home/<user>/.config/google-chrome/Local State
    /home/<user>/.config/google-chrome/Default/Preferences

    might have had their owner changed for some reason. (<user> being your login name).

    Open a terminal and change it back like so:
    Code:
    cd ~
    cd .config/google-chrome
    sudo chown <user>:<user> Local\ State
    sudo chown <user>:<user> Default/Preferences
    Done. Worked for me.
    Thanks a lot!! Worked for me too!!

  10. #20
    Join Date
    Sep 2007
    Beans
    66

    Re: Your preferences can not be read

    I am using Chromium from Ubuntu Software Center on Ubuntu 11.04

    cd /home/USERNAME/.config
    sudo chown -R username:username chromium

    Username being the user that I am logged in as.
    This worked for me.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •