Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: Your preferences can not be read

  1. #1
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Beans
    1,044
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Your preferences can not be read

    When I open Google Chrome, it says "Your preferences can not be read.Some features may be unavailable and changes to preferences won't be saved."

    How do I fix this? Thanks.
    Best thing that ever happened to me on Ubuntu Forums: http://i.imgur.com/itEJe.png

  2. #2
    Join Date
    Feb 2008
    Beans
    5,636

    Re: Your preferences can not be read

    Go to
    /home/yourusername/.config/chrome/Default/
    and delete the preferences file.
    Next time you open Chrome it will be regenerated, but you will have to reconfigure Chrome (unfortunately).

  3. #3
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Beans
    1,044
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Your preferences can not be read

    Quote Originally Posted by TeoBigusGeekus View Post
    Go to
    /home/yourusername/.config/chrome/Default/
    and delete the preferences file.
    Next time you open Chrome it will be regenerated, but you will have to reconfigure Chrome (unfortunately).
    Thanks!
    Best thing that ever happened to me on Ubuntu Forums: http://i.imgur.com/itEJe.png

  4. #4
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Beans
    1,044
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Your preferences can not be read

    Quote Originally Posted by TeoBigusGeekus View Post
    Go to
    /home/yourusername/.config/chrome/Default/
    and delete the preferences file.
    Next time you open Chrome it will be regenerated, but you will have to reconfigure Chrome (unfortunately).
    It does it still.
    Best thing that ever happened to me on Ubuntu Forums: http://i.imgur.com/itEJe.png

  5. #5
    Join Date
    Feb 2008
    Beans
    5,636

    Re: Your preferences can not be read

    Ok... delete the whole chrome folder.
    If it persists, purge chrome and reinstall it.

  6. #6
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Beans
    1,044
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Your preferences can not be read

    Quote Originally Posted by TeoBigusGeekus View Post
    Ok... delete the whole chrome folder.
    If it persists, purge chrome and reinstall it.
    I removed Chrome and reinstalled it but still the same problem.
    Best thing that ever happened to me on Ubuntu Forums: http://i.imgur.com/itEJe.png

  7. #7
    Join Date
    Feb 2008
    Beans
    5,636

    Re: Your preferences can not be read

    You also have to remove the chrome folder from .config.
    Something must be broken in there.

  8. #8
    Join Date
    Jul 2009
    Location
    Houston, Texas
    Beans
    1,044
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Your preferences can not be read

    Quote Originally Posted by TeoBigusGeekus View Post
    You also have to remove the chrome folder from .config.
    Something must be broken in there.
    Thanks!
    Best thing that ever happened to me on Ubuntu Forums: http://i.imgur.com/itEJe.png

  9. #9
    Join Date
    Jun 2010
    Beans
    1

    Lightbulb Re: Your preferences can not be read

    As explained here: http://ahmadzz.wordpress.com/2010/05...-chrome-error/, you might not have to delete files to fix this, because the files

    /home/<user>/.config/google-chrome/Local State
    /home/<user>/.config/google-chrome/Default/Preferences

    might have had their owner changed for some reason. (<user> being your login name).

    Open a terminal and change it back like so:
    Code:
    cd ~
    cd .config/google-chrome
    sudo chown <user>:<user> Local\ State
    sudo chown <user>:<user> Default/Preferences
    Done. Worked for me.

  10. #10
    Join Date
    Oct 2007
    Location
    Syracuse
    Beans
    504
    Distro
    Ubuntu Studio 13.10 Saucy Salamander

    Re: Your preferences can not be read

    Quote Originally Posted by dexlavis View Post
    As explained here: http://ahmadzz.wordpress.com/2010/05...-chrome-error/, you might not have to delete files to fix this, because the files

    /home/<user>/.config/google-chrome/Local State
    /home/<user>/.config/google-chrome/Default/Preferences

    might have had their owner changed for some reason. (<user> being your login name).

    Open a terminal and change it back like so:
    Code:
    cd ~
    cd .config/google-chrome
    sudo chown <user>:<user> Local\ State
    sudo chown <user>:<user> Default/Preferences
    Done. Worked for me.
    I'm just trying to make this a little clearer
    I think the \ in Local State is a typo and Local State needs to be in quotes because of the space in the file name

    Code:
    cd ~
    cd .config/google-chrome
    sudo chown <your user name>:<your user name> 'Local State'
    sudo chown <your user name>:<your user name> Default/Preferences
    well thats what worked for me
    Thank you dexlavis for finding the solution

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •