Results 1 to 5 of 5

Thread: Dos problemas al actualizar a 10.04

  1. #1
    Join Date
    Jun 2010
    Beans
    6

    Dos problemas al actualizar a 10.04

    Estimados

    Soy nuevo de foro. Al arrancar mi equipo recien actualizado, justo antes de aparecer la pantalla de login, la pantalla me muestra dos errores, luego el ordenador se queda unos 60 segundos colgado, hasta que finalmente arranca, no es un problema crítico, pero es molesto qe tarde tanto en arrancar (incluso mas que con windows xp, qe ya es decir)

    los errores son estos:

    mount: mounting none on /dev failed: No such device
    chroot: cannot execute /etc/apparmor/initramfs: No such file or directory

    Luego es cuando se queda colgado unos 60 segundos para arrancar sin problemas transcurrido ese tiempo.

    ¿alguien ha encontrado la solucion?

    Saludos cordiales

  2. #2
    Join Date
    Jul 2010
    Beans
    1

    Smile Re: Dos problemas al actualizar a 10.04 - Solucionado

    Hola aantinao, te comento que esto funciono para mi;
    Re: removing apparmor
    If you remove it, you need to update your initramfs. I did this:

    1. created custom kernel and got rid of apparmor (optional)

    2. to remove it: Code:
    apt-get purge apparmor
    3. to get rid of config folder: Code:
    rm -rf /etc/apparmor*
    4. to not try to load removed apparmor script: Code:
    update-initramfs -u
    And it was all gone. In your case, you may simply need to do the update-initramfs and that's it. I'd recommend making backups before doing any of these steps!


    Lo saque de aqui, http://georgia.ubuntuforums.org/show....php?p=8456613.

    En cuanto al otro error desaparecio, lo cual no es bueno ya que no saber la causas de una solucion es un problema futuro asegurado, asi que recomiendo hacer:

    unos

    apt-get update
    apt-get dist-upgrade
    apt-get -f install ( recuerden que si por equivocacion instalaron algun paquete raro de otra version este comando los puede tirar a la lona, siempre que lo vean chequee bien que es lo que van a borrar)
    apt-get clean
    apt-get autoclean
    apt-get autoremove


    Espero te/les sirva.

    saludos

  3. #3
    Join Date
    Aug 2006
    Location
    Santiago de Chile
    Beans
    385
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Dos problemas al actualizar a 10.04 - Solucionado

    El directorio /dev contiene los archivos de dispositivos especiales para todos los dispositivos hardware y pienso que no se montan porque apparmor permite al administrador del sistema asociar a cada programa un perfil de seguridad que restrinja las capacidades de ese programa.

    Entonces, si falla al leer las directrices de seguridad (pienso y lo resalto, pues no lo he comprobado) retrasa al sistema en montar los dispositivos de hardware o algún otro proceso posterior (debieras leer los sucesos del sistema)

    En conclusión, como ya decía Ferduz, es muy probable que si solo lo eliminas te de problemas posteriores. Yo creo que debes dirigir la acción, a ver porque no se ejecuta apparmor y tratar de repararlo o purgarlo e instalarlo nuevamente.


    Sobre Initramfs
    es un archivo cpio comprimido en gzip. En el arranque, el núcleo lo descomprime en la RAM, lo monta y lo usa como el sistema de archivo raíz inicial. El montado del sistema de archivo raíz real ocurre en espacio de usuario
    Eso explica por que retrasa el montado de discos.



    Saludos!

    Movido a "Instalación y Actualización"
    Last edited by Patriciologico; August 2nd, 2010 at 10:08 AM. Reason: Agrego informacion de Initramfs
    Guillermo Patricio Carreño Mancilla
    Estudiante de Ingeniería en Informática
    || Linux User #408707 / Debian User #199 / Ubuntu User #4231 ||
    || Nuestro /home || Lectura Necesaria de todo Buen Forero || Usa Huuf! ||

  4. #4
    Join Date
    Sep 2007
    Location
    Villa Constitucion
    Beans
    53
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Dos problemas al actualizar a 10.04

    hola: tuve un problema cuando quise actualizar a lucid. cuando reinicie la compu, me salio el siguiente error MV: cannot move `/etc/resolv.conf.pppd-backup'to /etc/resolv.conf´ operation not permited

    Luego de que pude entrar y reparar a travez de recovery mode, me surgieron una serie de problemas.
    no me permite actualizar
    no me permite montar los discos que tengo y el pendrive

    Desde ya muchas gracias
    lopulus

  5. #5
    Join Date
    May 2009
    Location
    South America
    Beans
    Hidden!
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Dos problemas al actualizar a 10.04

    Quote Originally Posted by lopulus View Post
    hola: tuve un problema cuando quise actualizar a lucid. cuando reinicie la compu, me salio el siguiente error MV: cannot move `/etc/resolv.conf.pppd-backup'to /etc/resolv.conf´ operation not permited
    Luego de que pude entrar y reparar a travez de recovery mode, me surgieron una serie de problemas.
    no me permite actualizar
    no me permite montar los discos que tengo y el pendrive
    Desde ya muchas gracias
    Lopulus,

    Por favor, la próxima vez que desees publicar una duda en el foro te pido que lo hagas en un Post nuevo ya que este Post fue abierto bajo una pregunta en especifico, por este motivo para poder ayudar a resolver tus dudas y problemas debes crear un Post nuevo donde planteas tu problema o duda.

    Si no tienes muy clara la división que utilizamos puedes leer el siguiente post:
    http://ubuntuforums.org/showthread.php?t=1319475

    También te pido que leas las normas he intentamos aplicarlas en el foro para que tu experiencia en el mismo sea más efectiva:
    http://ubuntuforums.org/showthread.php?t=1162750
    Last edited by RafaelG; September 4th, 2010 at 09:27 PM.
    RafaelG

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •