Page 1 of 3 123 LastLast
Results 1 to 10 of 26

Thread: NX Client Authentication failed

  1. #1
    Join Date
    May 2010

    Question NX Client Authentication failed


    I have been used NX client on windows 7 connected to ubuntu with NX client/node/server with no issues. The matter started when I have formatted Ubuntu and reinstalled NX, from that NX connects but shows a key error as follows:

    NX> 203 NXSSH running with pid: 4328
    NX> 285 Enabling check on switch command
    NX> 285 Enabling skip of SSH config files
    NX> 285 Setting the preferred NX options
    NX> 200 Connected to address: on port: 22
    NX> 202 Authenticating user: nx
    NX> 208 Using auth method: publickey
    NX> 204 Authentication failed.

    I have been doing all the procedures I could thought and others I have found at forums as:

    - included NX and 'my user' at sshd_config
    - included authorized_key2 at sshd_config
    - copyed the keys from /usr/NX/share/keys and used them at windows client
    - generated new key using nxserver -keygen and also used at windows client
    - changed the /.ssh ownership to 'my user' and NX giving them all privileges
    - reinstalled nx client/node/server at ubuntu
    - uninstalled client/node/server, deleted NX directory at ubuntu and reinstalled all
    - stoped and restarted the server service

    the only way i have managed to get back the connection was to reinstall the packs below but i can not answer why it runned. those packs were choosed just as a clue because I thought there is a SSh config issue. so once i reinstall them the connection runs fine BUT until the rebooting of PC! once PC it is restarted the only way to get new connection is to reinstall those packs again.


    it seems there is a SSH config issue but i was not been able to find what.
    all advices will be very welcome.


    my sshd_config copy:


    # Package generated configuration file
    # See the sshd( manpage for details
    # What ports, IPs and protocols we listen for
    Port 22
    # Use these options to restrict which interfaces/protocols sshd will bind to
    #ListenAddress ::
    Protocol 2
    # HostKeys for protocol version 2
    HostKey /etc/ssh/ssh_host_rsa_key
    HostKey /etc/ssh/ssh_host_dsa_key
    #Privilege Separation is turned on for security
    UsePrivilegeSeparation yes
    # Lifetime and size of ephemeral version 1 server key
    KeyRegenerationInterval 3600
    ServerKeyBits 768
    # Logging
    SyslogFacility AUTH
    LogLevel INFO
    # Authentication:
    LoginGraceTime 120
    PermitRootLogin yes
    AllowUsers nx meuuser
    StrictModes no
    RSAAuthentication yes
    PubkeyAuthentication yes
    AuthorizedKeysFile %h/.ssh/authorized_keys
    AuthorizedKeysFile %h/.ssh/authorized_keys2
    # Don't read the user's ~/.rhosts and ~/.shosts files
    IgnoreRhosts yes
    # For this to work you will also need host keys in /etc/ssh_known_hosts
    RhostsRSAAuthentication no
    # similar for protocol version 2
    HostbasedAuthentication no
    # Uncomment if you don't trust ~/.ssh/known_hosts for RhostsRSAAuthentication
    #IgnoreUserKnownHosts yes
    # To enable empty passwords, change to yes (NOT RECOMMENDED)
    PermitEmptyPasswords no
    # Change to yes to enable challenge-response passwords (beware issues with
    # some PAM modules and threads)
    ChallengeResponseAuthentication yes
    # Change to no to disable tunnelled clear text passwords
    #PasswordAuthentication yes
    PasswordAuthentication no
    # Kerberos options
    #KerberosAuthentication no
    #KerberosGetAFSToken no
    #KerberosOrLocalPasswd yes
    #KerberosTicketCleanup yes
    # GSSAPI options
    #GSSAPIAuthentication no
    #GSSAPICleanupCredentials yes
    X11Forwarding yes
    X11DisplayOffset 10
    PrintMotd no
    PrintLastLog yes
    TCPKeepAlive yes
    #UseLogin no
    #MaxStartups 10:30:60
    #Banner /etc/
    # Allow client to pass locale environment variables
    AcceptEnv LANG LC_*
    Subsystem sftp /usr/lib/openssh/sftp-server
    UsePAM yes
    Last edited by kevin_@; May 23rd, 2010 at 02:21 AM.

  2. #2
    Join Date
    May 2009

    Re: NX Client Authentication failed

    Hi Kevin.

    I have been having a very similar issue and have been working on it for a couple of days and can't seem to resolve it either. Have done exactly what you've done as well.

    Likely won't solve your problem but I noted in your sshd_config file that you have:
    AuthorizedKeysFile %h/.ssh/authorized_keys
    AuthorizedKeysFile %h/.ssh/authorized_keys2

    Depending on which file you're using you probably want to comment out the one you don't want to use. It looks like it is currently defaulting to authorized_keys2.

    When I run /usr/NX/bin/nxserver --status it gives me the following:
    NX> 900 Connecting to server ...
    NX> 204 Authentication to NX server failed.
    NX> 110 NX Server is stopped.
    NX> 999 Bye.

    However, when I run /usr/NX/bin/nxserver --usercheck chon it seems to be okay.
    NX> 900 Verifying public key authentication for NX user: chon.
    NX> 900 Public key authentication succeeded.
    NX> 999 Bye.

    Which version of ubuntu are you using? I'm using 10.4. Worked fine for me under 8.10, 9.04, 9.10 but can't seem to get it working on 10.4

    I share in your frustration.....

  3. #3
    Join Date
    May 2010

    Re: NX Client Authentication failed

    Hi Chon,

    Thanks for your replying and observation about 'authorized_keys'. I have commented that line, restarted the service and tryed to connect but no success...

    I am using Ubuntu 9.1 and NX has been running fine at 9.1 before I have formatted the machine.

    Does anybody has any suggestion for us??!!


  4. #4
    Join Date
    May 2010

    Re: NX Client Authentication failed

    Hi Again

    I just have tryed /usr/NX/bin/nxserver --status and got the same:

    root@xxxxxx:~# /usr/NX/bin/nxserver --status
    NX> 900 Connecting to server ...
    NX> 204 Authentication to NX server failed.
    NX> 110 NX Server is stopped.
    NX> 999 Bye.

    but then tryed /usr/NX/bin/nxserver --usercheck and it is not recognized by the system and so I clue the service is not up.

    but when I start the service it says that service is ALREADY running.

    root@xxxxxx:~# /usr/NX/bin/nxserver --start
    NX> 500 Service already running.
    NX> 999 Bye.

    and for the last try again /usr/NX/bin/nxserver --usercheck but is not recognized, still the same as before.

    strange but it seems we have a problem of permissions as a root cause of server service down...

    i will try to grant full permission to NX dir and see waht hapens, would be great if You could try the same Chon.

    Last edited by kevin_@; May 23rd, 2010 at 03:06 PM.

  5. #5
    Join Date
    Aug 2008

    Re: NX Client Authentication failed

    I'm seeing NX> 500 ERROR: Public key authentication failed when doing usercheck for my account. Any suggestions on how I fix this?

  6. #6
    Join Date
    May 2009

    Re: NX Client Authentication failed

    Hi all.

    After several attempts at trying to get NX up-and-running I was finally able to do it. To help others like me who struggled to do this I wrote up a "NoMachine NX Installation Guide v1.0" document in an attempt to help others. Please feel free to edit this document to improve on it.

    If you have any questions please let me know and I'll do what I can to help. Also, please let me know if this was helpful to you.

    Attached Files Attached Files
    Last edited by chon; April 22nd, 2011 at 06:07 AM.

  7. #7
    Join Date
    Dec 2010

    Re: NX Client Authentication failed

    chon, you saved my day. I would like to translate the installation into german and put it on my homepage (if you don't mind).

    Take care,

  8. #8
    Join Date
    May 2009

    Re: NX Client Authentication failed

    Hi Alex.

    I'm glad it helped. Please feel free to translate it and improve on it as you see fit.

    Last edited by chon; May 14th, 2011 at 02:52 AM.

  9. #9
    Join Date
    Dec 2011

    Re: NX Client Authentication failed

    Thank you so much for the wonderful write up. It helped me get thru all of my issues.

    Have a great day.

  10. #10
    Join Date
    Jul 2010

    Re: NX Client Authentication failed



Page 1 of 3 123 LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts