Hi Forum,

SORRY FOR THE CROSSPOST, it related directly to both server use and Apple Mac Mini use, so I am posting this here also in case my answer lies in the Apple User forum goer's hive-mind.

I recently purchased a couple of the new 2012 Mac Mini's released a few months back. I'm having some issues getting them to work, however.

In comparison, I have a 2009/10 (can't remember) Mac Mini sitting here, that 12.04.1 installed perfect. I am using the exact same installation media (USB stick).

The first issue I run into, is that I must have noacpi option selected, to even get to the language selection after selecing 'Install Ubuntu Server'. With nothing selected, I get a blank screen. With others selected, I get mixed result of getting to the next screen but no (USB) keyboard support, or blank screen once more.

The second issue I face is, that in the installation, Ubuntu can't detect the network interface (in this case a Broadcom BCM5701, which is a different chipset to the older Mac Mini I have). I complete the installation however, and can boot into Ubuntu, but can't seem to add support for that chipset to Ubuntu at all.

I attempted the same with Ubuntu Server 12.10, It eliminated the first issue described in the install process, but still doesn't pick up the interface in install. I didn't bother completing the install after that. Ultimately, I would prefer 12.04.1 for it being LTS.

Any help provided is appreciated .