Results 1 to 4 of 4

Thread: RaLink RT2860 Wireless issue

  1. #1
    Join Date
    Feb 2010
    Ubuntu 14.04 Trusty Tahr

    Talking RaLink RT2860 Wireless issue

    I sincerely hope all those suffering with wireless connection issues see this post and have success with it.

    I have been having problems with my wireless connection for months now since switching to Ubuntu. Like some people, my laptop would connect occasionally. When it wouldn't, I just kept getting a message on the screen asking to enter the WPA passphrase.

    The fix? I changed the security on the router from WPA and WPA2 to just WPA2. And TKIP and AES to AES only. For whatever reason changing the cipher settings works.

    Prior to doing this I've tried nearly every fix listed on the forum and I can't believe the fix was so simple

    I am using Ubuntu version 10.04 Lucid Lynx


  2. #2
    Join Date
    Feb 2009

    Re: RaLink RT2860 Wireless issue

    A few additional notes on this bug - yes bug.

    10.04 64 bit raw install on xw8600 workstation with EDIMAX 802.11N RT2860 based PCI card = works without changing to the OP's settings.

    Yes, I said that works - it works out of the box on a fresh install.

    Run update for the first time = fails.

    Something being updated in the first 175MB of patches is breaking this driver.

    Changing the router to the OP's settings is a viable work around - it worked for me as well. However, it should work anyway.

    Changing the router was OK since I don't have any WPA devices anymore. If I did, this wouldn't be cool. The fact that it works then breaks is annoying too.

    I'm not sure how the OP figured this out, but THANK YOU!

  3. #3
    Join Date
    Dec 2006

    Re: RaLink RT2860 Wireless issue

    I struggled for days trying to get this chipset to work without success. I followed all the instructions in the forum both for the native driver and ndiswrapper with the XP driver. Finally, I discovered this simple article in the archives, and it worked for Lucid 64 bit. Don't know why it doesn't work "out of the box," but it does not in Lucid, although I have heard it said it did in previous releases. Now I am finally operating at N speeds!

  4. #4
    Join Date
    Sep 2009

    Re: RaLink RT2860 Wireless issue

    I can't believe the fix was that easy! Thank you kkelly77!

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts