I'm having a problem installing this on my machine using Ubuntu 11.04, AMD64. I have a Pixma MX320. I tried following these instructions, but i'm getting package dependencies which are odd:

Code:
alan@devserver:~/cnijfilter-mx320series-3.10-1-i386-deb/packages$  sudo dpkg --force-architecture -i cnijfilter-common_3.10-1_i386.deb 
dpkg: warning: overriding problem because --force enabled:
 package architecture (i386) does not match system (amd64)
(Reading database ... 152767 files and directories currently installed.)
Preparing to replace cnijfilter-common:i386 3.10-1 (using cnijfilter-common_3.10-1_i386.deb) ...
Unpacking replacement cnijfilter-common:i386 ...
dpkg: dependency problems prevent configuration of cnijfilter-common:i386:
 cnijfilter-common:i386 depends on libc6 (>= 2.3.4-1).
 cnijfilter-common:i386 depends on libcupsys2 (>= 1.2.1) | libcups2.
 cnijfilter-common:i386 depends on libpopt0 (>= 1.7).
dpkg: error processing cnijfilter-common:i386 (--install):
 dependency problems - leaving unconfigured
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 cnijfilter-common:i386
then when i tried to apt-get those, i got the response that they were all up to date:
Code:
alan@devserver:~/cnijfilter-mx320series-3.10-1-i386-deb/packages$ sudo apt-get install libc6 libcupsys2 libcups2 libpopt0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'libcups2' instead of 'libcupsys2'
libc6 is already the newest version.
libpopt0 is already the newest version.
libcups2 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
that's as far as i got (basically to #7). any suggestions would be MUCH appreciated!