Results 1 to 5 of 5

Thread: compiz not working in ubuntu 10.04

  1. #1
    Join Date
    Aug 2008
    Beans
    54

    compiz not working in ubuntu 10.04

    Ok, so I've been trying to get compiz working in 10.04, and to no avail. When I try to run compiz --replace or compiz --replace --indirect-rendering I get the following message:
    Code:
    compiz (core) - Warn: No GLXFBConfig for depth 32
    However as you will notice from my Xorg file I do not have any 32 bit options set just 24:

    Code:
    # nvidia-xconfig: X configuration file generated by nvidia-xconfig
    # nvidia-xconfig:  version 1.0  (buildmeister@builder75)  Thu Apr 15 05:52:31 PDT 2010
    
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildd@palmer)  Fri Apr  9 10:35:18 UTC 2010
    
    Section "ServerLayout"
        Identifier     "Layout0"
        Screen      0  "Screen0" 0 0
        InputDevice    "Keyboard0" "CoreKeyboard"
        InputDevice    "Mouse0" "CorePointer"
        Option         "Xinerama" "0"
    EndSection
    
    Section "Files"
    EndSection
    myron@myron-desktop:~$ lspci | grep VGA
    01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Mouse0"
        Driver         "mouse"
        Option         "Protocol" "auto"
        Option         "Device" "/dev/psaux"
        Option         "Emulate3Buttons" "no"
        Option         "ZAxisMapping" "4 5"
    EndSection
    
    Section "InputDevice"
    
        # generated from default
        Identifier     "Keyboard0"
        Driver         "kbd"
    EndSection
    
    Section "Monitor"
    
        # HorizSync source: edid, VertRefresh source: edid
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "Acer AL1703"
        HorizSync       30.0 - 82.0
        VertRefresh     50.0 - 75.0
        Option         "DPMS"
    EndSection
    
    Section "Device"
        Identifier     "Device0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce2 MX/MX 400"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Device0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "TwinView" "0"
        Option         "TwinViewXineramaInfoOrder" "CRT-0"
        Option         "metamodes" "1024x768 +0+0"
        SubSection     "Display"
            Depth       24
        EndSubSection
    EndSection
    The video card that I'm using is:
    Code:
    myron@myron-desktop:~$ lspci | grep VGA
    01:00.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 MX/MX 400] (rev b2)
    I believe that I have the correct driver installed (I got it using the wonderful Ubuntu Hardware Drivers utility. it's the nvidia version 96 (recommended).

    I appreciate any help!

  2. #2
    Join Date
    Jun 2006
    Location
    Nux Jam
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: compiz not working in ubuntu 10.04

    lucid dont need xorg.conf by default, so rename yours
    or delete it : sudo rm -f /etc/X11/xorg.conf

    into synaptic, check that nvidia-current, nvidia-current-modaliases, nvidia-common, nvidia-settings are installed, then reboot

  3. #3
    Join Date
    Aug 2008
    Beans
    54

    Re: compiz not working in ubuntu 10.04

    Thanks for the quick response dino99! Ok, so the only thing missing was nvidia-current. I installed that, and I renamed my xorg.conf. That seemed to change things up a bit. I still can't enable compiz, but I'm getting a different error now:

    Code:
    myron@myron-desktop:~$ compiz --replace
    Xlib:  extension "GLX" missing on display ":0.0".
    compiz (core) - Fatal: Root visual is not a GL visual
    compiz (core) - Error: Failed to manage screen: 0
    compiz (core) - Fatal: No manageable screens found on display :0.0
    I also have the output of glxinfo for reference:

    Code:
    myron@myron-desktop:~$ glxinfo
    name of display: :0.0
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Error: couldn't find RGB GLX visual or fbconfig
    
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    Xlib:  extension "GLX" missing on display ":0.0".
    2 GLXFBConfigs:
       visual  x  bf lv rg d st colorbuffer ax dp st accumbuffer  ms  cav
     id dep cl sp sz l  ci b ro  r  g  b  a bf th cl  r  g  b  a ns b eat
    ----------------------------------------------------------------------
    Segmentation fault
    I found some other posts that said to add some settings to xorg.conf, but I can't do this because as you said before, lucid does not use an xorg.conf file by default.

  4. #4
    Join Date
    Aug 2008
    Beans
    54

    Re: compiz not working in ubuntu 10.04

    I think I have this figured out. I'll mark it as solved as soon as I make sure... To fix the "Xlib: extension "GLX" missing on display ":0.0" error message, I ran sudo nvidia-xconfig, which generated a new xorg.conf file. That brought me back to the same problem I had to begin with: "compiz (core) - Warn: No GLXFBConfig for depth 32." To fix this problem, I found that I needed to add some lines to my xorg.conf file:

    If there is a module section, add: " load "glx" " to that section. If there is not a module section, just copy and paste this to the bottom of your xorg.conf file.

    Code:
    ection "Module"
    	Load "glx"
    EndSection
    Also, I found that I needed to add some lines to the screen section:

    Code:
    	Option "AddARGBGLXVisuals" "True"
    	Option "DisableGLXRootClipping" "True"
    The previous two lines are actually what fixed the 32 bit depth error message.

    At this point I was able to enable compiz, but all of the settings did not work, and they wouldn't save.

    I found, from this thread, that I had a package missing that compiz needed. it was :
    compiz-fusion-plugins-extra
    I also found a helpful list of other packages that compiz needed. (I already had the rest of these installed)

    compiz compiz-plugins compiz-gnome compiz-core compiz-fusion-plugins-main compiz-fusion-plugins-extra compizconfig-backend-gconf compizconfig-settings-manager
    Last but not least, I found a nice tool here, that will check if compiz is able to run on your system.

    I hope this info is helpful to someone else too!

  5. #5
    Join Date
    Aug 2006
    Beans
    21

    Re: compiz not working in ubuntu 10.04

    You also get the error,
    "compiz (core) - Warn: No GLXFBConfig for depth 32"

    if you have this environment variable set.
    export XLIB_SKIP_ARGB_VISUALS=1

    I had set export XLIB_SKIP_ARGB_VISUALS=1 globally because I had a program that didn't play nice with compiz. Then the next day when I started my computer compiz would not work. After much searching I found out that setting export XLIB_SKIP_ARGB_VISUALS=1 caused the problem.

    I removed export XLIB_SKIP_ARGB_VISUALS=1 from my .profile and added it to the script that starts the program that doesn't play nice with compiz. Problem solved!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •