Results 1 to 3 of 3

Thread: Installed Linux Mint - Grub Gone - Can't boot

  1. #1
    Join Date
    Feb 2010
    Antalya, Turkey

    Angry Installed Linux Mint - Grub Gone - Can't boot

    I was pretty excited about the release of Linux Mint 9, so I got an ISO, and installed it next to my Ubuntu and Windows XP. Installation went fine, until I restarted my machine. When I boot, right after the memory count I see the following:

    Verifying DMI Pool Data.......
    Boot from Atapi CD-ROM
    error: unknown filesystem.
    grub rescue> (cursor blinks)

    Whereas I'm still excited about Mint, I must get back to Ubuntu. How do I put things back? Please help!!

  2. #2
    Join Date
    May 2007
    unity free space
    Xubuntu 12.04 Precise Pangolin

    Re: Installed Linux Mint - Grub Gone - Can't boot

    start from live cd --> then resinstall grub from command line. this worked for me:
    Reinstalling GRUB 2 from LiveCD
    If you cannot boot from GRUB 2 and need to reinstall it, here is the simple method. For more details or for advanced options, refer to the Ubuntu community documentation here: Grub2 - Reinstalling GRUB 2:

    * Boot LiveCD to the Desktop.
    * Open a terminal - Applications, Accessories, Terminal.
    * Determine your normal system partition - `sudo fdisk -l` (That is a lowercase L)
    * If you aren't sure, run `df -Th`. Look for the correct disk size and ext3 or ext4 format.
    * Mount your normal system partition:

    sudo mount /dev/sdXY /mnt

    o Example: sudo mount /dev/sda1 /mnt
    o Note: The partition to mount is normally the partition on which Ubuntu was installed: sda1, sdb5, etc. If you have a separate /boot partition, use the device on which the /boot partition is located. Grub 2 works best when installed in the MBR of the drive to which BIOS boots. Also remember that you mount the partition (including the number) in this step, but you do not include the partition number when you run the "sudo grub-install" command later.
    o Note: GRUB 2 counts the first drive (X) as "0", but the first partition (Y) as "1"
    * Only if you have a separate boot partition:

    sudo mount /dev/sdXY /mnt/boot

    with sdXY being your /boot partition designation.
    * Reinstall GRUB 2:

    sudo grub-install --root-directory=/mnt /dev/sdX

    o Example: sudo grub-install --root-directory=/mnt /dev/sda
    o Note: Substitute the device on which Ubuntu was installed - sda, sdb, etc. Do not specify a partition number.

    grub should recognize your other operating system. hope this works for you. good luck!
    Intel Core i5 CPU 750 oc@3.75GHz - Asus P7P55D - Nvidia GTX 260

  3. #3
    Join Date
    Feb 2010
    Antalya, Turkey

    Re: Installed Linux Mint - Grub Gone - Can't boot

    It worked! Thank you so much!!!

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts