Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 26

Thread: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

  1. #11
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    Quote Originally Posted by Darac View Post
    This makes me a sad panda. Too bad Flash is all over the Web, it's easy to bypass this problem on Youtube, using totem's built in plugin or minitube, but it's terrible to not be able to watch videos on any other video sites.
    That's the reason of all the hype around HTML5.

    Quote Originally Posted by Darac View Post
    Does flash have any log files i could check to see if there are any errors produced there?
    Start Firefox from terminal and it should output any errors, but I doubt it will produce any. Flash just sucks.

  2. #12
    Join Date
    Jan 2008
    Beans
    11

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    Quote Originally Posted by lovinglinux View Post
    Start Firefox from terminal and it should output any errors, but I doubt it will produce any. Flash just sucks.
    As you predicted it didn't produce any errors. I don't have time to wait for HTML 5 go live since it will take a couple of years..

    Oh well, Flash and my comp are just not meant to be

  3. #13
    Join Date
    Jan 2008
    Beans
    11

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    Hi again, i've had some progress. Just installed Flash 10.1 RC4 from Adobe, and i have 15% lower CPU usage from Xorg, total CPU usage is now 75-80% when watching flash videos. So it's quite a progress.

    Here's the tutorial how to install flash rc on Ubuntu: http://www.ubuntugeek.com/how-to-ins...in-ubuntu.html

    I won't tag this thread as solved since i'm still having far, far better results on my Celeron. But at least i can watch videos without Firefox freezing.
    Last edited by Darac; May 16th, 2010 at 10:05 PM.

  4. #14
    Join Date
    Apr 2006
    Beans
    87
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    Quote Originally Posted by Darac View Post
    As you predicted it didn't produce any errors. I don't have time to wait for HTML 5 go live since it will take a couple of years..

    Oh well, Flash and my comp are just not meant to be
    At least on Youtube it is live now. You have to use a webkit browser (like Chrome or Chromium or Safari) but it works.
    Quote Originally Posted by anonymous admin
    root is a flying nuclear buzzsaw
    GETFIXED: Video BadAlloc crashes! Turn ON the error beep! Get 64 bit Flash! Fix mplayer!

  5. #15
    Join Date
    Apr 2006
    Location
    UK
    Beans
    556
    Distro
    Ubuntu Mate

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    is it worth trying a lower screen resolution? just curious..
    Steve
    Intel Pentium Dual Core 2.6 Ghz 2 Gb ram, Asus P5KPL motherboard, 2.5 TB Storage running Hardy.
    HP Pentium 4 2.8 Ghz 756 mb ram running Intrepid.

  6. #16
    Join Date
    Jan 2008
    Beans
    11

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    Quote Originally Posted by mister_p_1998 View Post
    is it worth trying a lower screen resolution? just curious..
    Steve
    No, it doesn't help, the CPU usage stays the same.

    I ran some tests with HTML5, and to my surprise the CPU usage of Xorg is the same or sometime spikes even to 60% of total CPU. Firefox CPU usage is lower, but Xorg is equally terrible with HTML5 videos. As a reference i used ogg theora vid from this site, since Firefox can render it. I also disabled Flash plugin in Firefox prior to watching just to be safe Flash isn't used.

    http://camendesign.com/code/video_fo...body/test.html

    I tried disabling composite, but the result is the same. So i guess this isn't a problem with Flash plugin from Adobe, but Xorg server and it's rendering of vids inside browser windows.

    Btw, i'm rly astonished how many ppl just don't give a f*ck about this problem which is 4 years old. And no one even tried to do some proper debugging or experiments to get to the root cause. All ppl usually write in threads with Xorg high CPU usage when rendering Flash is that it's Adobe's fault, which it clearly isn't in some cases and especially in this case i described above.

    I even tried installing newer Xorg.server and newer radeon drivers from Xorg edgers PPA, but that didn't help either. So i'm rly out of ideas by now. Any help or idea would be appreciated.
    Last edited by Darac; May 19th, 2010 at 08:22 PM.

  7. #17
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    Quote Originally Posted by Darac View Post
    No, it doesn't help, the CPU usage stays the same.

    I ran some tests with HTML5, and to my surprise the CPU usage of Xorg is the same or sometime spikes even to 60% of total CPU. Firefox CPU usage is lower, but Xorg is equally terrible with HTML5 videos. As a reference i used ogg theora vid from this site, since Firefox can render it. I also disabled Flash plugin in Firefox prior to watching just to be safe Flash isn't used.

    http://camendesign.com/code/video_fo...body/test.html

    I tried disabling composite, but the result is the same. So i guess this isn't a problem with Flash plugin from Adobe, but Xorg server and it's rendering of vids inside browser windows.

    Btw, i'm rly astonished how many ppl just don't give a f*ck about this problem which is 4 years old. And no one even tried to do some proper debugging or experiments to get to the root cause. All ppl usually write in threads with Xorg high CPU usage when rendering Flash is that it's Adobe's fault, which it clearly isn't in some cases and especially in this case i described above.

    I even tried installing newer Xorg.server and newer radeon drivers from Xorg edgers PPA, but that didn't help either. So i'm rly out of ideas by now. Any help or idea would be appreciated.
    I know is not a solution, but I'm finishing the development of an extension that will allow to replace flash videos with mplayer compatible videos on site. See thread and the extension web site.

  8. #18
    Join Date
    Jan 2008
    Beans
    11

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    Quote Originally Posted by lovinglinux View Post
    I know is not a solution, but I'm finishing the development of an extension that will allow to replace flash videos with mplayer compatible videos on site. See thread and the extension web site.
    Oh yes that's a solution! I rly don't care which way vids will play on sites, just as long they are played without hogging the resources.

    Excellent news, now i have something to look forward to. Hope your extension will work well.

  9. #19
    Join Date
    Aug 2008
    Location
    Brazil
    Beans
    12,497
    Distro
    Ubuntu Studio 12.04 Precise Pangolin

    Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    Quote Originally Posted by Darac View Post
    Oh yes that's a solution! I rly don't care which way vids will play on sites, just as long they are played without hogging the resources.

    Excellent news, now i have something to look forward to. Hope your extension will work well.
    It works well. The only problem is that I need to create a separate code for every web site I want to support.

  10. #20
    Join Date
    Jun 2010
    Beans
    1

    Lightbulb Re: [10.04 Lucid Lynx] Xorg + Flash = insane CPU usage

    Hi all, Removing Flash has corrected this problem for me until i open System Monitor and then 100% CPU usage. System Monitor then has a problem shutting down using the close box button, highlighting the process and using end process sorts that. I am thinking with the system shut-down errors and these Ubuntu is in need of some fixes. I use a older machine with Fedora 12 fully loaded with Flash etc and when watching files from you-tube and the like my processor is on 14% and drops to 0 - 1% when idle.

Page 2 of 3 FirstFirst 123 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •