Page 1 of 4 123 ... LastLast
Results 1 to 10 of 33

Thread: Nautilus does not respect GTK theme set in Appearance

  1. #1
    Join Date
    Feb 2008
    Location
    St. Petersburg, FL, USA
    Beans
    108

    Question Nautilus does not respect GTK theme set in Appearance

    I have recently experienced an odd issue regarding Nautilus and the GTK theming. No matter what theme is set in the "Appearance" dialog, Nautilus shows the bland default GTK theme with the title bars of the theme set in Appearance.

    I think this is related to an error regarding GConf I saw once, but never again. It flashed so quickly on shutdown that I did not have time to note down what it says. This issue effects the desktop as well. Any ideas? Rebooting doesn't fix it and beyond that, I have no clue where to start for an issue like this.
    Eric

  2. #2
    Join Date
    Mar 2010
    Beans
    10

    Re: Nautilus does not respect GTK theme set in Appearance

    Quote Originally Posted by guitarMan666 View Post
    I have recently experienced an odd issue regarding Nautilus and the GTK theming. No matter what theme is set in the "Appearance" dialog, Nautilus shows the bland default GTK theme with the title bars of the theme set in Appearance.

    I think this is related to an error regarding GConf I saw once, but never again. It flashed so quickly on shutdown that I did not have time to note down what it says. This issue effects the desktop as well. Any ideas? Rebooting doesn't fix it and beyond that, I have no clue where to start for an issue like this.
    Funnily enough. I'm having the exact same problem. This problem started happening after a crash that I experienced last night.

    If anyone has any ideas on how to fix it, I would be most grateful. Thanks!

  3. #3
    Join Date
    Mar 2007
    Beans
    22

    Re: Nautilus does not respect GTK theme set in Appearance

    I've got this problem too, a search led me to this:

    https://bugs.launchpad.net/ubuntu/+s...us/+bug/500417

    Post 22 seems to have a fix, but I'm too new to know how to do it...

    I guessed it might be in the root folder, so used terminal to launch Nautilus with sudo, and it loaded with the theme....

    I can't find that thing to delete like in the post though

  4. #4
    Join Date
    Feb 2008
    Location
    St. Petersburg, FL, USA
    Beans
    108

    Re: Nautilus does not respect GTK theme set in Appearance

    The fix is actually very simple. It involves removing a folder. The simplest way to accomplish this is to open a terminal and run the following:
    Code:
    rm -vr ~/.gconf/apps/nautilus && killall nautilus
    This command removes the directory /home/yourname/.gconf/nautilus and the files in it giving you written confirmation, and kills the nautilus process IF the delete is successful.

    You may find this solution more comfortable as a beginner:
    Code:
    rm -vr ~/.gconf/apps/nautilus && sudo reboot
    Which reboots instead of merely killing the process. This may save any abnormalities that might occur from killing nautilus (like missing desktop icons).

    EDIT: First command works flawlessly. No abnormal effects or anything.
    Last edited by guitarMan666; May 16th, 2010 at 05:36 AM. Reason: Updating info
    Eric

  5. #5
    Join Date
    Mar 2007
    Beans
    22

    Re: Nautilus does not respect GTK theme set in Appearance

    awesome, thankyou! It worked

  6. #6
    Join Date
    Mar 2010
    Beans
    10

    Re: Nautilus does not respect GTK theme set in Appearance

    Quote Originally Posted by guitarMan666 View Post
    The fix is actually very simple. It involves removing a folder. The simplest way to accomplish this is to open a terminal and run the following:
    Code:
    rm -vr ~/.gconf/apps/nautilus && killall nautilus
    This command removes the directory /home/yourname/.gconf/nautilus and the files in it giving you written confirmation, and kills the nautilus process IF the delete is successful.

    You may find this solution more comfortable as a beginner:
    Code:
    rm -vr ~/.gconf/apps/nautilus && sudo reboot
    Which reboots instead of merely killing the process. This may save any abnormalities that might occur from killing nautilus (like missing desktop icons).

    EDIT: First command works flawlessly. No abnormal effects or anything.
    Thank you! Worked for me as well!

  7. #7
    Join Date
    Mar 2007
    Beans
    22

    Re: Nautilus does not respect GTK theme set in Appearance

    Ok, maybe it didn't work... it keeps going back to the rubbish theme, and it makes noises when it does it! Clicking things makes a noise, it's gets very irritating.
    It works if I do the above, but goes back when I restart.

  8. #8
    Join Date
    Mar 2007
    Beans
    22

    Re: Nautilus does not respect GTK theme set in Appearance

    *bump*

    No one got any ideas?
    This is starting to get annoying now, and I don't want to do an complete reinstall just for a theme problem.

  9. #9
    Join Date
    May 2009
    Beans
    2

    Re: Nautilus does not respect GTK theme set in Appearance

    Check if you have a file named gnome-settings-daemon.desktop in your /home/username/.config/autostart folder. If you find it there, just delete it (or, if you don't feel like, just try moving it to another location) and reboot. That solved the problem with me.
    Last edited by muschiosauro; June 22nd, 2010 at 12:49 AM.

  10. #10
    Join Date
    Mar 2007
    Beans
    22

    Re: Nautilus does not respect GTK theme set in Appearance

    Thanks for the reply, but I don't have that file.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •