Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: 10.04 Mounted Shares Cause Slow Shutdown

  1. #1
    Join Date
    Jan 2008
    Beans
    477

    10.04 Mounted Shares Cause Slow Shutdown

    I have been mounting several shares in fstab for a couple years now to facilitate using my music, photos and videos (pre Storage Groups) on my front ends. However, with my new 10.04 frontends, having these mounts in fstab causes unbearably slow reboots (like almost 10 minutes for one of them). Remove the mounts, and if I blink, I miss the shut down.

    I tried renaming /etc/rc6.c/S31umountnfs.sh to run before /etc/rc6.c/S15wpa-ifupdown like I saw suggested somewhere to no avail. Though, I am using samba, not NFS, so that may have something to do with that not helping.

    Anyone have any ideas on how I can combat this?

  2. #2
    Join Date
    May 2007
    Beans
    2,337

    Re: 10.04 Mounted Shares Cause Slow Shutdown

    Hi,

    I'm mounting my samba shares through rc.local rather than in fstab and shutdown only takes afew seconds from my frontend.

    Just delete the fstab entries and add the mount commands to your /etc/rc.local script.


    Regards
    Ian Dobson
    Walking on water and writing software to specification is easy if they're frozen.

    My corner of the internet http://www.planet-ian.com

  3. #3
    Join Date
    Jul 2008
    Beans
    171

    Re: 10.04 Mounted Shares Cause Slow Shutdown

    When I used to use samba + fstab, I experienced this behavior as well.

    Fixed it with this: http://ubuntuforums.org/showthread.php?t=293513

    Ian's suggestion would be much more elegant, however.

  4. #4
    Join Date
    Jan 2008
    Beans
    477

    Re: 10.04 Mounted Shares Cause Slow Shutdown

    Quote Originally Posted by ian dobson View Post
    Just delete the fstab entries and add the mount commands to your /etc/rc.local script.


    Regards
    Ian Dobson
    Cheers! Could you please provide me with an example mount in rc.local? I have tried adding the following just before "exit 0", both with and without sudo. It is not doing the mount for me.

    smbmount //mMYSERVERNAME/Music /media_storage/Music/ -o username=MYUSER,password=MYPASS rw

    Thanks

  5. #5
    Join Date
    May 2007
    Beans
    2,337

    Re: 10.04 Mounted Shares Cause Slow Shutdown

    Hi,

    This is the mount command I'm using in rc.local:-

    Code:
    mount -t cifs -o  username=NAME,password=PASSWORD,rsize=8192,wsize=8192,noatime  //192.168.0.2/Data /mnt/video
    Regards
    Ian Dobson
    Last edited by ian dobson; May 13th, 2010 at 12:55 PM.
    Walking on water and writing software to specification is easy if they're frozen.

    My corner of the internet http://www.planet-ian.com

  6. #6
    Join Date
    Jan 2008
    Beans
    477

    Re: 10.04 Mounted Shares Cause Slow Shutdown

    With nothing special done to provide root access?

  7. #7
    Join Date
    May 2007
    Beans
    2,337

    Re: 10.04 Mounted Shares Cause Slow Shutdown

    Hi uncle hammy,

    rc.local is started as root by the init script.

    Regards
    Ian Dobson
    Walking on water and writing software to specification is easy if they're frozen.

    My corner of the internet http://www.planet-ian.com

  8. #8
    Join Date
    Jan 2008
    Beans
    477

    Re: 10.04 Mounted Shares Cause Slow Shutdown

    It's not working. I am seeing a quick message during boot up (before I actually get to any UI)

    Mount error, network is unreachable.

  9. #9
    Join Date
    Dec 2007
    Location
    Adelaide, Australia
    Beans
    678
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 Mounted Shares Cause Slow Shutdown

    I suspect this is because your not connected to your network at the time rc.local is trying to mount the drives.

    I had a similar issue when trying to wake up the backend via wakeonlan in rc.local.

    The way I got around it is by editing the network configuration file /etc/network/interfaces.
    In my case I added the following lines:
    Code:
    auto eth0
    iface eth0 inet dhcp
    Yours might be slightly different, depending on your network interface, dhcp or static etc.

    That way networking gets started earlier in the boot process and should be up when rc.local gets called. At least it is in my case.
    I also uninstalled network manager, although I read somewhere that step is not necessary (haven't tried it though).
    Lucid Lynx 10.04 on a Lenovo Thinkpad R61i
    Arch frontend/backend
    Arch frontend
    Yay North Adelaide Ultimate !!!

  10. #10
    Join Date
    Jan 2008
    Beans
    477

    Re: 10.04 Mounted Shares Cause Slow Shutdown

    OK, well between moving to rc.local, and abandoning Network Manager for /etc/network/interfaces, I have it working.

    It also only helps me with my front ends. On my Ubuntu laptop, that I also like to redirect my Music, Pictures, etc folders to those shares on my server, I have to manually set up all the wireless settings in /etc/network/interfaces. Which means when I leave my house, I have a whole pile of work in front of me to connect to say my dad's wireless network.

    Seems like a real PITA to me. In this day and age, mounting a network share at boot is pretty common place...should NOT be this difficult. All the fancy GUI tools in the world are rendered pretty useless by things like this.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •