Page 4 of 4 FirstFirst ... 234
Results 31 to 38 of 38

Thread: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

  1. #31
    Join Date
    Dec 2010

    Unhappy Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Quote Originally Posted by enoch.brown View Post
    Hi all,
    I have a Gigabyte T1028X with the eGalax touchscreen. I just installed a fresh install of Lucid on it. I have tried everything in this post to set it up, however whenever I touch the screen the cursor flits around in seeming random patterns.

    Thanks in advance,
    Hi enoch.brown,

    I got exact same problem with yours. the mouse cursor is flying around. have you solve your problem yet?

    PS. I am not sure which brand of my touch screen. it seems like a oem 8" touch screen.
    Last edited by imato; December 21st, 2010 at 03:52 AM.

  2. #32
    Join Date
    Dec 2010

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Hi, I have done a lot of search on internet. Finally, I sort it out haha .

    Here is my installation note :
    Last edited by imato; April 30th, 2012 at 10:10 PM.

  3. #33
    Join Date
    Jan 2007

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    i have a eeepc 901 asus and ubuntu 10.10 netbook with touchscreen

    i did this

    and then

    Linux driver installer for TouchKitTouch controller

    (I) Check user permission: root, you are the supervisor.
    (I) Begin to setup the TouchKitTouch driver.
    (I) Found and removed previous TouchKitTouch driver.
    (I) Extract TouchKitTouch driver archive to /usr/local/TouchKit32.
    (I) Create TouchKit utility shortcut in /usr/bin.
    (I) Create TKCal tool shortcut in /usr/bin.
    (I) Check X window version: 6.9.0 ~ 7.2.0
    (I) Copy X module: x69/ to /usr/lib/xorg/modules/input.

    (Q) Which interface controller do you use?
    (I) [1] RS232 [2] PS/2 [3] USB : 3
    (I) Using interface: USB
    (I) Found a HID compliant touch controller.
    (I) Found inbuilt kernel module: usbtouchscreen.
    (I) It is highly recommended that add it into blacklist.
    (Q) Do you want to add it into blacklist? (y/n) y

    (I) Found X configuration file: /etc/X11/xorg.conf.
    (I) Removed touch configuration from /etc/X11/xorg.conf.
    (I) Add touch configuration into /etc/X11/xorg.conf.

    (I) Please reboot the system for some changes to take effect.
    (I) After booting, type "TouchKit" to do calibration.
    but still "no touch controller found"

    Section "ServerLayout"
        Identifier     " Configured"
        Screen      0  "Screen0" 0 0
        InputDevice    "Mouse0" "CorePointer"
        InputDevice    "Keyboard0" "CoreKeyboard"
    Section "Files"
        ModulePath   "/usr/lib/xorg/modules"
        FontPath     "/usr/share/fonts/X11/misc"
        FontPath     "/usr/share/fonts/X11/cyrillic"
        FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath     "/usr/share/fonts/X11/Type1"
        FontPath     "/usr/share/fonts/X11/100dpi"
        FontPath     "/usr/share/fonts/X11/75dpi"
        FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
        FontPath     "built-ins"
    Section "Module"
        Load  "dbe"
        Load  "glx"
        Load  "record"
        Load  "dri"
        Load  "dri2"
        Load  "extmod"
    Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
    Section "InputDevice"
        Identifier  "Mouse0"
        Driver      "mouse"
        Option        "Protocol" "auto"
        Option        "Device" "/dev/input/mice"
        Option        "ZAxisMapping" "4 5 6 7"
    Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
            ### <percent>: "<f>%"
            ### [arg]: arg optional
            #Option     "NoAccel"                # [<bool>]
            #Option     "SWcursor"               # [<bool>]
            #Option     "ColorKey"               # <i>
            #Option     "CacheLines"             # <i>
            #Option     "Dac6Bit"                # [<bool>]
            #Option     "DRI"                    # [<bool>]
            #Option     "NoDDC"                  # [<bool>]
            #Option     "ShowCache"              # [<bool>]
            #Option     "XvMCSurfaces"           # <i>
            #Option     "PageFlip"               # [<bool>]
        Identifier  "Card0"
        Driver      "intel"
        BusID       "PCI:0:2:0"
    Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
            Viewport   0 0
            Depth     1
        SubSection "Display"
            Viewport   0 0
            Depth     4
        SubSection "Display"
            Viewport   0 0
            Depth     8
        SubSection "Display"
            Viewport   0 0
            Depth     15
        SubSection "Display"
            Viewport   0 0
            Depth     16
        SubSection "Display"
            Viewport   0 0
            Depth     24

  4. #34
    Join Date
    Nov 2006
    Kubuntu 6.10 Edgy

    Unhappy Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)


    with Ubuntu 10.10 (Maverick) I also was able to use my eGalax touchscreen. This is my /usr/share/X11/xorg.conf.d/40-touch.conf file:

    PHP Code:
    Section "InputClass"
    Identifier "eGalax touch class"
    MatchProduct "eGalax"
    MatchDevicePath "/dev/input/event*"
    Driver "evtouch"
    Option "MinX" "150"
    Option "MinY" "100"
    Option "MaxX" "1900"
    Option "MaxY" "1950"
    Option "ReportingMode" "Raw"
    Option "Emulate3Buttons"
    Option "Emulate3Timeout" "50"
    Option "SendCoreEvents" "On"
    Option "Rotate" "CCW"
    Option "SwapY" "1"
    But with 11.04 the 'evtouch' isn't available any more
    The news is:
    • The eGalax input device gets detected automatically using the general evdev driver.
    • With help of 'xinput' it is possible to configure it (swap, calibration, invert, ...).
    • BUT there is a nasty hassle with the touchscreen 'button' emulation (see below).

    In 10.10 'evtouch' was kind of clever: if you ticked short onto the screen, it was detected as 'left mouse button'; if you ticked short and then a little longer immediate after that, it was detected as 'right mouse button'. If you touched the screen for longer (and moving the finger/mouse around), no mouse event was recorded (as it should be!).

    In 11.04, if you touch the screen this will always trigger a mouse button event. And because of this, the new state of affairs renders the touchscreen unusable.

    Anyone with a suggestion?

    Kind regards,

    Last edited by aanno; April 14th, 2011 at 08:50 PM.

  5. #35
    Join Date
    Feb 2006
    Cumbria, UK
    Ubuntu 7.10 Gutsy Gibbon

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Hi aanno,
    I am in exactly the same boat with my egalax touchscreen. Tell me if you stumble upon a cure for this.

  6. #36
    Join Date
    Oct 2011

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    I bought a little car computer type 7" LCD touch screen that uses the eGalax USB driver and I am using it with Ubuntu 10.04. I read many lists and forums regarding how to get a touchscreen to function with Ubuntu, and much of the information was wrong or misleading.

    So I would like to clear up what has and has not worked for me after spending 18 hours to get this screen to work properly.

    The eGalax drivers that came with the screen were old and obsolete. 3.02 was the latest on the little mini cd. I found a 3.06 version on the web from the company that writes the drivers and although it looked good and it had concise instructions on how to use it, it did not work with Ubuntu 10.04 on a MW525 intel mb. The software could never find the touch controller, even though it was showing up in the USB device list! After doing a lot of reading on the web about this driver, I came to the conclusion that the driver is junk and should be avoided. I lost some hair working with that driver. Do yourself a favor and don't bother trying to use these old drivers.

    With no additional drivers loaded into Ubuntu 10.04, the system cannot identify the eGalax touch screen device. A driver called evtouch must be loaded. You can find it via the Synaptic package manager. Install that and reboot.

    Not comes the really weird part. The newest USB driver is called the evdev driver and the evtouch driver is apparently being phased out (I have read that it does not work with version 11 or later ??)

    After you load the evtouch driver, Ubuntu will find the touch device using the evtouch driver but then the evdev driver apparently wrestles control of the touchscreen away from the evtouch driver.

    So two files need to be modified to allow this screen to work:

    The configuration file for the evdev and evtouch driver is in /usr/lib/X11/xorg.conf.d and the files I edited were called 05-evdev.conf and 10-evtouch.conf. Do not be tempted to try and make and edit a file called xorg.conf as mentioned in older docs. That is a no no in Ubuntu 10.04 and later. Only edit the config files in xorg.conf.d.

    This is how I modified the last InputClass section of the evdev config file (at the very bottom):

    Section "InputClass"
    Identifier "evdev touchscreen catchall"
    MatchIsTouchscreen "on"
    MatchDevicePath "/dev/input/event*"
    Driver "evdev"
    Option "InvertX" "true"
    Option "InvertY" "true"
    Option "Calibration" "38 2003 30 1825"

    The calibration section is minX maxX minY maxY for settings.

    This is how I modified the config file for the evtouch driver:

    Section "InputClass"
    Identifier "eGalax TouchScreen"
    MatchProduct "eGalax TouchScreen"
    MatchDevicePath "/dev/input/event*"
    Driver "evtouch"

    The descriptor (in this case "eGalax TouchScreen" ) must match up with what the computer identifies in the description you can see via "lsusb" at a terminal window.

    Other things:

    If you look in the boot up log for X you can see how your computer is trying to handle the touch screen. /var/log/xorg.0.log You can access it via gedit like this: sudo gedit /var/log/xorg.0.log.

    If you run evtest (may need to install the evtest software) via
    sudo evtest /dev/input/eventx” and try different x events, then you can find the touch screen and see how it is interacting with linux – live. This is a real eye opener if you haven't seen the evtest program run.

    Of course you can get some info from boot up via "dmesg" at a terminal screen also.

    If you get a lockout of the screen and end up not seeing Gnome desktop on the reboot, then hit Control-Alt-F2 and log in as root (make sure you have a root login setup or else you could lock yourself out of your computer on an error) , go and edit the .conf file via nan.. ie nano 05-evdev.conf.

    Reboot and try it again. A typo in that file can cause a lockout of the Gnome desktop.

    There is a calibration program called xinput-calibrator, but I have found it of limited use and it also has directions on how to update an fdi hal entry which is not required when using the evdev driver. (The hal entry is stuff from version 9.10 I believe) However finding the screen calibration coordinates might be useful for some. I ended up tweaking them manually in the .conf file, reboot, try, repeat.

    On my eGalax equipped screen ( I don't know the brand as it was made in China and really don't have a brand name!) if I input a MaxY value that was too large the touchscreen simply stopped responding via the evdev driver. So if in doubt start with smaller values for the maxX and maxY and work up until things look right.

    I really like Linux but the development of the software moves so fast from version to version and the changes between major version are substantial that trying to stay on top of what is required is a major task. The good thing is that the software is progressing (unlike windows) and making technical jumps.
    Last edited by Dave911; October 8th, 2011 at 11:55 PM.

  7. #37
    Join Date
    Nov 2009

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Quote Originally Posted by WillardPotter View Post
    Has anyone managed to get the eGalax screens working properly?
    Yes, me.
    took about 2 hours of reading and then in 5 min it was working..
    Its realy simpel.

    1) go here, and get the drivers.

    2) backup you config of xorg.conf remove it.
    ( make sure its al back to basic, like new install )
    cd /etc/X11
    X -configure

    3) unpack downloaded drivers, and run

    reboot the server.

    4) touch wil work now, but things are not right. ( for me x-y mouse was incorrect )
    to fix this.
    login in X, In Aplications-Accessories, you find : eGalaxTouch Utiliy
    Start it and go to tab Tool.
    First do a 4 Pts Calibration, then do 25 points linearization.

    After this every thing was working correct for me.

    hope this helps someone

  8. #38
    Join Date
    Dec 2005

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Quote Originally Posted by ka1axy View Post
    I've just been through the whole eGalax journey with a Xenarc 700TSV display. This thread (and some others) was a major part of my finally getting it working (after an entire day of trying things). I'm writing this to summarize what worked for me on an Asus EB1501, running Lucid 10.4 with the Xenarc display. My system also has a USB/Bluetooth mouse and keyboard. The mouse is extra helpful while trying to get things working, and seems to coexist well with the touchscreen.

    The key steps were:
    - downloading the beta Linux driver (3.03.4510 at this time) from the EETI website:
    - running the unmodified script with sudo
    - rebooting
    - running the eGalaxTouch command after rebooting and selecting USB and disabling right click
    - running the TKCal command and doing a 4-point calibration
    - running xinput -list and note that there were two eGalax input sources
    - adding a startup program: xinput -set-prop "eGalax Inc. Touch" "Device Enabled" 0

    Disabling the second eGalax input device was the key to eliminating the upper-left pointer issue. I'm still working to determine exactly where to run this command during startup, as it sometimes seems to lose its effect, but rerunning it *always* removes the upper-left pointer problem.
    Thanks a lot for the tip on disabling the eGalax device using xinput, it solved my problem with the upper-left pointer. Before this I was planning to discard any mouse event with 0,0 coordinates in my software (I'm developing a custom system).
    In my system, xinput list shows two eGalax devices, one named "egalax" and the second "eGalax Inc. TouchController", disabling the second one fixes the problem. I have placed the xinput calls in my xinitrc file, hope it helps you.
    Last edited by GeoMX; December 20th, 2011 at 01:56 AM.
    The limit is your imagination.
    Visit my blog, in English or Spanish .

Page 4 of 4 FirstFirst ... 234

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts