Page 1 of 2 12 LastLast
Results 1 to 10 of 38

Thread: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

Hybrid View

  1. #1
    Join Date
    Mar 2010
    Beans
    19

    eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    [not sure, but it might work with earlier versions.]

    Without installing the eGalaxTouch support I got everything working great with default evdev setup in ubuntu 10.04 adding these two commands to fix the old problems with rotation / swapped axes. Correct tap behaviour was present out-of-the-box.

    Code:
    xinput set-prop --type=int --format=8 "eGalax Inc. USB  TouchController" "Evdev Axes Swap" 1
    fixed the swap
    If Y is inverted:
    Code:
    xinput set-int-prop "eGalax Inc. USB TouchController" "Evdev Axis Inversion" 8 0 1
    and then calibration:
    Code:
    xinput set-prop --type=int --format=32 "eGalax Inc. USB  TouchController" "Evdev Axis Calibration" 57 1938 162 1979
    to get Your own calibration numbers You need this:
    http://www.freedesktop.org/wiki/Soft...put_calibrator

    building from source:

    #for fresh desktop install You'll need some packages:
    Code:
    sudo apt-get install g++ autoconf libtool xorg-dev
    unpack the calibrator, cd to the folder and run
    Code:
    ./autogen.sh
    make
    cd to the src folder and run
    Code:
     ./xinput_calibrator_x11
    do the clicks and it will write Your config to console.

    binary built on ubuntu 10.04 32bit
    Attachment 156303
    Last edited by naugtur; May 10th, 2010 at 12:00 PM.

  2. #2
    Join Date
    Mar 2006
    Beans
    45

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Does not work for me on Lucid Lynx, full updated and a eGalax Touchscreen (xinput name "eGalax Inc. Touch") in my Samsung NC10

    Tried every hint I found via searchengine (bug reports on this, threads, even a newly developed driver) to get the touchscreen working with evdev (read somwhere this should be more responsive and with much less wakeups than original eGalax driver), nothing works:

    The cursor moves to upper left corner (or somwhere else after trying to calibrate via xinput), calibrate_x11 recognizes only click #1

    Only way to get the touchscreen work with Lucid for me is to use the original 32Bit beta-driver -> "xinput --list" shows 2 eGalax-devices -> deactivate the device managed by evdev (device 13 here)-> calibrate with eGalax tool -> done.

    Do you use any other hints/quirks to get this working with evdev only and Lucid???? Do you use a xorg.conf ?

    I'd love to uninstall the original eGalax driver...
    Ubuntu Lucid Lynx @ 10,4" Travelmate C110 TabletPC, 1Ghz, 1.5GB RAM, no fan
    Ubuntu Lucid Lynx @ Samsung NC10, Touchscreen

  3. #3
    Join Date
    Dec 2008
    Location
    Johannesburg, South Afric
    Beans
    19
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    I'm facing the same problem as the person above.

    I have a Lilliput EBY701, using eGalax drivers, on a desktop computer.

    I can only calibrate to one point, and even before doing this, regardless where I touched, the pointer would remain in the upper-left position of the screen.

    Could you please mark this thread as unsolved? Thanks

  4. #4
    Join Date
    Jan 2010
    Location
    Brisvegas, QLD, AU
    Beans
    13
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Quote Originally Posted by merajchhaya View Post
    I'm facing the same problem as the person above.

    I have a Lilliput EBY701, using eGalax drivers, on a desktop computer.

    I can only calibrate to one point, and even before doing this, regardless where I touched, the pointer would remain in the upper-left position of the screen.

    Could you please mark this thread as unsolved? Thanks
    +1

    I got a Gigabyte T1028x (eGalax touch screen) and get this "jump to top left" behaviour since upgrading to 10.04.

    In 9.10 UNR I got the touch screen working fine using these instructions:
    http://samiux.blogspot.com/2009/12/h...te-t1028x.html

    I attempted to use those again to no avail in 10.04.

    I notice that I don't get the "Calibrate Touchscreen" option under administration anymore either even after following the instructions in the link.

  5. #5
    Join Date
    Nov 2006
    Beans
    22

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Im having some issues after updating too.

    xinput set-prop --type=int --format=32 "eGalax Inc. USB TouchController" "Evdev Axis Calibration" 57 1938 162 1979
    unable to find device eGalax Inc. USB TouchController

    I tried it through the /dev/input/by-id/usb...etc got the same result

    using the attatchment calibrator of Naugter recognized the points very good, but didnt seem to write.

    In 9.10 i ended up manually editing my numbers in the evtouch configuration file. Is that still being used in 10.04?

    Only way to get the touchscreen work with Lucid for me is to use the original 32Bit beta-driver -> "xinput --list" shows 2 eGalax-devices -> deactivate the device managed by evdev (device 13 here)-> calibrate with eGalax tool -> done.
    How did u do that? cause i cant use it at all now.....

  6. #6
    Join Date
    Mar 2006
    Beans
    45

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    First of all: using the original egalax driver is suboptimal for me as the touchscreen stops working after a while, using it with easystroke somehow causes the touchscreen to quit working, too. That's the reason I'm trying to get the touchscreen to work with evdev/evtouch...

    Original egalax driver:

    1) Download and extract the driver
    2) Create xorg.conf if does not exist
    3) Install original driver via setup.sh

    3.1) Edit xorg.conf, section for mouse changed to use numbered input device instead of "dev/input/mice", egalax driver to use "/dev/usb/hiddev0":

    Code:
    Section "ServerLayout"
    	Identifier     "X.org Configured"
    	Screen      0  "Screen0" 0 0
            InputDevice "EETI" "CorePointer"
    	InputDevice    "Mouse0" "CorePointer"
    	InputDevice    "Keyboard0" "CoreKeyboard"
    EndSection
    
    Section "ServerFlags" 
    	Option "BlankTime" "5" 
    	Option "StandbyTime" "0" 
    	Option "SuspendTime" "0" 
    	Option "OffTime" "0" 
    EndSection
    
    Section "Files"
    	ModulePath   "/usr/lib/xorg/modules"
    	FontPath     "/usr/share/fonts/X11/misc"
    	FontPath     "/usr/share/fonts/X11/cyrillic"
    	FontPath     "/usr/share/fonts/X11/100dpi/:unscaled"
    	FontPath     "/usr/share/fonts/X11/75dpi/:unscaled"
    	FontPath     "/usr/share/fonts/X11/Type1"
    	FontPath     "/usr/share/fonts/X11/100dpi"
    	FontPath     "/usr/share/fonts/X11/75dpi"
    	FontPath     "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
    	FontPath     "built-ins"
    EndSection
    
    Section "Module"
    	Load  "dri"
    	Load  "dbe"
    	Load  "glx"
    	Load  "dri2"
    	Load  "extmod"
    	Load  "record"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Keyboard0"
    	Driver      "kbd"
    EndSection
    
    Section "InputDevice"
    	Identifier  "Mouse0"
    	Driver      "mouse"
    	Option	    "Protocol" "auto"
    	Option	    "Device" "/dev/input/event8"
    	Option	    "ZAxisMapping" "4 5 6 7"
    EndSection
    
    Section "Monitor"
    	Identifier   "Monitor0"
    	VendorName   "Monitor Vendor"
    	ModelName    "Monitor Model"
    EndSection
    
    Section "Device"
            ### Available Driver options are:-
            ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
            ### <string>: "String", <freq>: "<f> Hz/kHz/MHz"
            ### [arg]: arg optional
            #Option     "NoAccel"            	# [<bool>]
            #Option     "SWcursor"           	# [<bool>]
            #Option     "ColorKey"           	# <i>
            #Option     "CacheLines"         	# <i>
            #Option     "Dac6Bit"            	# [<bool>]
            #Option     "DRI"                	# [<bool>]
            #Option     "NoDDC"              	# [<bool>]
            #Option     "ShowCache"          	# [<bool>]
            #Option     "XvMCSurfaces"       	# <i>
            #Option     "PageFlip"           	# [<bool>]
    	Identifier  "Card0"
    	Driver      "intel"
    	VendorName  "Intel Corporation"
    	BoardName   "Mobile 945GME Express Integrated Graphics Controller"
    	BusID       "PCI:0:2:0"
    EndSection
    
    Section "Screen"
    	Identifier "Screen0"
    	Device     "Card0"
    	Monitor    "Monitor0"
    	SubSection "Display"
    		Viewport   0 0
    		Depth     1
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     4
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     8
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     15
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     16
    	EndSubSection
    	SubSection "Display"
    		Viewport   0 0
    		Depth     24
    	EndSubSection
    EndSection
    
    ### Touch Configuration Beginning ###
    Section "InputDevice"
            Identifier "EETI"
            Driver "egalax"
    	Option "Device" "usbauto"
            Option "Device" "/dev/usb/hiddev0"
            Option "Parameters" "/var/lib/eeti.param"
            Option "ScreenNo" "0"
            Option "SkipClick" "0"
    EndSection
    ### Touch Configuration End ###
    4) Reboot
    5) Run "xinput --list" in (gnome-)terminal, there should be some touchscreen devices, found "egalax" and 2 times "eGalax Inc. Touch" in the list. "egalax" is the new xorg.conf defined original driver and I had to deactivate the other devices via
    6) "xinput -set-prop 11 "Device Enabled" 0", 11 is the device id provided by the "xinput --list" command, instead of the number the id string could be used, too.
    7) "sudo eGalaxTouch" to do the calibrating stuff.

    After this the touchscreen works for a while, then stops working, after a reboot the calibration is ok, after deacticating the other devices the touchscreen works for a while,...

    Alternative method to stop xorg from loading evdev for the two unneccessary devices ist to edit "/usr/lib/X11/xorg.conf.d/05-evdev.conf" and change the two touchscreen relevant sections at the end of the file (commented them out so only device created is the one defined in xorg.conf -> "egalax").

    Did anybody get this to work with evdev driver only??
    Last edited by cywhale; May 22nd, 2010 at 01:20 PM.
    Ubuntu Lucid Lynx @ 10,4" Travelmate C110 TabletPC, 1Ghz, 1.5GB RAM, no fan
    Ubuntu Lucid Lynx @ Samsung NC10, Touchscreen

  7. #7
    Join Date
    Mar 2006
    Beans
    45

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Ok then...

    made my "Egalax Inc. Touch" (-screen) work with module "usbtouchscreen":

    Preferences: Fully updated Ubuntu Lucid Lynx, Samsung NC10, Touchscreen \w Xinput-ID "Egalax Inc. Touch"

    1) Edited /etc/default/grub adding "usbhid.quirks=0xeef:0x1:0x40" to the boot parameters line so it looks like this:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash usbhid.quirks=0xeef:0x1:0x40"
    Then "sudo update-grub" in (gnome-)terminal.

    2) Edited /etc/modules, inserting
    Code:
    usbtouchscreen
    usbhid
    right after the line containing "lp". Important: "usbtouchscreen" MUST be loaded before "usbhid"

    3) Reboot

    4) Calibration using xinput_calibrator_x11 from first post in this thread

    That's it. The touchscreen seems to work as intended, left-click, moving windows, using easystroke, drawing with xournal - all simple tests are looking good.

    Does anybody know how to get right-click functionality by touching > 3sec. with module usbtouchscreen ?

    All the used hints above were gathered in many searches about the egalax touchscreen, it seems i never tried the right/working combination...
    Last edited by cywhale; May 22nd, 2010 at 10:12 PM.
    Ubuntu Lucid Lynx @ 10,4" Travelmate C110 TabletPC, 1Ghz, 1.5GB RAM, no fan
    Ubuntu Lucid Lynx @ Samsung NC10, Touchscreen

  8. #8
    Join Date
    May 2006
    Beans
    43
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Quote Originally Posted by aeqel View Post
    In 9.10 UNR I got the touch screen working fine using these instructions:
    http://samiux.blogspot.com/2009/12/h...te-t1028x.html

    I attempted to use those again to no avail in 10.04.
    I looked at that link, and it's obvious that it does not work in 10.04 since hal is not used anymore (deprecated) and since they use hal rules inthere...

    But I adapted it to 10.04 (with xorg.conf.d) and it works for my touchscreen!!!
    I have a Samsung Q1 ultra. My touchscreen is a
    ID 0eef:0001 D-WAV Scientific Co., Ltd eGalax TouchScreen
    as reported by lsusb
    and udev reports it as Touchkit Touch (that's how I found it in Xorg.0.log)

    So here's the configuration I added to /usr/lib/X11/xorg,conf.d:
    file name 11-touchkit.conf

    Code:
    Section "InputClass"
    	Identifier "Touchkit Touch"
    	MatchIsTablet	"on"
    	MatchDevicePath "/dev/input/event*"
    	Driver 	"evtouch"
    	Option	"ReportingMode"	"Raw"
    	Option	"Emulate3Buttons"
    	Option	"Emultate3Timeout"	"50"
    	Option	"SendCoreEvents"	"On"
    	Option	"TapTimer"		"200"
    	Option	"LongTouchTimer"	"400"
    	Option	"MinX"			"145"
    	Option	"MinY"			"193"
    	Option	"MaxX"			"3973"
    	Option	"MaxY"			"3898"
    EndSection
    I got those evtouch options out of an old xorg.conf file from a configuration package specially made for a q1ultra which existed in the ubuntu 8.04 time.
    And now it runs perfectly!!!
    I also calibrated it using the utility in the first post, but I don't think that was necessary.

    Thanks everybody for your contributions
    I'm glad I got everything together finally
    And I hope that it can be of use to anyone

    Edit: To be clear to anyone, I also was troubled by the cursor stuck in upper left corner 'bug' after clicking once. So I can advice everyone with that problem to install xserver-xorg-input-evtouch and add a file like mine to the directory xorg.conf.d
    Last edited by border; June 8th, 2010 at 09:40 PM.

  9. #9
    Join Date
    Jun 2010
    Beans
    1

    Smile Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Worked a treat on my eeePC 701 and I had almost given up and was getting ready to get rid of the touchscreen

    Just one comment, if just copy and pasting from the original post there is an additional space between USB and TouchController which I needed to remove

  10. #10
    Join Date
    Jun 2010
    Location
    Russia
    Beans
    11
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: eGalax touchscreen setup and calibration in Ubuntu Lucid (with calibration tool)

    Hi!
    Works for me too Many thanks, border!

    Off: by the way, does anybody know correct keyboard mapping name for Q1U (or how to tune default)?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •