Results 1 to 2 of 2

Thread: upgrade from 8.4 to 9.10 problems

  1. #1
    Join Date
    Feb 2010
    Beans
    14

    upgrade from 8.4 to 9.10 problems

    I just upgraded to 9.10 and now my software builds do not compile.

    pkg-config --cflags gtk+-2.0

    no longer works because it can no longer find the gtk+-2.0 package.

    Did this change between versions? Why did upgrading to a newer version uninstall the older libraries? I cannot even find ANY newer version!! gtk+-2.1 ?? 2.2 perhaps??

    Why didn't the upgrade at least inform me that I would have to upgrade all of my software development makefiles?

    What gtk+ version was installed in ubuntu 9.10 and where is it located?

    Thanks,

    -Andres

  2. #2
    Join Date
    Mar 2010
    Location
    Freedom 3
    Beans
    379
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: upgrade from 8.4 to 9.10 problems

    From what I see the version in 9.10 is 2.0. You may have to install the `libgtk2.0-dev' package to get the functionality you want; I don't think it is installed by default.

    Open the Synaptic Package Manager and enter `libgtk2.0' on the Quick Search Box; it will show all related packages.
    To suppress free speech is a double wrong. It violates the rights of the hearer as well as those of the speaker.
    Free Software - Free Society | The GNU Project | FSF | ESP

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •