Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: HP DV6000 Webcam not getting detected in Ubuntu 10.04 (Lucid Lynx)

  1. #1
    Join Date
    May 2010
    Beans
    1

    Angry HP DV6000 Webcam not getting detected in Ubuntu 10.04 (Lucid Lynx)

    I have a HP DV6000 series laptop and its integrated webcam is not getting detected in Ubuntu 10.04
    lsusb
    Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 002: ID 05ca:1870 Ricoh Co., Ltd Webcam 1000
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    I tried checking with :
    xawtv /dev/video0
    This gives me following error :

    This is xawtv-3.95.dfsg.1, running on Linux/i686 (2.6.32-21-generic)
    xinerama 0: 1280x800+0+0
    WARNING: No DGA direct video mode for this display.
    can't open /dev/video0: No such device or address
    v4l-conf had some trouble, trying to continue anyway
    v4l2: open /dev/video0: No such device or address
    v4l2: open /dev/video0: No such device or address
    v4l: open /dev/video0: No such device or address
    no video grabber device available

    Could someone please help me on this?

    -Mithil

  2. #2
    Join Date
    Jan 2010
    Location
    Hyderabad, AP, India
    Beans
    14
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: HP DV6000 Webcam not getting detected in Ubuntu 10.04 (Lucid Lynx)

    This post says it has been solved.

    But i am not understanding it.

    can you help me by understanding it.

    http://ubuntuforums.org/showthread.p...egrated+webcam


    Thanks.

  3. #3
    Join Date
    Sep 2009
    Beans
    2,333

    Re: HP DV6000 Webcam not getting detected in Ubuntu 10.04 (Lucid Lynx)

    most webcams just work now days no need to install drivers
    in/on 910 and up cheese webcam booth is installed
    look in sound and video for it
    try the cam in cheese first

    hope this helps

  4. #4
    Join Date
    Aug 2010
    Beans
    4

    Re: HP DV6000 Webcam not getting detected in Ubuntu 10.04 (Lucid Lynx)

    I have the exact same problem and can't find a solution anywhere.

    I'm running Lucid Lynx 10.04 on a HP Pavillion DV6000 with a built in Ricoh Webcam

    My lsusb gives me:
    Bus 002 Device 002: ID 03f0:171d Hewlett-Packard Wireless (Bluetooth + WLAN) Interface [Integrated Module]
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 003: ID 05ca:1870 Ricoh Co., Ltd Webcam 1000
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

    Cheese says No Device Found.
    It doesn't work on Skype and XawTV doesn't seem to work at all.

    I tried to do
    sudo apt-get install r5u87x
    but nothing has changed

    I've also tried a few other things to install r5u87x but no luck.

    All the solved problems seems to only work for r5u870 devices. I don't know enough about computers to know if mine is different. I only know that those fixes don't work for me.

    I'm new at linux, but if someone can give me some straight forward advice I think I'm competent enough to give it a shot. Let me know if more info is needed.

  5. #5
    Join Date
    Jul 2008
    Beans
    39
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: HP DV6000 Webcam not getting detected in Ubuntu 10.04 (Lucid Lynx)

    I followed the directions on this page on Lucid Lynx, and now my camera works:
    https://launchpad.net/~r5u87x-loader/+archive/ppa

    Hope this helps.

  6. #6
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: HP DV6000 Webcam not getting detected in Ubuntu 10.04 (Lucid Lynx)


  7. #7
    Join Date
    Aug 2010
    Beans
    4

    Re: HP DV6000 Webcam not getting detected in Ubuntu 10.04 (Lucid Lynx)

    SteveMcQwark
    I have tried that solution a few times, but as I said, I don't think my camera is the R5U87x, but rather the 1000 (???)

    lidex
    I have just tried following those instructions (A) again and got this result:

    sudo apt-get install luvcview
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    luvcview is already the newest version.
    0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

    sudo modprobe uvcvideo
    luvcview -d /dev/video0 -f yuv -s 640x480
    luvcview 0.2.6

    SDL information:
    Video driver: x11
    A window manager is available
    Device information:
    Device path: /dev/video0
    ERROR opening V4L interface: No such file or directory

    (B) is again about the R5U87x webcam and a different HP model and has so far not worked.

    I read somewhere that Windows might have 'blocked' access to the webcam, but Windows is not longer installed on this laptop - only Ubuntu. Any ideas about that?

    Thank you both for trying!

  8. #8
    Join Date
    Sep 2009
    Beans
    2,333

    Re: HP DV6000 Webcam not getting detected in Ubuntu 10.04 (Lucid Lynx)

    this is your webcam

    Bus 001 Device 003: ID 05ca:1870 Ricoh Co., Ltd Webcam 1000


    type webcam
    in a terminal see what comes up

  9. #9
    Join Date
    May 2008
    Location
    Ohio, USA
    Beans
    6,905
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: HP DV6000 Webcam not getting detected in Ubuntu 10.04 (Lucid Lynx)

    Maybe installing this will help:
    Code:
    sudo apt-get install xserver-xorg-video-v4l

  10. #10
    Join Date
    Aug 2010
    Beans
    4

    Re: HP DV6000 Webcam not getting detected in Ubuntu 10.04 (Lucid Lynx)

    Well, my laptop broke down so I never got to check out the latest suggestion. Shame.
    Thank for the help though!

    Now on to dual boot with Vista on my PC

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •