Results 1 to 8 of 8

Thread: 10.4 apt-get install openssh-server failure

  1. #1
    Join Date
    Apr 2010
    Beans
    84

    10.4 apt-get install openssh-server failure

    I'm trying to get openssh-server working so I can stop using the family TV and just SSH from my laptop. I've only just installed 10.4 server edition, and I've made a change to /etc/apt/sources.lst by removing the # in front of
    deb cdrom:[Ubuntu-Server 10.04 LTS ...

    Anyway I run:
    sudo apt-get install openssh-server

    Code:
    Reading package lists... Done
    Building dependancy tree
    Reading state information... Done
    The following extra packages will be installed:
      libwrap0 tcpd
    Suggested packages:
      ssh-askpass rssh molly-guard openssh-blacklist openssh-blacklist-extra
    The following NEW packages will be installed:
      libwrap0 openssh-server tcpd
    0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B/409kB of archives.
    After this operation, 1,126kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Err cdrom://Ubuntu-Server 10.04 LTS _Lucid Lynx_ - Release amd64 (20100427)/ lucid/main openssh-server 1:5.3p1-3ubuntu3
      File not found
    Err cdrom://Ubuntu-Server 10.04 LTS _Lucid Lynx_ - Release amd64 (20100427)/ lucid/main tcpd 7.6.q-18
      File not found
    Failed to fetch cdrom:[[Ubuntu-Server 10.04 LTS _Lucid Lynx_ - Release amd64 (20100427)]/pool/main/o/openssh/openssh-server_5.3p1-3ubuntu3_amd64.deb  File not found
    Failed to fetch cdrom:[[Ubuntu-Server 10.04 LTS _Lucid Lynx_ - Release amd64 (20100427)]/pool/main/t/tcp-wrappers/tcpd_7.6.q-18_amd64.deb  File not found
    #: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
    Firstly, what's "Suggested packages" mean?

    Anyway, so I run "sudo apt-get update" then
    sudo apt-get install openssh-server --fix-missing

    Code:
    Reading package lists... Done
    Building dependancy tree
    Reading state information... Done
    The following extra packages will be installed:
      libwrap0 tcpd
    Suggested packages:
      ssh-askpass rssh molly-guard openssh-blacklist openssh-blacklist-extra
    The following NEW packages will be installed:
      libwrap0 openssh-server tcpd
    0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
    Need to get 0B/409kB of archives.
    After this operation, 1,126kB of additional disk space will be used.
    Do you want to continue [Y/n]? y
    Err cdrom://Ubuntu-Server 10.04 LTS _Lucid Lynx_ - Release amd64 (20100427)/ lucid/main openssh-server 1:5.3p1-3ubuntu3
      File not found
    Err cdrom://Ubuntu-Server 10.04 LTS _Lucid Lynx_ - Release amd64 (20100427)/ lucid/main tcpd 7.6.q-18
      File not found
    Failed to fetch cdrom:[[Ubuntu-Server 10.04 LTS _Lucid Lynx_ - Release amd64 (20100427)]/pool/main/o/openssh/openssh-server_5.3p1-3ubuntu3_amd64.deb  File not found
    Failed to fetch cdrom:[[Ubuntu-Server 10.04 LTS _Lucid Lynx_ - Release amd64 (20100427)]/pool/main/t/tcp-wrappers/tcpd_7.6.q-18_amd64.deb  File not found
    Selecting previously deselected package libwrap0.
    (Reading database ... 41523 files and directories currently installed.)
    Unpacking libwrap0 (from .../libwrap0_7.6.q-18_amd64.deb) ...
    Setting up libwrap0 (7.6.q-18) ...
    
    Processing triggers for libc-bin
    ldconfig deferred processing now taking place
    So I have no idea what to do to get it working.

  2. #2
    Join Date
    May 2007
    Location
    The New Forest
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: 10.4 apt-get install openssh-server failure

    Go to your software sources in System > Admin.

    Disable the cdrom entry and reload.

    Should be ok then.

  3. #3
    Join Date
    Apr 2010
    Beans
    84

    Re: 10.4 apt-get install openssh-server failure

    Thanks for you're quick reply.

    I'm in just a command line interface, so there's no menu's, but I #'d the deb cdrom line in /etc/apt/sources.lst

    /etc/apt/sources.lst doesn't exist anymore...? I'm sure it was there before? Instead, /etc/apt/sources.list does! WTH?

    Anyway, I run
    Code:
    sudo apt-get update
    sudo apt-get install openssh-server
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    Package openssh-server is not available, but is referred to by another package.
    This may mean that the package is missing, has been obsoleted, or
    is only available from another source
    E: Package openssh-server has no installation candidate
    So I don't think that worked...


    Also, just for my information what's "Suggested packages" mean? And why are they suggested?

  4. #4
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: 10.4 apt-get install openssh-server failure

    No it was always /etc/apt/sources.list. I think you must be confusing the older /boot/grub/menu.lst from legacy grub.

  5. #5
    Join Date
    May 2007
    Location
    The New Forest
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: 10.4 apt-get install openssh-server failure

    Sorry completely I misunderstood you.

    If you actually want to use the cd then you need to remove the # as you did and then make sure the cd is inserted when you run the update and install.

  6. #6
    Join Date
    Apr 2010
    Beans
    84

    Re: 10.4 apt-get install openssh-server failure

    Thanks for the confirmation ajgreeny.

    forestpiskie, the first time I ran it, it had the cd in and had the deb cdrom line un#d.

    The error messages:
    Code:
    Failed to fetch cdrom:[[Ubuntu-Server 10.04 LTS _Lucid Lynx_ - Release amd64 (20100427)]/pool/main/o/openssh/openssh-server_5.3p1-3ubuntu3_amd64.deb  File not found
    Failed to fetch cdrom:[[Ubuntu-Server 10.04 LTS _Lucid Lynx_ - Release amd64 (20100427)]/pool/main/t/tcp-wrappers/tcpd_7.6.q-18_amd64.deb  File not found
    But the CD does have:
    /pool/main/o/openssh/openssh-server_5.3p1-3ubuntu3_amd64.deb (304,142 bytes)
    /pool/main/t/tcp-wrappers/tcpd_7.6.q-18_amd64.deb (71,578 bytes)

  7. #7
    Join Date
    Apr 2010
    Beans
    84

    Re: 10.4 apt-get install openssh-server failure

    I'm completely unsure how this has happened, but for some reason it just works now. Thank you all for your help. I can't understand why its working now and wasn't before!

  8. #8
    Join Date
    Aug 2008
    Location
    Victoria, BC Canada
    Beans
    1,721

    Re: 10.4 apt-get install openssh-server failure

    Its possible a repository was off-line for a bit.
    SERVER: Azure datacenters, Hyper-V

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •