Results 1 to 6 of 6

Thread: Macbook 2,1 Ubuntu 10.04 Keybaord

  1. #1
    Join Date
    May 2010
    Beans
    1

    Macbook 2,1 Ubuntu 10.04 Keybaord

    Running rEFit to dual boot snow leopard and Ubuntu 10.04. I have a black macbook 2,1 model. I have searched everywhere for a guide for this model and have not had any success. For the most part I have been able to configure everything from other guides. I get the following error when trying to change the keyboard to the Mac layout (in order deadkey alt and make the Command or Apple key the major key). Does anyone have any suggestions? Is there any more info I can provide? Thanks.

    Error activating XKB configuration.
    It can happen under various circumstances:
    - a bug in libxklavier library
    - a bug in X server (xkbcomp, xmodmap utilities)
    - X server with incompatible libxkbfile implementation

    X server version data:
    The X.Org Foundation
    10706000

    If you report this situation as a bug, please include:
    - The result of xprop -root | grep XKB
    - The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd
    Last edited by bacord; May 6th, 2010 at 05:32 PM.

  2. #2
    Join Date
    Jan 2009
    Location
    Fremantle, Australia
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Macbook 2,1 Ubuntu 10.04 Keybaord

    Getting the same error on my Macbook Pro 3,1 when running Ubuntu 10.04. I want the ctrl key mapped to the Command/Win/Apple key and vice versa so that I have the same behaviour as I have in Mac OS. So you hit the Apple key to get the Ctrl function and the Ctrl key to get the Super function.

    Trying to do anything with the keyboard options or trying to do anything with xmodmap results in the error:

    Error activating XKB configuration.
    It can happen under various circumstances:
    - a bug in libxklavier library
    - a bug in X server (xkbcomp, xmodmap utilities)
    - X server with incompatible libxkbfile implementation

    X server version data:
    The X.Org Foundation
    10706000

    If you report this situation as a bug, please include:
    - The result of xprop -root | grep XKB
    - The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/kbd


    I see that a bug has been recorded already but is there anything we can do to get around it?

    Thanks

  3. #3
    Join Date
    Jan 2009
    Location
    Fremantle, Australia
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Macbook 2,1 Ubuntu 10.04 Keybaord

    Does anyone know what to do about this error?

  4. #4
    Join Date
    Sep 2007
    Beans
    3

    Re: Macbook 2,1 Ubuntu 10.04 Keybaord

    I had this problem, and after changing my keyboard layout from "USA (Macintosh)" to "USA" I was able to enable the Macbook/MacbookPro keyboard model without an error, but it had no effect on the behavior I'm looking to change (swap the apple key with ctrl).

    Any ideas?

  5. #5
    Join Date
    Jan 2008
    Location
    Netherlands
    Beans
    2,930
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Macbook 2,1 Ubuntu 10.04 Keybaord

    Linux on your Apple Mac │ iLinux
    http://mac.linux.be
    http://www.mintppc.org

  6. #6
    Join Date
    Jan 2009
    Location
    Fremantle, Australia
    Beans
    25
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Macbook 2,1 Ubuntu 10.04 Keybaord

    Quote Originally Posted by AmaranthineNight View Post
    I had this problem, and after changing my keyboard layout from "USA (Macintosh)" to "USA" I was able to enable the Macbook/MacbookPro keyboard model without an error, but it had no effect on the behavior I'm looking to change (swap the apple key with ctrl).

    Any ideas?
    Everything I've tried works temporarily at best. In the end I gave up and learnt to use it the "normal" non-mac way.


Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •