Okay, so I tried hitting up Update Manager to upgrade from Karmic to Lucid (apparently that's the sissy way to do it, but whatever). So, it starts doing its thing... and then a window pops up saying it can only do a "partial upgrade".

So I smell a rat, and go a-Googling. Most of the threads I've seen seem to refer to the Alpha/Beta versions, and all just advise waiting a little while to see if the issue clears itself up. This I will do, but in the meantime, I booted up the terminal and tried using apt-get. Maybe I'd get an error message or something:

Code:
aaron@aaron-desktop:~$ sudo apt-get update && sudo apt-get upgrade
Hit http://security.ubuntu.com karmic-security Release.gpg
Ign http://security.ubuntu.com karmic-security/main Translation-en_US
Ign http://security.ubuntu.com karmic-security/restricted Translation-en_US
Hit http://us.archive.ubuntu.com karmic Release.gpg                  
Ign http://us.archive.ubuntu.com karmic/main Translation-en_US       
Ign http://us.archive.ubuntu.com karmic/restricted Translation-en_US 
Hit http://packages.medibuntu.org karmic Release.gpg                 
Ign http://packages.medibuntu.org karmic/free Translation-en_US      
Ign http://packages.medibuntu.org karmic/non-free Translation-en_US  
Ign http://security.ubuntu.com karmic-security/universe Translation-en_US
Ign http://security.ubuntu.com karmic-security/multiverse Translation-en_US
Hit http://security.ubuntu.com karmic-security Release               
Ign http://us.archive.ubuntu.com karmic/universe Translation-en_US   
Ign http://us.archive.ubuntu.com karmic/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com karmic-updates Release.gpg
Ign http://us.archive.ubuntu.com karmic-updates/main Translation-en_US
Ign http://us.archive.ubuntu.com karmic-updates/restricted Translation-en_US
Ign http://us.archive.ubuntu.com karmic-updates/universe Translation-en_US
Ign http://us.archive.ubuntu.com karmic-updates/multiverse Translation-en_US
Hit http://us.archive.ubuntu.com karmic Release                      
Hit http://packages.medibuntu.org karmic Release                               
Hit http://security.ubuntu.com karmic-security/main Packages         
Hit http://us.archive.ubuntu.com karmic-updates Release
Hit http://packages.medibuntu.org karmic/free Packages                         
Hit http://security.ubuntu.com karmic-security/restricted Packages   
Hit http://security.ubuntu.com karmic-security/main Sources          
Hit http://security.ubuntu.com karmic-security/restricted Sources    
Hit http://security.ubuntu.com karmic-security/universe Packages     
Hit http://security.ubuntu.com karmic-security/universe Sources      
Hit http://security.ubuntu.com karmic-security/multiverse Packages   
Hit http://security.ubuntu.com karmic-security/multiverse Sources    
Hit http://us.archive.ubuntu.com karmic/main Packages                
Hit http://us.archive.ubuntu.com karmic/restricted Packages
Hit http://us.archive.ubuntu.com karmic/main Sources
Hit http://us.archive.ubuntu.com karmic/restricted Sources
Hit http://us.archive.ubuntu.com karmic/universe Packages
Hit http://packages.medibuntu.org karmic/non-free Packages
Hit http://us.archive.ubuntu.com karmic/universe Sources
Hit http://us.archive.ubuntu.com karmic/multiverse Packages
Hit http://us.archive.ubuntu.com karmic/multiverse Sources
Hit http://us.archive.ubuntu.com karmic-updates/main Packages
Hit http://us.archive.ubuntu.com karmic-updates/restricted Packages
Hit http://us.archive.ubuntu.com karmic-updates/main Sources
Hit http://us.archive.ubuntu.com karmic-updates/restricted Sources
Hit http://us.archive.ubuntu.com karmic-updates/universe Packages
Hit http://us.archive.ubuntu.com karmic-updates/universe Sources
Hit http://us.archive.ubuntu.com karmic-updates/multiverse Packages
Hit http://us.archive.ubuntu.com karmic-updates/multiverse Sources
Reading package lists... Done
Reading package lists... Done
Building dependency tree       
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

aaron@aaron-desktop:~$ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
...um, wasn't that supposed to also do the 9.10->10.04 upgrade? Is there something else screwy going on? And, while I'm on the subject, is there something buggy with the released 10.04, that's giving me only a partial upgrade, or is the problem on my end?