Page 3 of 3 FirstFirst 123
Results 21 to 28 of 28

Thread: Ubuntu 10.04 Login Loop

  1. #21
    Join Date
    May 2009
    Beans
    5

    Re: Ubuntu 10.04 Login Loop

    I had this issue, and the suggestion to install gnome-session again was it. I realized when doing so, it was reinstalling evolution, which I removed out of spite because it has let me down more often than not. Seems a bug that it would remove gnome-session for evolution, enough to break the desktop. I'm sure I'm not the only one that hates evolution enough to inadvertently kill their desktop. sudo apt-get install gnome-session Evolution might not be the only thing dangerously removing gnome-session the only dependency.

  2. #22
    Join Date
    Aug 2009
    Beans
    27

    Smile Re: Fixed on my machine!

    Quote Originally Posted by bitter_mike View Post
    Ok, so good news and bad news. Good news: I got this fixed on my computer. Bad news: its a pain in the ***. Here's how I did it:

    step 1: Re-install GDM.

    ...

    step 2: Install gnome-session

    ...

    step 3: Install the applet again.
    Thanks so much sir! Worked a treat for me.

  3. #23
    Join Date
    Apr 2006
    Beans
    1
    Distro
    Dapper Drake Testing/

    Re: Fixed on my machine!

    Quote Originally Posted by bitter_mike View Post
    Ok, so good news and bad news. Good news: I got this fixed on my computer. Bad news: its a pain in the ***. Here's how I did it:

    Important note: I noticed that the menu for selecting a Gnome session was gone from the login menu before I got the idea to do this.

    step 1: Re-install GDM.

    Boot up normally, then press control+alt+f3 to get to a TTY login window and login. From there, execute the following command to stop GDM:

    Code:
    sudo service gdm stop
    Then, use apt-get to first remove, then re-install the gdm package.

    At this stage, restarting GDM and logging in got me to a blank desktop with a cursor and a single terminal window in the upper-right hand corner. There was still no sessions menu at the logon page; just keyboard and language selection.

    step 2: Install gnome-session

    For some reason this package is not installed when you re-install GDM. As far as I can tell, it actually enables GDM to run the desktop environment session with menu bars and such. From that tty window, use apt-get to install gnome-session.

    At this stage, when I logged it, everything worked fine except it threw an error about not being able to load the fast-user-switcher applet.

    step 3: Install the applet again.

    Just use apt-get to install the package indicator-applet-session. This fixed my problems completely and I'm not back to my normal desktop.

    If this works for anyone else with the problem, go ahead and mark it solved.
    It worked for me either, thanks

  4. #24
    Join Date
    Jul 2010
    Location
    Minnesota
    Beans
    16
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question Re: Ubuntu 10.04 Login Loop

    Quote Originally Posted by cato58 View Post
    This is how I fixed this problem on my computer:


    During the boot up, hit ctrl-alt-F1 for a tty login

    Use these commands:

    sudo stop gdm
    sudo apt-get purge gdm
    sudo apt-get install wdm
    sudo reboot now
    In another post in this thread, it has it as ctrl-alt-f3. Which one is it: f1 or f3? I've also been having the same problem of the login looping. And, yes, I am a noob! Thanks!
    Last edited by Penny N. Nickels; July 18th, 2010 at 06:08 PM.

  5. #25
    Join Date
    Jul 2007
    Location
    Madagascar
    Beans
    18
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Ubuntu 10.04 Login Loop

    Quote Originally Posted by cato58 View Post
    This is how I fixed this problem on my computer:


    During the boot up, hit ctrl-alt-F1 for a tty login

    Use these commands:

    sudo stop gdm
    sudo apt-get purge gdm
    sudo apt-get install wdm
    sudo reboot now
    Please Help!

    I tried this

    after
    sudo apt-get install wdm

    I get the following message

    Reading Package Lists ... Done
    Building dependancy tree ... Done
    Reading State information ... Done
    Package wdm is not available etc...
    E: Package wdm has no installation candidate
    What do I do now?
    O yes, I am a noobs noob!

    PS That pc is not connected to the www. Wil not be connected. Ever. If that is relevant.
    Last edited by ClrScr; August 26th, 2010 at 02:26 PM.

  6. #26
    Join Date
    Jul 2007
    Location
    Madagascar
    Beans
    18
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Fixed on my machine!

    Quote Originally Posted by bitter_mike View Post
    Ok, so good news and bad news. Good news: I got this fixed on my computer. Bad news: its a pain in the ***. Here's how I did it:

    Important note: I noticed that the menu for selecting a Gnome session was gone from the login menu before I got the idea to do this.

    step 1: Re-install GDM.

    Boot up normally, then press control+alt+f3 to get to a TTY login window and login. From there, execute the following command to stop GDM:

    Code:
    sudo service gdm stop
    Then, use apt-get to first remove, then re-install the gdm package.

    At this stage, restarting GDM and logging in got me to a blank desktop with a cursor and a single terminal window in the upper-right hand corner. There was still no sessions menu at the logon page; just keyboard and language selection.

    step 2: Install gnome-session

    For some reason this package is not installed when you re-install GDM. As far as I can tell, it actually enables GDM to run the desktop environment session with menu bars and such. From that tty window, use apt-get to install gnome-session.

    At this stage, when I logged it, everything worked fine except it threw an error about not being able to load the fast-user-switcher applet.

    step 3: Install the applet again.

    Just use apt-get to install the package indicator-applet-session. This fixed my problems completely and I'm not back to my normal desktop.

    If this works for anyone else with the problem, go ahead and mark it solved.
    Mike, please be so kind as to add the code to all the steps so that I can try this out.
    Thanks

  7. #27
    Join Date
    Sep 2007
    Beans
    615
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Ubuntu 10.04 Login Loop

    Hi all,

    I just wanted to share my own encounter with this login loop.

    Before doing anything without knowing what was causing the issue I used CTRL+ALT+F1 and tried loggin into TTY (command prompt) with success. I then did "service gdm stop" followed by "service gdm start" and saw that the first thing my system tried to do was find /usr/lib/oracle/ex/product/...blah blah some file.

    The problem was that the file didn't exist because I had removed oracle the night before. Even after deleting the lines from my .bashrc file that exported the path to oracle, something in my system was still trying to open the non-existing path. In my case I had installed oracle with su - but when I removed it I used synaptic and chose the "completely remove" option. It failed to tell me that something residual was left in the system.

    The fix was to log in as root in the command prompt and then reinstall oracle. Well that was what it took to get me back into gdm anyway. Now I have to figure out how to remove oracle without it causing the login loop again.

    The point of sharing this is to say that you should try logging in to TTY and see if you get any clue as to what is actually causing the problem before trying random fixes.

  8. #28
    Join Date
    Oct 2007
    Beans
    9

    Re: Ubuntu 10.04 Login Loop

    It doesn't matter either way, whether you use CTRL+ALT+F3 or CTRL+ALT+F1. On *most* Linux systems, regardless of distribution, you will find multiple TTYs... usually associated against CTRL+ALT+F1~F6. CTRL+ALT+F7 usually takes you to the TTY that Xwindows is loading on.

    Also, provided that you are either using an older version of Ubuntu, or a different Linux distro altogether, you can use CTRL+ALT+Backspace to restart the X-server. However, the last few versions of Ubuntu have dropped this setting from the defaults... it can be re-enabled though.

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •