Results 1 to 10 of 10

Thread: 10.04 Server Virtual Terminal >Display< not working

  1. #1
    Join Date
    Feb 2009

    10.04 Server Virtual Terminal >Display< not working

    Clean install of 10.04 Server 32 bit
    Only services OpenSSH Server and Print Server
    Machine boots and can be accessed through ssh.

    Virtual terminals (cntl-alt-1,2,3,4,... do not result in video to the monitor (no sync) or a display.

    If I type blind, I can log in, ssh back to my other machine, and create a file. So the virtual terminal is there and listening to the keyboard and running, just not creating a display.

    This machine has been working fine with 08.10 for quite time up until yesterday, so I don't believe it is a hardware problem.

    Any ideas why the video on the virtual terminals would not work?


  2. #2
    Join Date
    Feb 2009

    Re: 10.04 Server Virtual Terminal >Display< not working

    Attached is tail tail end of dmesg (Including the nouveau part) from the latest boot. Nothing looks like an error to me. Any other information I could provide?

    (Would not upload as file named dmesg.txt for some reason. At 4300 bytes, it is well under the 19.5K for a text file)

    [ 11.797280] nouveau 0000:01:00.0: PCI INT A -> Link[LNKA] -> GSI 11 (level, low) -> IRQ 11
    [ 11.823880] type=1505 audit(1273022878.611:5): operation="profile_replace" pid=524 name="/sbin/dhclient3"
    [ 11.863376] type=1505 audit(1273022878.651:6): operation="profile_replace" pid=524 name="/usr/lib/NetworkManager/nm-dhcp-client.action"
    [ 11.864831] type=1505 audit(1273022878.655:7): operation="profile_replace" pid=524 name="/usr/lib/connman/scripts/dhclient-script"
    [ 11.876694] [drm] nouveau 0000:01:00.0: Detected an NV30 generation card (0x034200b1)
    [ 11.876972] [drm] nouveau 0000:01:00.0: Attempting to load BIOS image from PROM
    [ 12.009592] [drm] nouveau 0000:01:00.0: ... appears to be valid
    [ 12.010293] [drm] nouveau 0000:01:00.0: BMP BIOS found
    [ 12.010302] [drm] nouveau 0000:01:00.0: BMP version 5.40
    [ 12.010312] [drm] nouveau 0000:01:00.0: Bios version
    [ 12.010324] [drm] nouveau 0000:01:00.0: Found Display Configuration Block version 2.2
    [ 12.010337] [drm] nouveau 0000:01:00.0: Raw DCB entry 0: 01000300 000088b8
    [ 12.010349] [drm] nouveau 0000:01:00.0: Raw DCB entry 1: 01010312 00000000
    [ 12.010358] [drm] nouveau 0000:01:00.0: Raw DCB entry 2: 02010310 000088b8
    [ 12.010367] [drm] nouveau 0000:01:00.0: Raw DCB entry 3: 02020321 00000303
    [ 12.010967] [drm] nouveau 0000:01:00.0: Loading NV17 power sequencing microcode
    [ 12.010978] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 0 at offset 0xEE75
    [ 12.050638] type=1505 audit(1273022878.839:8): operation="profile_load" pid=525 name="/usr/lib/cups/backend/cups-pdf"
    [ 12.053156] type=1505 audit(1273022878.843:9): operation="profile_load" pid=525 name="/usr/sbin/cupsd"
    [ 12.084474] type=1505 audit(1273022878.875:10): operation="profile_load" pid=527 name="/usr/sbin/tcpdump"
    [ 12.169506] EMU10K1_Audigy 0000:00:0c.0: PCI INT A -> Link[LNKC] -> GSI 12 (level, low) -> IRQ 12
    [ 12.204207] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 1 at offset 0xF12A
    [ 12.204230] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 2 at offset 0xF270
    [ 12.204290] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 3 at offset 0xF3F9
    [ 12.204302] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 4 at offset 0xF416
    [ 12.204315] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 5 at offset 0xF433
    [ 12.212205] [drm] nouveau 0000:01:00.0: Parsing VBIOS init table 6 at offset 0xF5CC
    [ 12.271834] [TTM] Zone kernel: Available graphics memory: 383672 kiB.
    [ 12.271886] [drm] nouveau 0000:01:00.0: 128 MiB VRAM
    [ 12.272135] agpgart-intel 0000:00:00.0: AGP 1.0 bridge
    [ 12.273082] agpgart-intel 0000:00:00.0: putting AGP V2 device into 2x mode
    [ 12.273153] nouveau 0000:01:00.0: putting AGP V2 device into 2x mode
    [ 12.273165] [drm] nouveau 0000:01:00.0: 256 MiB GART (aperture)
    [ 12.274363] [drm] nouveau 0000:01:00.0: Allocating FIFO number 0
    [ 12.285894] [drm] nouveau 0000:01:00.0: nouveau_channel_alloc: initialised FIFO 0
    [ 12.285924] [drm] nouveau 0000:01:00.0: Initial CRTC_OWNER is 0
    [ 12.285937] [drm] nouveau 0000:01:00.0: Saving VGA fonts
    [ 12.363416] [drm] nouveau 0000:01:00.0: Detected a VGA connector
    [ 12.365096] [drm] nouveau 0000:01:00.0: Detected a DVI-I connector
    [ 12.365658] [drm] nouveau 0000:01:00.0: Detected a TV connector
    [ 12.367218] [drm] nouveau 0000:01:00.0: Setting dpms mode 3 on vga encoder (output 0)
    [ 12.367231] [drm] nouveau 0000:01:00.0: Setting dpms mode 3 on tmds encoder (output 1)
    [ 12.367243] [drm] nouveau 0000:01:00.0: Setting dpms mode 3 on vga encoder (output 2)
    [ 12.367253] [drm] nouveau 0000:01:00.0: Setting dpms mode 3 on TV encoder (output 3)
    [ 12.648785] [drm] nouveau 0000:01:00.0: allocated 1600x1200 fb: 0x49000, bo ec0bea00
    [ 12.649092] fb0: nouveaufb frame buffer device
    [ 12.649099] registered panic notifier
    [ 12.649117] [drm] Initialized nouveau 0.0.15 20090420 for 0000:01:00.0 on minor 0
    [ 12.691995] vga16fb: initializing
    [ 12.692631] vga16fb: mapped to 0xc00a0000
    [ 12.692651] vga16fb: not registering due to another framebuffer present
    [ 12.871917] [drm] nouveau 0000:01:00.0: Setting dpms mode 0 on vga encoder (output 0)
    [ 12.871935] [drm] nouveau 0000:01:00.0: Output VGA-1 is running on CRTC 0 using output A
    [ 12.937434] Console: switching to colour frame buffer device 200x75

  3. #3
    Join Date
    Feb 2009

    Re: 10.04 Server Virtual Terminal >Display< not working

    KMS (Kernel Mode Setting) was selecting the wrong mode. My monitor said something like "xyz out of range", vs. "no sync". There are countless posts with people having similar problems, mostly with ATI or Intel graphics. Mine is an NVidia card (GeForce FX 5200).

    I simply disabled KMS:

    /etc/default/grub chage:

    one of the posts indicated that you could change the monitor mode by also putting something like "VGA=795" (With various numbers depending on resolution, but this does not appear to work.

    I will never understand why Linux distributions never put out a truly stable and correctly functioning release. I came to Ubuntu because I was driven away from 9 years of SUSE by a steady ramp in focus on bells, whistles, and eye candy that drove the distribution to where it was really really neat but did not work well enough to get ANYTHING done between searching for the solution to bugs. My initial reaction to 08.10 was delight, but each successive release (9.04, 9.10) has been an advancement in features that are valuable but peripheral, and a stream of issues. There are always new things that don't work.

    In a previous thread I was advised that this is what LTS is for, that the new content is slowed down so that it is more reliable/stable/solid than typical. So I waited for 10.04 LTS, planning to run it for two full years. My first experience is that the SERVER flavor of this reliable LTS does not even set my monitor into a visible text mode for the console. To me it displays an insufficiently conservative attitude toward the purpose of an "LTS-Like release to incorporate a NEW capability that requires a section in the release notes titled "Working around bugs in..."

    Perhaps there should be a release that has a conservative philosophy AND *only* bug fixes. Sort of like 9.10 or even 8.10 updated 10.04 to be rock-solid (Heck, people are happily running Windows XP SP2!). Its features may not be the latest and greatest, but hey, having it work reliably is more important. Its features were considered great just a little over a year ago!

    There is a place for Alpha's
    a place for Beta's
    a place for Release Candidates,
    a place for new releases
    and a place for services pack'ed, solid distributions

    Linux would be my first choice to run, the functionality is great, the broad selection of applications is great, the convenient OS features to do ALL KINDS of things easily are great, but I am getting weary of being a never ending Beta tester (12 years now). "It's gunna be good", and it is always better, but the push forward naturally ensures problems. There needs to be a trailing version for the general public that "just works"

    I know that this comment will be offensive to many, but how many people buy a computer to play with it and get a charge out of running a new capability, and how many get a computer as a TOOL? New capabilities are great, when they are mature.

    There are plenty of people who want to run the nightly build, the alphas, betas, the latest sort-of-ready releases.

    Please make a release for people (Which if you really want to compete with M$ and Apple is 95-98%) who want to run their computer as a tool to accomplish something, not to get excited about the computer!

    Anyone who resonates with this message, please repeat it in a constructive manor. Perhaps I am blunt, but it is to make a clear statement. Do we want Linux to be a never ending hobbiest / geek / engineer thing? Or do we want it to become the computer of choice for the general public who needs a computer?

    Incidentaly, Microsoft has the same disease - bells, whistles, and hype, except that in the eyes of the man on the street they are the only choice, linux being for engineers, geeks, geniuses, etc. And they are the best there is, and if nothing else, that is what the entire world runs and they have to run it to be compatible and employable.

    Why are we chasing them to fight the wrong fight? Deliver what *people* need, don't try to out-microsoft-microsoft. Otherwise Linux will may in time win the battle, but they will loose the war.

    Thanks for listening. Please think about it, don't just chuckle and move to the next post.

  4. #4
    Join Date
    Feb 2009

    Re: 10.04 Server Virtual Terminal >Display< not working


    After updating /etc/default/grub, you must run as root:


    for grub2.

    Also note that grub 2 is what 10.04 server installs; I don't know about 10.04 desktop. (This might be a nice thing to add to the release note)

  5. #5
    Join Date
    Jul 2008

    Re: 10.04 Server Virtual Terminal >Display< not working

    Thanks for sharing your work-around, RNSC! I had upgraded from 9.10 to 10.4 LTS with the same high expectations about reliability. I felt equally set-back when I recognized that I just could not access virtual consoles anymore. So I quickly reverted the whole set-up back to 9.10. (I had learnt my lesson in previous such actions to always(!) take an image snapshot of the system partition before upgrading.)
    I do share your feelings about the need for a STABLE solution that does not break basic features (cf. my "lessons learnt" above). Thinking of friends I have or still intend to talk into using Ubuntu instead of Windows, I do hesitate from taking that step because I am afraid that they might just get stuck. Which would be the "perfect catastrophy" in terms of spreading the word.
    On a technical side, I have another question: my Acer C310 also has an nVidia card. I have read posts that after turning off kernel mode setting (which I suppose is what your work-around does, although I am not very knowledgeable in this matter) Compiz did not work anymore. How is this on your system?
    St. Müller, Switzerland

  6. #6
    Join Date
    Feb 2009

    Re: 10.04 Server Virtual Terminal >Display< not working

    sm8ps, My understanding is that what I did simply turned off some kernel code that detects the display instead of X11 code. I suppose it must pass it's decision to X11 and that X11 takes it as truth, since I don't see what could stop X11 from RE-DETECTING the display.

    I have not used compiz... is that the thing where you have multiple displays that you can rotate like a cube to see one side or another?

    If so, that seems to me to be completely independent of identifying your monitor and/or video card. Unless it was written to want to re-detect it AND depend on the kernel to re-detect it.

    So while I don't have direct knowledge of whether the issue I wrote about could be related to your problem with compiz, my reasoning says that it probably is not related.

  7. #7
    Join Date
    Jul 2008

    Re: 10.04 Server Virtual Terminal >Display< not working

    Thank for your quick answer! I did think the same but I thought that maybe you would know. So I shall give another shot at 10.4 then and try for myself. I will soon give a short resume of how it went.
    Indeed, Compiz is just what you described and much more. I really like it a lot although I must admit that I have not made much productive use of it (it allows writing on screen which is potentially very useful for a tablet pc). One thing it has provided very helpful is for a vision-impaired friend (one of those that I did talk into using Ubuntu ...) who much appreciates the various magnification tools included in Compiz.
    He is one that I worry about when I think about any trouble occuring in a major upgrade. It is okay to have someone give you an initial push helping you to get started with Ubuntu or Linux in general. After that the system should just run without the need for any trouble-shooting -- at least what the basic functionalities are concerned with.
    To be fair, I must admit that probably 99% (or even more if one judges from the system maintenance point of view) of Ubuntu does work like that for 99% of all users which is admirable, indeed. Maybe the combination of kernel mode setting and nvidia proprietary drivers and using virtual consoles (which many users do not) is one of the few things that just don't work out of the box and maybe got over-looked.
    St. Müller, Switzerland

  8. #8
    Join Date
    Jan 2010

    Re: 10.04 Server Virtual Terminal >Display< not working

    I am having the same problem on my vaio cw laptop with nvidia geforce 310m gpu (running the latest proprietary driver, 256.35) ... when I try to drop into virtual terminal, the display goes black and seems to shut off completely. I tried the solution posted here, but to no avail ... can someone help me out, or is there no fix for this?

  9. #9
    Join Date
    May 2007
    Winnipeg, Canada
    Ubuntu 10.04 Lucid Lynx

    Re: 10.04 Server Virtual Terminal >Display< not working

    Hmmm ... Just found this problem myself today ...

    I am running 10.4 x86 32-bit on Acer T180 with AMD 3800 and NVidia 6100.

    1) In file /etc/default/grub, I changed:




    2) Then run sudo update-grub.

    3) Then restart.

    I'm very pleased to say it worked for me, but only after rebooting TWICE for some reason.

    Compiz is still working fine.

    Have a nice day ...
    Last edited by mcook2; August 19th, 2010 at 07:54 AM.

  10. #10
    Join Date
    Nov 2011

    Re: 10.04 Server Virtual Terminal >Display< not working

    Bump. Performed the changes above to no avail as well.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts