Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: lubuntu do not detect 3g mobile broadband huawei

  1. #1
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: lubuntu do not detect 3g mobile broadband huawei

    hi

    can you boot up the computer without the modem wait for the system to settle then connect the modem

    post the results of these commands from the terminal

    Code:

    dmesg | grep -e "modem" -e "tty"

    Code:

    lsusb

    thanks in advance

    alexfish
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

  2. #2
    Join Date
    May 2009
    Location
    North West England
    Beans
    2,676
    Distro
    Ubuntu Development Release

    Re: lubuntu do not detect 3g mobile broadband huawei

    Hi, one of the people on the #lubuntu IRC channel has released a work-around for lubuntu 10.04, as the work-around for ubuntu 10.04 does not work with lubuntu. (one day maybe they'll fix it at the kernel level and we can have 3G devices working out of the box as used to happen).

    NM Mobile Broadband workaround

    Lubuntu ships with console PPP dialer wvdial, and menu driven PPP
    configuration utility pppconfig.


    1. wvdialconf/wvdial
    ********************

    Plug in your modem and run "sudo wvdialconf". If everything is ok,
    wvdial will generate a configuration file /etc/wvdial.conf

    Edit this file, uncomment and enter Phone, Password and Username.

    Run "sudo wvdial" to get a connection

    If you need to enter an Access point, add following lines to the
    /etc/wvdial.conf:

    Init1 = ATZ
    Init2 = AT+CGDCONT=1,"IP","your.access.point.name"


    2. pppconfig/pon/poff/plog
    **************************

    Run "sudo pppconfig"

    Select "Create a connection"

    Enter connection name, e.g.: 3g

    Select "Use dynamic DNS"

    Check Authentication Method for provider and hit "Ok"

    Enter username

    Enter password

    Enter port speed

    Select Tone

    Enter phone number, e.g.: #777

    Try autoprobe modem.
    If it fails just enter your modem device, e.g.: /dev/ttyUSB0
    To find out your modem device unplug it/plug it, run "dmesg" and see
    log output.

    Select "Finished Write files and return to main menu"

    Quit

    A new configuration file will be placed in /etc/ppp/peers/ folder.

    Now when you have made a PPP configuration run "sudo pon 3g" to
    initiate connection.
    "3g" is a provider name you've entered before.

    Run "sudo plog" to see connection log output.

    Run "sudo poff" to disconnect.
    Regards,
    Phill.
    Last edited by phillw; May 6th, 2010 at 04:56 PM.

  3. #3
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: lubuntu do not detect 3g mobile broadband huawei

    hi all

    don't know what happen to the original OP , my post was in response to it:

    anyhow , this work around would apply may to any version of Ubuntu if the Network Manager fails to connect , generally the case where the modem has multiple control lines

    this is the reason for the {dmesg | grep -e "modem" -e "tty"} this is important as with wvdial and ppp , you may have to manually enter the ttyX to get the correct connection

    below is an example :

    alexfish@alexfish-desktop:~$ dmesg | grep -e "modem" -e "tty"
    [ 0.000000] console [tty0] enabled
    [ 0.262965] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    [ 0.263234] 00:08: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    [ 22.298251] USB Serial support registered for GSM modem (1-port)
    [ 22.298430] option 1-10:1.0: GSM modem (1-port) converter detected
    [ 22.298610] usb 1-10: GSM modem (1-port) converter now attached to ttyUSB0
    [ 22.298628] option 1-10:1.1: GSM modem (1-port) converter detected
    [ 22.298766] usb 1-10: GSM modem (1-port) converter now attached to ttyUSB1
    [ 22.298787] option 1-10:1.3: GSM modem (1-port) converter detected
    [ 22.298957] usb 1-10: GSM modem (1-port) converter now attached to ttyUSB2
    [ 22.299000] option: v0.7.2:USB Driver for GSM modems
    alexfish@alexfish-desktop:~$

    this modem has TWO control lines ttyUSB1 and ttyUSB2 , in some instances the dialler may select ttyUSB0 or ttyUSB1 automatically, but I know this modem works on ttyUSB2

    you will have to try them, from the results of the {dmesg | grep -e "modem" -e "tty"}

    in response to the above comment (one day maybe they'll fix it at the kernel level and we can have 3G devices working out of the box as used to happen).user could try Sakis3g details can be found here

    How To : Mobile Broadband Connections [ Ubuntu 10.04 : 9.10 : 9.04 ]

    to highlight kernel level problem , I would highlight Modem problem and software problem , one been the modem firmware and the other is the software which connects the modem, it can't be a kernel issue if the modem is detected on the system with the above command

    regards

    alexfish
    Last edited by alexfish; May 13th, 2010 at 08:30 PM. Reason: kernal issue
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

  4. #4
    Join Date
    Jul 2010
    Beans
    5

    Re: lubuntu do not detect 3g mobile broadband huawei

    I have tried your 3G mobile broadband connection setting, but I still cannot connect to the internet. By default, my probe modem is on ttyS0 (cannot connect), and I changed to ttyUSB0, it's still unconnected. From the wvdial output, cannot configure pppd.
    Any one has idea, so my mobile device can be detected by network manager as usual and I can build my network as on ubuntu??
    Last edited by Bagustrix; July 24th, 2010 at 11:07 AM.

  5. #5
    Join Date
    Apr 2005
    Beans
    2,336

    Re: lubuntu do not detect 3g mobile broadband huawei

    turn your computer on; plug your device in;

    open a terminal

    tell us what

    lsusb
    says: copy and paste the results back here;

    ALSO: copy and paste the command below into a terminal

    dmesg | grep tty
    and tell us what you get;

    let's go from there .............

  6. #6
    Join Date
    Oct 2008
    Location
    Krakow, Poland
    Beans
    27

    Re: lubuntu do not detect 3g mobile broadband huawei

    Guys, good news!

    I found out, what is needed, to get the regular Ubuntu method (based on NetworkManager) working. No matter - straight one or workaround with usb_modeswitch.

    The answer is, you just need to install small text-based modem-manager.

    sudo apt-get install modemmanager

    That's it. Works beautifully after restart.

    Greetz, Alex
    Last edited by Alex22; July 31st, 2010 at 10:52 AM.

  7. #7
    Join Date
    Aug 2010
    Beans
    5

    Re: lubuntu do not detect 3g mobile broadband huawei

    Doesn't work for me...
    Since i don't have internet connection via 3g modem, i've downloaded the .deb package in another computer and installed it... and it doesn't work!!

  8. #8
    Join Date
    Apr 2009
    Beans
    20
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: lubuntu do not detect 3g mobile broadband huawei

    @jpxsat
    After you install modemmanager, plug in your 3g modem, and right click your network manager icon down by the clock. You should now see a new checkbox that says enable mobile broadband, if you check that all should work fine. It should throw up a dialog to configure your new 3g connection.

  9. #9
    Join Date
    Jul 2010
    Beans
    18

    Unhappy Re: lubuntu do not detect 3g mobile broadband huawei

    Please help somebody...UBUNTU 10.04
    i have tried many things from wvdial to modswitch but still nothing works for the same issue.....
    Only once it got connected as i mentioned in my earlier post...but after restarting its gone again...
    When i go to System->Preferences->Network Connections and try to add the new Mobile connection, it does not even detect the device...
    Even gnome-ppp and "wvdial netconnect" does not work.....Both are not able to detect the device....
    Below is the Log to clarify things...

    gaurav@gaurav-laptop:/$ lsusb
    Bus 002 Device 005: ID 12d1:1446 Huawei Technologies Co., Ltd.
    Bus 002 Device 003: ID 0bc2:2120 Seagate RSS LLC
    Bus 002 Device 002: ID 8087:0020
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 001 Device 006: ID 413c:8162 Dell Computer Corp.
    Bus 001 Device 005: ID 413c:8161 Dell Computer Corp.
    Bus 001 Device 004: ID 0c45:6417 Microdia
    Bus 001 Device 003: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
    Bus 001 Device 002: ID 8087:0020
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    gaurav@gaurav-laptop:/$ sudo wvdial netconnect
    --> WvDial: Internet dialer version 1.60
    --> Cannot open /dev/ttyUSB0: No such file or directory
    --> Cannot open /dev/ttyUSB0: No such file or directory
    --> Cannot open /dev/ttyUSB0: No such file or directory
    gaurav@gaurav-laptop:/$
    gaurav@gaurav-laptop:/$ gnome-ppp

    (gnome-ppp:8001): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated

    (gnome-ppp:8001): Gtk-WARNING **: GtkSpinButton: setting an adjustment with non-zero page size is deprecated
    WVCONF: /home/gaurav/.wvdial.conf
    GNOME PPP: STDOUT: Editing `/dev/null'.
    GNOME PPP: STDERR: Modem Port Scan<*1>: S0 S1 S2 S3
    GNOME PPP: STDOUT:
    GNOME PPP: STDOUT: Scanning your serial ports for a modem.
    GNOME PPP: STDOUT:
    GNOME PPP: STDOUT:
    GNOME PPP: STDOUT:
    GNOME PPP: STDOUT: Sorry, no modem was detected! Is it in use by another program?
    GNOME PPP: STDOUT: Did you configure it properly with setserial?
    GNOME PPP: STDOUT:
    GNOME PPP: STDOUT: Please read the FAQ at http://open.nit.ca/wiki/?WvDial
    GNOME PPP: STDOUT:
    GNOME PPP: STDOUT: If you still have problems, send mail to <wvdial-list@lists.nit.ca>.

  10. #10
    Join Date
    Apr 2005
    Beans
    2,336

    Re: lubuntu do not detect 3g mobile broadband huawei

    in lsusb when it says

    12d1:1446
    this is the ID of a device that has NOT switched from being seen as storage device;

    go here

    http://packages.debian.org/sid/usb-modeswitch

    go down the page; select the right version of usb_modeswitch (ie i386 for 32bit etc)

    download; install; reboot your system; now plug your device in;

    type

    lsusb
    you should now see

    0x12d1:0x14ac
    ..... or some such number:

    the point is it should be different to the original 1446 ..

    now copy and paste this into a terminal

    dmesg | grep tty
    and hopefully you will see ttyUSB0 or somesuch:

    and you could now configure ..

    any joy?

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •