Page 1 of 4 123 ... LastLast
Results 1 to 10 of 34

Thread: lucid upgrade causes USB automount problems (tips/advice)

  1. #1
    Join Date
    Nov 2006
    Location
    UK
    Beans
    63
    Distro
    Ubuntu Studio 10.04 Lucid Lynx

    lucid upgrade causes USB automount problems (tips/advice)

    I had some trouble after upgrading to Lucid Lynx (10.04) where my USB drives would automount, but were only available to root. Hopefully, this post will help others with similar problems.

    I use Thunar file manager, not Nautilus or Dolphin or anything else except Midnight Commander. Thunar automounts using HAL - but HAL is being pushed aside in favour of udev, as I understand it.

    Ultimately, I found that I had to go into Synaptic and remove the 'usbmount' package, as that was causing my USB drives to mount at /media/usb0, /media/usb1 and so on - and when mounted, it was only as root. It would seem that having usbmount and pmount and HAL causes the automount some kind of permissions problem, and so the device is only available to root.

    I did NOT have the problem where nothing was automounted; USB devices were automounting fine, but only under root.

    I saw a lot of advice about changing udev rules, editing /etc/fstab, changing preferences, group permissions and so on, but none of it helped - the only solution for me was to remove 'usbmount'. I hope this helps someone else Googling for the same issue.

  2. #2
    Join Date
    May 2009
    Beans
    2

    Re: lucid upgrade causes USB automount problems (tips/advice)

    Thank you so much Euchrid - this was driving me (a little bit) crazy.
    Your solution worked!
    Thanks again

  3. #3
    Join Date
    Nov 2005
    Location
    Paris, France
    Beans
    99
    Distro
    Xubuntu 12.10 Quantal Quetzal

    Re: lucid upgrade causes USB automount problems (tips/advice)

    Thanks a lot !!
    At a certain stage in Lucid beta, i had to install usbmount because an update messed the automount thing, and forgot to uninstall it when the devs fixed it.
    Computer Science is no more about computers than astronomy is about telescopes.
    E. W. Dijkstra

  4. #4
    Join Date
    Apr 2009
    Location
    New York
    Beans
    2
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: lucid upgrade causes USB automount problems (tips/advice)

    I have a similar problem, HOWEVER, it is not due to usbmount. I upgraded 9.10 to 10.4 (released) yesterday. Running Gnome/Nautilis on desktop. Upon inserting a usb disk, nothing is automatically mounted, although if I look at the "Computer" file browser window, I do see the inserted device and I can mount it from the properties menu or by double clicking. After several hours of Google searches, I found the following post http://ubuntuforums.org/showthread.php?p=9167961 which was closed when Lucid was released. The cause of the problem was a floppy device that is not always connected to the system. I have the same situation w/ my old Compaq Evo N410c which I had just upgraded. The floppy is part of a docking station which I rarely use. After I connected the laptop to the docking station, usb drives would automount and appear on the desktop as they had previously in 9.10.

    Hope this info helps others with similar problems.

    tm
    Last edited by tmazzotta; May 3rd, 2010 at 03:02 AM.

  5. #5
    Join Date
    Jan 2010
    Beans
    21

    Re: lucid upgrade causes USB automount problems (tips/advice)

    I've switched to Lucid Lynx and I have the same automount problem. When I plug an usb drive, I do see it under "Computer" and can mount it with a double click.However it isn't done automatically. Once the drive is mounted, I can't unmount it. I see a warning saying that I can't unmount because the device isn't listed in fstab ...
    This automount problem has surely something to do with the floppy. I have a floppy0 device listed under "computer". But I don't have any floppy drive installed in my PC ... lol
    This floppy drive has now disappeared because I have added # in front of floppy in /etc/fstab
    BUT I still have the usb autmount problem. I don't see what I can do with my ghost floppy problem ... Maybe someone has an idea ?


    EDIT : I've disabled floppy support in my BIOS and now everything is working
    Last edited by pimseb; May 4th, 2010 at 09:08 PM. Reason: found the solution

  6. #6
    Join Date
    Mar 2010
    Beans
    1

    Re: lucid upgrade causes USB automount problems (tips/advice)

    Worked like a charm. Thanks so much for posting that fix.

  7. #7
    Join Date
    Feb 2008
    Beans
    3

    Re: lucid upgrade causes USB automount problems (tips/advice)

    This also fixed my problem. Just for clarity's sake I'm going to describe a symptom that no one else has mentioned.

    In Nautilus I was seeing two icons for my USB:
    1) "contents" name of the usb (such as TRK_3-3)
    2) the mount name /usb0

    Clicking on /usb0 showed me the device but it belonged only to root, clicking on the name of the device would not go anywhere.

  8. #8
    Join Date
    Oct 2006
    Location
    Dawlish, Devon, UK
    Beans
    636
    Distro
    Ubuntu Gnome 15.04 Vivid Vervet

    Re: lucid upgrade causes USB automount problems (tips/advice)

    I had the similar problems after an upgrade to Lucid - but in my case USB drives were not automounting and were not showing up in Nautilus either. After much pulling out of the greying hairy fibrous material, I solved the problem by uninstalling pmount, and then re-installing it together with libpmount0.0

    This seems to have solved the problem. I hope this may help others in the same situation.

  9. #9
    Join Date
    Mar 2009
    Beans
    6

    Re: lucid upgrade causes USB automount problems (tips/advice)

    Thanks, euchrid. Your proposed solution worked great.

    I had no problems with automatic USB drives mounting (at least by PCMan File Manager) before the upgrade to 10.04. Then first time after inserting the device it began to be atomatically mounted with absolutely wrong options - owned by 'root' as already described. It also had some files with non-Latin characters to appear as "??????" so character encoding also broke. I wonder if autodetection of non-FAT filesystems got broken too.

    Just removing that "usbmount" package helped. I don't think I would be able to figure out the problem without stumping by chance on this thread. Adding such raw, badly tested packages to an LTS distribution release is IMHO bad practice.

  10. #10
    Join Date
    May 2009
    Location
    Germany
    Beans
    13
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: lucid upgrade causes USB automount problems (tips/advice)

    Although I made a Lucid clean install, I also faced that USB automount problem: my USB flash drive was always autmounted to /media/disk and owned by root so that I couldn't really use it. The solution was to remove hal
    Code:
    sudo apt-get remove hal
    Don't know how I got hal installed (maybe an odd dependency), but removing it definitely solved the problem.

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •