Results 1 to 5 of 5

Thread: m-audio delta 44 in Ubuntu 10.04 [pulse probs]

  1. #1
    Join Date
    Nov 2007
    Beans
    254

    m-audio delta 44 in Ubuntu 10.04 [pulse probs]

    Here's how I got my M-Audio delta 44 working in Ubuntu 10.04:

    1.
    Disable on-boad audio card in BIOS

    2.
    open a terminal and type:
    Code:
    sudo gedit /etc/pulse/default.pa
    3. Find 'module-udev-detect' and 'module detect' and put # in front of the sentences so that it looks like this:

    Code:
    ### Automatically load driver modules depending on the hardware available
    # .ifexists module-udev-detect.so
    # load-module module-udev-detect
    # .else
    ### Alternatively use the static hardware detection module (for systems that
    ### lack udev support)
    # load-module module-detect
    # .endif
    4.
    Paste the following text in the file:
    Code:
    # Load Delta 44:
    load-module module-alsa-sink sink_name=delta_out device=hw:1 channels=10 channel_map=left,right,aux0,aux1,aux2,aux3,aux4,au x5,aux6,aux7
    load-module module-alsa-source source_name=delta_in device=hw:1 channels=12 channel_map=left,right,aux0,aux1,aux2,aux3,aux4,au x5,aux6,aux7,aux8,aux9
    5.
    save & quit

    (DON'T CHANGE /etc/pulse/system.pa or /usr/share/alsa/cards/ICE1712.conf

    6.
    reboot

    good luck!

    PS This thread was composed with the help of the following links:
    http://www.linuxforums.org/forum/ubu...-problems.html
    http://ubuntuforums.org/showthread.php?t=1317065
    Last edited by nlz; May 7th, 2010 at 08:49 PM.
    they stole our revolution. we stole it back. they hired us to work on it. and now we're occupying the plant. -@mala

  2. #2
    Join Date
    Mar 2008
    Beans
    7

    Re: m-audio delta 44 in Ubuntu 10.04 [pulse probs]

    Hi nlz,

    Same problem, but your solution didn't work for me.
    The sound service failed to start

    any other idea?

    sys / pref /sound show Digital Surround 4 IEC958 as parameter.

    thanks in advance
    Last edited by yagogak; May 8th, 2010 at 03:10 PM.

  3. #3
    Join Date
    May 2010
    Beans
    1

    Re: m-audio delta 44 in Ubuntu 10.04 [pulse probs]

    I've been struggling with this too, but just found a solution that works for me by adding two lines to usr/share/alsa/cards/Ice1712.conf.

    Follow picrard's instructions in green.

    Hope this works for everyone else...

    Rob

  4. #4
    Join Date
    Sep 2005
    Beans
    173

    Re: m-audio delta 44 in Ubuntu 10.04 [pulse probs]

    Quote Originally Posted by rdmiller View Post
    I've been struggling with this too, but just found a solution that works for me by adding two lines to usr/share/alsa/cards/Ice1712.conf.

    Follow picrard's instructions in green.

    Hope this works for everyone else...

    Rob
    This did the trick for me! Thank you!

  5. #5
    Join Date
    May 2009
    Beans
    12
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: m-audio delta 44 in Ubuntu 10.04 [pulse probs]

    @ NLZ

    TOTALLY works! awesome! thank you so much!!!!!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •