Results 1 to 4 of 4

Thread: Toshiba Satellite L300 & Ubuntu 10.04

  1. #1
    Join Date
    Jan 2009
    Beans
    3

    Angry Toshiba Satellite L300 & Ubuntu 10.04

    I have Toshiba Satellite L300 with H2O Bios, and i have dual boot Windows 7 and Ubuntu 10.04. In Windows 7 everything works SUPER !! in Ubuntu 10.04 i have a problem with my FN keys, not all of them, only Fn+F3 works and after i press Fn+F3 i can use other Fn keys like Fn+F6 or Fn+F7 for Dispay brightness they start to work but after i restart my laptop again only Fn+F3 works . I also think that my CPU is sometimes hot . Please tell me, i like to use only Ubuntu on my laptop !! Thanks
    Last edited by Benyt; May 1st, 2010 at 02:30 PM.

  2. #2
    Join Date
    Apr 2010
    Beans
    2

    Re: Toshiba Satellite L300 & Ubuntu 10.04

    Yes your computer is getting hot, very hot!
    Seems to be the same problem with all newer Toshiba's.
    I have Toshiba Satellite L500, H20 bios.
    10.04 64bit. Ubuntu

    Same problem exits with Fedora and PCLinuxOS

    NO FAN CONTROL

    Here is what works for me.
    This does not solve the problem with the function keys but more importantly, gets the fan working properly and prevents a laptop meltdown.

    first. sudo apt-get install sensors-applet
    next. sudo sensors-detect

    next. answer yes to everything.

    exit then restart computer.

    next. sudo gedit /etc/default/grub and then change

    GRUB_CMLINE_LINUX_DEFAULT="quiet splash"

    to read

    ..."quiet splash acpi_osi=Linux"

    next. sudo update-grub to update /boot/grub/grub.cfg

    exit then restart computer.

    I hope this helps.

  3. #3
    Join Date
    Mar 2010
    Location
    Ohio, USA
    Beans
    41
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Toshiba Satellite L300 & Ubuntu 10.04

    Thanks for this. I too am trying to get my FN keys to work correctly but, I hadn't really noticed just how bad my CPU was overheating (I rarely have my laptop directly on my lap). Thanks to this post I successfully Fixed my fan and it is running much cooler now. Also something that helped was http://stochasticflux.com/blog/?p=13 be warned though that the formatting gets screwed up in the script, you need to change the quotes from single to double and I'm not quite sure if it's necessary or not but, I also deleted the preceding tabs. The K10 sensor was necessary to my knowledge to get the sensors working. (The sensors-detect command told me that unless it was already in my kernel I needed to install this driver.)

    FYI My computer is a Toshiba Satellite L355D-S7901

  4. #4
    Join Date
    Dec 2006
    Beans
    Hidden!

    Re: Toshiba Satellite L300 & Ubuntu 10.04

    Sorry to bump up an old post but I have the solution. You need to upgrade the BIOS to get fan control and function keys to work properly in Linux. See my complete article here:
    https://wiki.archlinux.org/index.php...Satellite_L300

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •