Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16

Thread: Where is /etc/init.d/samba in 10.04?

  1. #11
    Join Date
    Jan 2005
    Beans
    276
    Distro
    Ubuntu

    Re: Where is /etc/init.d/samba in 10.04?

    Quote Originally Posted by Morbius1 View Post
    ...They must have hired a developer that is very persnickety about grammar - you can't restart something that hasn't started
    But what if it had started and then stopped? Wouldn't I restart it?
    If anyone asks you to
    sudo rm -rf /
    you would be better to just format the partition. It's faster and at least you may be able to recover all your LOST DATA!!

  2. #12
    Join Date
    Aug 2010
    Beans
    1

    Exclamation Re: Where is /etc/init.d/samba in 10.04?


    Checked the boot and startup processes in webmin
    viewed content of the mechanics.

    found: service
    Usage: service < option > | --status-all | [ service_name [ command | --full-restart ] ]


    service smbd start
    smbd start/running, process 1510

    service nmbd start
    nmbd start/running, process 1527

    made 2 shell scripts

    open shell and..

    cd /etc/init.d
    echo service smbd start > samba-up
    echo service nmbd start >> samba-up

    echo service smbd stop > samba-down
    echo service nmbd stop >> samba-down

    chmod +rx samba-up samba-down

    replace the Samba start/stop entries in Webmin
    with /etc/init.d/samba-up - and /etc/init.d/samba-down


    issue resolved?
    Last edited by herauthon; August 22nd, 2010 at 12:26 PM.

  3. #13
    Join Date
    Sep 2006
    Beans
    44

    Re: Where is /etc/init.d/samba in 10.04?

    So now How does one disable the starting of samba on boot? Back about a decade ago when I setup Red Hat and Mandrake servers it was as simple as
    Code:
    service smb off
    I used to be able to apt-get install rcconf and disable it there. does rcconf play well with upstart?

    How does one simply disable samba on boot now that everything is moved to upstart.

  4. #14
    Join Date
    May 2006
    Beans
    1

    Re: Where is /etc/init.d/samba in 10.04?

    lol the documentation needs changed too

    https://help.ubuntu.com/10.04/server...ileserver.html

    #

    Finally, restart the samba services to enable the new configuration:

    sudo /etc/init.d/samba restart

  5. #15
    Join Date
    Jun 2010
    Beans
    4

    Re: Where is /etc/init.d/samba in 10.04?

    Quote Originally Posted by Morbius1 View Post
    Two things have happened - "upstart" has replaced the old way of starting services and the "samba" service has been replaced by the old way of separating the smbd and nmbd daemons.

    So the way you need to restart samba is now this way:

    sudo service smbd restart
    sudo service nmbd restart
    Does this detach the daemons so they run in the background? Just today I set up samba and after making changes to the smb.conf file I used the above commands to restart samba. All was good until I logged out of the server and people lost their connections to the network share. So I restarted them again and left the server logged in until I could sort it out.

  6. #16
    Join Date
    Jan 2012
    Beans
    1

    Re: Where is /etc/init.d/samba in 10.04?

    It looks like you should have to use initctl to start or stop SAMBA, but there is some problem with the /etc/init/smbd.conf file used by Upstart that prevents it from working. Anybody have any ideas about how to modify the script so it will work correctly? --John
    Last edited by hagfish52; January 29th, 2012 at 11:15 PM.

Page 2 of 2 FirstFirst 12

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •