Results 1 to 10 of 10

Thread: Ugly plymouth splash

  1. #1
    Join Date
    Apr 2010
    Location
    Behind you
    Beans
    175
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Ugly plymouth splash

    when i installed the proprietary nvidia drivers the splash screen res changed to 600X400.
    Now that I have increased the res to 1200X800, the logo is not visible only ubuntu 10.04 is written in a ugly font and small letters, definitly not the type i saw in live CD. Solutions?
    Ubuntu 12.04 (best thing after 10.04) |Intel Dual Core 2.0GHz|1 Gb DDR2 RAM|Nvidia 8600GM| This PC was bartered for with an iRock from ancient Mesopotamia

  2. #2
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Ugly plymouth splash

    The splash screen looked pretty good before you added the proprietary driver, didn't it?

    Sigh.

    It seems that after installing proprietary drivers, what you have left is the ugly step-sister.

    Unfortunately, proprietary drivers are not loaded until after plymouth renders the splash. I have seen suggested methods for forcing them to be invoked before plymouth, but I'm not going to mess with it.

    Open source driver -- pretty plymouth splash.

    Proprietary driver -- ugly plymouth splash.

    I go for the proprietary driver because the splash screen is but a fleeting irritation.
    Please read The Forum Rules and The Forum Posting Guidelines
    My Blog
    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  3. #3
    Join Date
    Apr 2008
    Location
    London
    Beans
    1,873
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Ugly plymouth splash

    There's a way to change that in the grub.cfg

    http://ubuntu-ky.ubuntuforums.org/sh...1451820&page=3

    You'll need to run sudo update-grub afterwards to make sure the change is applied.

    .

  4. #4
    Join Date
    Apr 2010
    Location
    Behind you
    Beans
    175
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Ugly plymouth splash

    Quote Originally Posted by Sealbhach View Post
    There's a way to change that in the grub.cfg

    http://ubuntu-ky.ubuntuforums.org/sh...1451820&page=3

    You'll need to run sudo update-grub afterwards to make sure the change is applied.

    .
    That increases the res but the new ubuntu logo has disappeared.

    PS: If nothing works then i guess having no splash is better than a ugly splash. How do i remove the splash and go in with text booting?
    Ubuntu 12.04 (best thing after 10.04) |Intel Dual Core 2.0GHz|1 Gb DDR2 RAM|Nvidia 8600GM| This PC was bartered for with an iRock from ancient Mesopotamia

  5. #5
    Join Date
    Jun 2007
    Location
    The Mistake by the Lake
    Beans
    1,813

    Re: Ugly plymouth splash

    Plymouth is rough for this release. I'm sure it will all get worked out.
    Quote Originally Posted by Homer J. Simpson
    "Dinner is the perfect break between work, and drunk."


  6. #6
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Ugly plymouth splash

    I'd be careful with the change to /etc/default/grub.

    For some, it works. For others, it makes no difference. For some, it prevents them from getting to the grub menu before the card shuts off signal to the monitor(s) and they simply cannot use their machine without a reinstall. It is somewhat dependent on hardware.
    Please read The Forum Rules and The Forum Posting Guidelines
    My Blog
    A thing discovered and kept to oneself must be discovered time and again by others. A thing discovered and shared with others need be discovered only the once.
    This universe is crazy. I'm going back to my own.

  7. #7
    Join Date
    May 2010
    Beans
    1

    Re: Ugly plymouth splash

    try this solution: http://idyllictux.wordpress.com/2010...ricted-driver/

    worked for me.

  8. #8
    Join Date
    Dec 2006
    Location
    England
    Beans
    1,173
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Ugly plymouth splash

    Quite a few of the proprietary drivers have issues with Kernel Mode Setting, which as far as I can remember is the way that they get the plymouth image pretty and sharp. It was nice on the loadup because the open source drivers will have been used - its probably a matter of time before the proprietary ones catch up. I just have the issue my card runs nearly 20 degrees hotter on the OSS drivers than the proprietary ones!

    J
    How to help yourself|Ubuntu Guide

    * Think you've found a bug? Get it reported using apport-bug.

  9. #9
    Join Date
    Mar 2008
    Beans
    16

    Re: Ugly plymouth splash

    Proprietary drivers are extremely unlikely to ever support KMS, so don't expect a solution on that front.

    OSS drivers for Ati recently gained dynamic power control which drops power consumption to levels close to that of proprietary drivers (seriously!) Some people have reported 30W reduction in power consumption using the newest code.

    There's some work to be done still, but this should make it to the 2.6.35 kernel.

  10. #10
    Join Date
    Apr 2008
    Location
    London
    Beans
    1,873
    Distro
    Kubuntu 12.04 Precise Pangolin

    Re: Ugly plymouth splash

    Quote Originally Posted by QIII View Post
    I'd be careful with the change to /etc/default/grub.

    For some, it works. For others, it makes no difference. For some, it prevents them from getting to the grub menu before the card shuts off signal to the monitor(s) and they simply cannot use their machine without a reinstall. It is somewhat dependent on hardware.
    It worked fine for me but I already had the proprietary Nvidia driver installed (the one you get through Hardware Drivers). I hadn't heard anything about it being problematic, so I went ahead and did it.

    .

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •