Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Aspire one 532h touchpad problems in Lucid Lunx (10.04)

  1. #1
    Join Date
    May 2010
    Beans
    6

    Aspire one 532h touchpad problems in Lucid Lunx (10.04)

    Installed ubuntu 10.04 netbook remix on my aspire one 532h netbook. My touch pads vertical scroll doesnt work although i've enabled it in the mouse preferences. And is there a way to get the multi gesture feature to work in ubuntu?

  2. #2
    Join Date
    May 2010
    Beans
    1

    Re: Aspire one 532h touchpad problems in Lucid Lunx (10.04)

    I have this problem on the Acer Aspire One 532h as well. I fixed it by:

    Code:
    sudo modprobe -r psmouse
    sudo modprobe psmouse proto=imps
    You should be able to make it permanent by putting:
    Code:
    options psmouse proto=imps
    in /etc/modprobe.d/options and rebooting

    I've only done the first part on my actual machine since I was booted from a flashdrive. I have Karmic on the laptop now, but I'm installing it. This was what was holding me up.

  3. #3
    Join Date
    May 2010
    Beans
    6

    Re: Aspire one 532h touchpad problems in Lucid Lunx (10.04)

    thanks busycrab ! that fixes it .. but if someone could get the multi gestures working, please tell me how.

  4. #4
    Join Date
    Aug 2007
    Beans
    130

    Re: Aspire one 532h touchpad problems in Lucid Lunx (10.04)

    I ve been trying to solve this since upgrading my ACER

    I can't get it to work - once I run the first line of code my touchpad stops working! So I'm scuppered I can't run the second line.

    It won't paste both lines of code together for some reason. Am I missing something?


    Running the second line on its own does nothing -still won't scroll

    Edit: /etc/modprobe.d/options doesn't seem to exist.
    Last edited by thered; May 3rd, 2010 at 08:13 PM.

  5. #5
    Join Date
    Apr 2010
    Beans
    1

    Re: Aspire one 532h touchpad problems in Lucid Lunx (10.04)

    Quote Originally Posted by thered View Post
    I ve been trying to solve this since upgrading my ACER

    I can't get it to work - once I run the first line of code my touchpad stops working! So I'm scuppered I can't run the second line.

    It won't paste both lines of code together for some reason. Am I missing something?
    It's pretty normal that the first line stops your touchpad. It unloads the kernel module that handles it. The second line, on the other hand, reloads it with special parameter that tells it to use a special protocol that knows about scroll-wheels.
    Why not just typing things by hand?


    Running the second line on its own does nothing -still won't scroll
    sure, pretty normal, too. Kernel modules, that are already loaded are not reloaded. You have to unload them and load them again. That's pretty much what those 2 lines do. You have to type both of them.

    Edit: /etc/modprobe.d/options doesn't seem to exist.
    [/QUOTE]

    /etc/modprobe.d/options does not exist any more (does it?). Just use any filename in that directory, that ends with a .conf.

    /etc/modprobe.d/psmouse.conf sounds like a good name to me. And it works for me like a charm.
    Of course, this is only a workaround, it handles the touchpad like a scrollwheel mouse, touchpad specific features are missing. But it already helps a lot! Thanks busycrab!
    I guess we'll have to wait until the new fixed kernel's available to have proper touchpad support.

  6. #6
    Join Date
    Aug 2007
    Beans
    130

    Re: Aspire one 532h touchpad problems in Lucid Lunx (10.04)

    Yes, got it working, thanks to all.

    Couldn't type two commands into terminal to test first but created .conf file in /etc/modprobe.d/mouse.conf

    It seems a bit jerky but works!!!

  7. #7
    Join Date
    May 2010
    Beans
    2

    Re: Aspire one 532h touchpad problems in Lucid Lunx (10.04)

    Upgrading to Kubuntu 10.04 on my DELL XPS 1210 I lost control of the touch-pad
    Strange behaviour, I would need two finger on the pad to use it!
    Creating the modprobe.d/options file with
    options psmouse proto=imps
    solved the problem. Many thanks.
    But if
    "Of course, this is only a workaround"!!
    please let me know if someone discovers a more straightforward solution.
    rs

    QUOTE
    /etc/modprobe.d/options does not exist any more (does it?). Just use any filename in that directory, that ends with a .conf.

    /etc/modprobe.d/psmouse.conf sounds like a good name to me. And it works for me like a charm.
    Of course, this is only a workaround, it handles the touchpad like a scrollwheel mouse, touchpad specific features are missing. But it already helps a lot! Thanks busycrab!
    I guess we'll have to wait until the new fixed kernel's available to have proper touchpad support.
    /QUOTE
    Last edited by scotti; May 4th, 2010 at 08:46 PM.

  8. #8
    Join Date
    May 2010
    Beans
    3

    Re: Aspire one 532h touchpad problems in Lucid Lunx (10.04)

    Thanks this worked great... I miss gestures still but this helps things out.
    I am running 64bit version not the Netbook version however (via Wubi right now)... just because I can
    I wish there was a 64 bit Netbook edition; it is sweet.
    When I was running the Netbook version I found the touchpad would wig out if I touched it before logging into my account. I had to be careful not to touch it until I was logged it and then it worked fine. The 64bit version did this a bit as well but I think an update may have fixed it. Did this happen to anyone else on a 532H?

  9. #9
    Join Date
    May 2010
    Location
    Auckland New Zealand
    Beans
    1

    Re: Aspire one 532h touchpad problems in Lucid Lunx (10.04)

    Hi I am also having scrolling issues on a gateway NV 54 series.

    I enter the first two lines of code and i get scrolling capabilities however entering the last code ' options psmouse proto=imps does not make it permanent for me and only results in a 'command not found message'. As such, once i reboot i have no scrolling again.

    Also im not sure what is meant by "in /etc/modprobe.d/options and rebooting" so maybe this is part of my problem.

    Any help on enlightening me would be great, very very new to this having only just downloaded and installed Ubuntu today. I have been searching everywhere for a solution and would be nice not to have to be forced back to Windows only.

    Fruitbaby

  10. #10
    Join Date
    Feb 2009
    Beans
    8

    Re: Aspire one 532h touchpad problems in Lucid Lunx (10.04)

    Thank you. Confirmed scroll working in Compaq 311c with Lucid Lynx.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •