Results 1 to 8 of 8

Thread: Tomboy Notes Startup in Background

  1. #1
    Join Date
    Mar 2010
    Location
    Safad, Palestine
    Beans
    22
    Distro
    Ubuntu

    Question Tomboy Notes Startup in Background

    Is there a way to make Tomboy Notes startup in the background when Ubuntu is lunched? I added the command "tomboy --search" to startup applications and whenever Ubuntu starts, Tomboy Notes opens the [Search All Notes] window.

    In the previous Ubuntu version, I used to use the Tomboy Notes applet from (Add to Panel) and it used to startup without opening any windows. This method still work on Ubuntu 10.04, but I liked the new icon for Tomboy Notes that appears in the status bar.

    Is there a way I can do that?
    Last edited by tareksobh; April 30th, 2010 at 10:31 PM.

  2. #2
    Join Date
    Apr 2006
    Location
    Las Vegas, NV
    Beans
    69

    Re: Tomboy Notes Startup in Background

    The --search option is what makes the search window appear. Just add "tomboy" to your startup items, without --search, and you should be fine.

  3. #3
    Join Date
    Feb 2010
    Beans
    4

    Re: Tomboy Notes Startup in Background

    Quote Originally Posted by sharm View Post
    The --search option is what makes the search window appear. Just add "tomboy" to your startup items, without --search, and you should be fine.
    I have same problem, and I've done that. But at startup the "search window" still opens. The weird thing is, if I run the "tomboy" command in a terminal it starts without the "search window". The command used is the same! Any suggestions?

  4. #4
    Join Date
    Apr 2006
    Location
    Las Vegas, NV
    Beans
    69

    Re: Tomboy Notes Startup in Background

    Quote Originally Posted by Raev33 View Post
    I have same problem, and I've done that. But at startup the "search window" still opens. The weird thing is, if I run the "tomboy" command in a terminal it starts without the "search window". The command used is the same! Any suggestions?
    Either you are accidentally starting Tomboy twice (the second time will cause the Search window to appear), or your panel is taking > 2 seconds to load after Tomboy is started (in which case Tomboy shows the Search window so you can be assured it's actually running).

    Accidentally starting Tomboy twice is the most common cause.

  5. #5
    Join Date
    Feb 2010
    Beans
    4

    Re: Tomboy Notes Startup in Background

    Quote Originally Posted by sharm View Post
    Either you are accidentally starting Tomboy twice (the second time will cause the Search window to appear), or your panel is taking > 2 seconds to load after Tomboy is started (in which case Tomboy shows the Search window so you can be assured it's actually running).

    Accidentally starting Tomboy twice is the most common cause.
    Thanks for the answer. I'm positive that Tomboy is not started twice, so it's probably the > 2 seconds thing. Sounds like a good feature, but in in this particular case it's quite annoying.

  6. #6
    Join Date
    Nov 2006
    Beans
    16

    Re: Tomboy Notes Startup in Background

    Quote Originally Posted by Raev33 View Post
    Thanks for the answer. I'm positive that Tomboy is not started twice, so it's probably the > 2 seconds thing. Sounds like a good feature, but in in this particular case it's quite annoying.
    I had this issue as well, as a quick work around you can create a script like this for example. I named it delay-tomboy.sh in my ~/bin/ directory.

    Code:
    #!/bin/sh
    /bin/sleep 5
    /usr/bin/tomboy
    Just run chmod +x on it to make it executable, then choose that as the command in your startup entry instead of tomboy itself. You might need to play with the sleep time a little depending how long it's taking your panel to load.

    -Dan

  7. #7
    Join Date
    Mar 2006
    Location
    Winnipeg, Canada
    Beans
    365
    Distro
    Ubuntu Intrepid Ibex (testing)

    Re: Tomboy Notes Startup in Background

    An even more elegant solution:

    make your entry in startup applications read "tomboy --quiet".

    cheers
    last.fm: the social music revolution.

  8. #8
    Join Date
    Apr 2006
    Location
    Las Vegas, NV
    Beans
    69

    Re: Tomboy Notes Startup in Background

    Quote Originally Posted by groggyboy View Post
    An even more elegant solution:

    make your entry in startup applications read "tomboy --quiet".

    cheers
    There is no --quiet option. That is the same as starting "tomboy" without any arguments.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •