Page 3 of 4 FirstFirst 1234 LastLast
Results 21 to 30 of 33

Thread: How to enable Fn keys on Eee PC 1005HA and 10.04 Lucid Lynx?

  1. #21
    Join Date
    Jan 2008
    Beans
    5

    Re: How to enable Fn keys on Eee PC 1005HA and 10.04 Lucid Lynx?

    i started to do what post #2 says but I found that my grub folder must be located elsewhere as the terminal command opened up and empty file...


    any idea, running lucid

  2. #22
    Join Date
    Jan 2008
    Beans
    125

    Re: How to enable Fn keys on Eee PC 1005HA and 10.04 Lucid Lynx?

    mine too was empty!!! can someone please upload their grub file, or paste the complete file code?

    i have other problems with my upgrade, most notably, the multi-touch/ two-finger scrolling stopped working too. did any of you experience that? i followed instructions on enabling the multi-touch for my 1005ha on 9.10 a few months agho, but its all been lost with this 10.04 update

  3. #23
    Join Date
    Jul 2010
    Beans
    4

    Re: How to enable Fn keys on Eee PC 1005HA and 10.04 Lucid Lynx?

    I have also wiped out Windows XP from my Eee PC 1000H and installed Ubuntu 10.04 Netbook Edition on it. Everything works fine including audio, video, touchpad, wifi, lan, sd card reader, etc. The grub entries fixed most of the Fn keys and custom hard keys are working. Thanks.

    Asus Eee PC 1000H

    Fn+F1 = Suspend. Works even before the grub fix.
    Fn+F2 = Wireless/Bluetooth Toggle. Works even before the grub fix. However, it seems to toggle WiFi only. In XP it toggles Bluetooth as well. That's not a problem though. No on-screen notification.
    Fn+F5 = Decrease Brightness. Works even before the grub fix. Before grub fix, on-screen notification was available. After the grub fix, on-screen notification stopped working.
    Fn+F6 = Increase Brightness. Works even before the grub fix. Before grub fix, on-screen notification was available. After the grub fix, on-screen notification stopped working.
    Fn+F8 = Toggle monitor. Works after applying the grub fix. No on-screen notification.
    Fn+F9 = ? combo key. Works after applying the grub fix. I remapped this key combo to launch an application.
    Fn+F10 = Mute. Works after applying the grub fix. On-screen notification works fine too.
    Fn+F11 = Decrease Volume. Works after applying the grub fix. On-screen notification works fine too.
    Fn+F12 = Increase Volume. Works after applying the grub fix. On-screen notification works fine too.

    Custom Hard Key #1 = Activate Screen Saver. Works after applying the grub fix.
    Custom Hard Key #2 = No response before and after the grub fix.
    Custom Hard Key #3 = User Hard Key. Works after applying the grub fix. Key remapped to launch app.
    Custom Hard Key #4 = User Hard Key. Works after applying the grub fix. Key remapped to launch app.

  4. #24
    Join Date
    Jan 2008
    Beans
    125

    Re: How to enable Fn keys on Eee PC 1005HA and 10.04 Lucid Lynx?

    Quote Originally Posted by Mike8913 View Post
    i started to do what post #2 says but I found that my grub folder must be located elsewhere as the terminal command opened up and empty file...


    any idea, running lucid
    hey mike, i had the same problem. i started a new thread and was able to solve the problem. basically you have to edit the /boot/grub/menu.lst file by adding "acpi_osi=Linux" to the line "# defoptions=quiet splash" so that it becomes:

    "# defoptions=quiet splash acpi_osi=Linux"

    then run "sudo update-grub"

    if a prompt pops up asking you what to do (like in my attachment), choose the first option (install the package maintainer's version). then restart and it should work. refer to my thread for more detail:

    http://ubuntuforums.org/showthread.php?t=1529767
    Attached Images Attached Images

  5. #25
    Join Date
    Oct 2007
    Beans
    240
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How to enable Fn keys on Eee PC 1005HA and 10.04 Lucid Lynx?

    Nice one guys... All seem to work, except from the Fn+F7 = blank monitor, which used to work before the acpi additions... any ideas on this?

    Cheers

  6. #26
    Join Date
    Aug 2007
    Location
    Colorado
    Beans
    51
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How to enable Fn keys on Eee PC 1005HA and 10.04 Lucid Lynx?

    hey guys, i've got a 1005pe n' i've got the same issue after upgrading to lucid just now. all was fine in karmic.

  7. #27
    Join Date
    Aug 2007
    Location
    Colorado
    Beans
    51
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: How to enable Fn keys on Eee PC 1005HA and 10.04 Lucid Lynx?

    Changed grub line in /etc/default/grub from GRUB_CMDLINE_LINUX_DEFAULT= "quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT= "quiet splash acpi_osi=Linux acpi_backlight=vendor" according to the instructions at https://bugs.launchpad.net/ubuntu/+s...ux/+bug/505452. Works great on my 1005PE.

  8. #28
    Join Date
    Jul 2010
    Beans
    4

    Re: How to enable Fn keys on Eee PC 1005HA and 10.04 Lucid Lynx?

    Asus ePC 1015PE - Lucid


    Thank you very much.

  9. #29
    Join Date
    Sep 2007
    Location
    Miami, FL
    Beans
    143

    Smile Re: How to enable Fn keys on Eee PC 1005HA and 10.04 Lucid Lynx?

    no longer participating in ubuntuforums.org
    Last edited by MarkieB; April 16th, 2012 at 01:14 AM.

  10. #30
    Join Date
    Aug 2005
    Beans
    45
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: How to enable Fn keys on Eee PC 1005HA and 10.04 Lucid Lynx?

    This worked on my Eee PC 901. Thanks!

Page 3 of 4 FirstFirst 1234 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •