Results 1 to 10 of 80

Thread: How To : Mobile Broadband Connections [ Ubuntu 11.04 : 10.10 : 10.04 : 9.10]

Threaded View

  1. #1
    Join Date
    Oct 2009
    A world without windows

    How To : Mobile Broadband Connections [ Ubuntu 11.04 : 10.10 : 10.04 : 9.10]

    11.04 users: First read post #59

    Upgraded to
    Natty: Network Manager not connecting any more, check this out: Post #2
    Natty new install :read through this "first" post :(if device is not recognized) : note the reference to USB_MODESWITCH >Natty users: and the link

    Keep in touch

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~

    New Devices , RE: next generation , can have a look here #59 #60
    This may relate to most of next generation devices it may help you get connected (but I never say die) as each device is different ,
    the below is left for historical purposes , if asking why : then a udev rule may be required to bring up the net interface , so worth reading. again (I never say die) if read through most of this thread , had promise script to identify some modem ports
    most of this was in place until these device came up,, the script will , hopefully identify most devices , suggest which switching methods can be use + the udev rules , + check which port could be the modem + a suggested udev rule to bring the interface up
    as to the historical purpose of leaving the below , look near end of the thread where found the UDEV RULES to bring the net interface up : as said the script is nearly done, and will post asp : it's been a busy year , well thats my excuse , but true , again never say die :: First part now at #61

    Have new Huawie device then look towards Huawie Mobile Partner , most Patches and Rules + Drivers are included: RE: POST #60 , link is above , don't forget to read further down this post RE; supported devices. And don't forget sakis3g , if you have not read "the files" how to disable or as it is put "make the device available to third party" and your stuck because modem manager can,t see the device, sakis3g should work. till you get sorted. OH and one last thing Check the Sim Card is inserted the Right way. had seen a few posts , Where Network Manager failed to connect or shows offline ,, ??? SEE POST #64 FIRST BEFORE COMMITTING

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ ~~~
    some require specific dialing methods, related <cid> dialing and cdc_ether interfaces + devices with multiple usb ID's
    as an insight can look at these two posts

    update (24 feb 2011)as to some progress #82 ::: #87

    and finaly [SOLVED] Vodafone USB (K 3805-z) {may also apply to Vodafone USB (K 3806-z)not tested (best go to last page)

    Re: NEW verizon lg vl600 4g(lte) aircard not working can have a look at this post (patch available . if the .py files have#! /usr/bin/python3 , try edit to #! /usr/bin/python ) #19 : patch level .38 : patch level .35 #23 >>>read both.

    (update 6 feb 2011 , you may find that some of these devices have 2 modem ports , this for one makes life difficult , which one to choose?
    ........ also of note the device nodes tty* may be different depending on it's state at boot time )
    Best advice I can give at present :
    If Network Manager is failing to connect using APN
    use <cid> method of dialing , + omit the APN ,
    refrain from persistent attempts at dialing APN,s , it could have adverse affect on the sim card (take this as literal)
    list the device ports with the "ls -al /dev/serial/by-id" , then check each port for a connect message , using the <cid> method of dialing
    have copied a later post concerning Meerkat to post #2, an will be updating , as and when info becomes available
    4. there is a sample output of the usb-devices command at the foot of this post .REF: INFO possible 4g LTE DEVICE
    5. there appears be on going discussions at usb_modeswitch forum regarding 4g LTE devices , suggest users to get involved ModeSwitchForum
    6. update the usb id's
    sudo /usr/sbin/update-usbids
    Check to see if recognized
    Can use this at any time to see status of NM network

    can also use nmcli : may be built in , try the command
    for reference :
    Link indicates :Where to report NM bugs> The Preferred Method of reporting : IE the SOURCE
    if not part of the distro:
    can suggest installing:command-line client for network manager : cnetworkmanager

    For link to Compatible devices #Compatable Devices post #46 / looks if this info could be outdated. best reference , try

    usb_modeswitch data

    or if already have the device:
    simply connect the device then read through rest post #1
    and post #2 , see if it is recognized.

    VMC and BMC connection manager {re vodafone mobile connect)
    Check this site :
    If Software Manager installed. use the debian package , it may inform problems with package , if advises not to install or prevents install : take heed
    for VMC check this out
    Vodafone Mobile Connect Software . with a reference to permissions
    if you are experiencing connection problems , and the network manager is failing to recognize the device
    compatible devices also check post #55.. A lot of users fail to read all documentation .. Finally :Always READ the info at the site before Commiting

    Natty users also check this post :#54

    prior to installing this software established a connection with the methods listed below , other than Network Manager.>> 3g ... Suggest Sakis3g .. others PPP . wvdial...
    take this as a must do if have devices not listed in the data-cards/index page , have tested this latest software , and constantly refuses or times out , on devices requiring simPIN
    IE: it can't get the device to accept the PIN number , so advise disable the PIN function on the device , if a problem

    Laptops: have tested numerous Laptops , where by the usb devices are not registering . Check the bios configurations as regards usb1 and usb2 settings,
    these setting are important,as it will also affect the speed of the device (sometimes may also apply to older desktops).
    if still a problem, then suggest trying Sakis3g to find the device and update the system, if successful, then should see the device in network manager
    (date: June 6, 2011)


    Boot up the computer without the modem give time for the system to settle then connect the modem:Obvious if the modem is part of the system {you can't plug it in}
    Natty users: Connect device prior to booting , after boot, modem manager will take time to process the device, be patient

    Click on the Network Manager you may see something like " Make Connection" , click on it and follow the Wizard

    The Network Manager at default is in the Notification area ,Top Panel ,right hand side , or can call up the the connections from the Terminal

    IF 3g Connection: Require correct APN and {username and password if required }relevant to Your Pay Plan Check with your ISP
    Note: For New Devices Ask If the Device Dial Method is <CID>

    Importance of User names and passwords .Generally these are used for CDMA connections if using CHAP ;.. 3g generally uses PAP {no username or password required}, the pppd Daemon usually negotiates this automatically, as for 3g connections your service provider may at times want authorization using CHAP, hence sometimes you may experience problems getting connected because your configurations has no User name or Password ,try entering your user-name and password for your service provider, the connections can be monitored in the system log viewer messages
    Need to retrieve this info from the sms texts have a look at pos
    t #27

    you may be able to find your service providers APN from the terminals ,connect the modem

    IF intending to Install Huawei Mobile Partner , then suggest getting the necessary info ( apn + {mcc and mnc numbers to look up the info in providers data base} )
    prior to install , it will help with the configuration... had been doing script to automate this , but found glitch in (updated serviceproviders.2.dtd :re attlist ussd replacement code)
    will post this asp, so keep a watch out :dated 22nd feb 2012

    Also look through the "10-Huawei-datacard.rules" to see if your device is supported : if device not supported, read next paragraph (Script at Post) this will
    help to add an unlisted device to the rules , but read and digest how the rules are related ; since there are patches to certain drivers , Hint:may be possible to
    add devices other than Huawei. All the info and how-to already posted at #59 #60 #61 #62, Read All Before Commiting , Post #60 relates to if Modem-Manager sees the Device using the "dbus" if so the Info may Help to configure Huawie Mobile Partner

    Open up first terminal to monitor the modem outputs :To find the ports : read below {Example : FINDING THE PORTS} Also see post #2 UDEVADM: or can try;
    Script at POST
    #61 , with arg tty , it will give all necessary info IE ; which could be the modem port,, if the response to AT command = OK and the STATUS lines have 1's in them may assume modem port, this is
    helpful if the device endpoints = 2 , most modems have 3 so easy identified, this will show in the udev info displayed , for user of 11.10 , may have to install tclsh , there are links at same post of how to do this the easy way , for future , keep a copy on usb stick

    edit the ttyPORT to suit the modem

    tr -s "\n" < /dev/ttyUSB2
    open up a second terminal
    echo -e "AT\r" > /dev/ttyUSB2
    if response
    assume the device is responding

    to find APN's on device
    echo -e "AT+CGDCONT?\r" > /dev/ttyUSB2
    example response from the first terminal
    +CGDCONT: 1,"IP","","",0,0
    +CGDCONT: 2,"IP","","",0,0
    +CGDCONT: 3,"IP","","",0,0
    +CGDCONT: 4,"IP",","",0,0 <======= This is mine

    can be use as reference for <cid> dialing. Note the Number after +CGDCONT:
    to dial <cid> reference the APN to the Number

    example: for APN and Network Manager (remember , reference this to APN of NM connection Manager)
    dial code = *99***4#
    other dialers = ATDT*99***4#

    example:for and Network Manager (remember , reference this to APN of NM connection Manager)
    dial code = *99***2#
    other dialers = ATDT*99***2#

    Find ISP or Operator
    echo -e "AT+COPS?\r" > /dev/ttyUSB2
    this returned
    +COPS: 0,0,"T-Mobile UK",2 <=======This was mine /
    also shows it is registered to the network. this may be " 0.0.0 " indicating the device is not registered ,safest way , register on windows machine , or
    "search net for a how to , Not for the novice"

    Have been requested to re-instate these commands removed from other posts : may be of benefit if the modem has a sim card and connects through APN.

    to find the mmc and mnc numbers
    echo -e "AT+COPS=0,2\r" > /dev/ttyUSB2

    echo -e "AT+COPS?\r" > /dev/ttyUSB2
    Returns something like this
    +COPS: 0,2,"23430",2
    these numbers can be used to find apn ,user name , password from the
    serviceproviders database , can copy and paste this in the browser

    the mcc and mnc number is taken from "23430" and splits into
    mcc =234
    mnc =30

    To find service providers use the AT+COPS=? command
    this will take time while it searches
    be patient

    example reply
    +COPS: (2,"T-Mobile","T-Mobile","23430",2),(1,"T-Mobile","T-Mobile","23430",0),(3,"Vodafone UK","Vodafone UK","23415",2),(3,"Vodafone UK","Vodafone UK","23415",0),(3,"O2-UK","O2-UK","23410",0),(3,"Orange","Orange","23433",0),(1, "3","3","23420",2),(3,"Orange","Orange","23433",2) ,(3,"O2-UK","O2-UK","23410",2),
    have highlight the bits relative to the provider , also note the numbers before and after the sim identifier .

    Test : pin code or puk code required
    echo -e "AT+CPIN?\r" > /dev/ttyUSB2
    example results:
    +CPIN: READY not pending for any password
    +CPIN: SIM PIN required
    +CPIN: SIM PUK PUK1 required
    +CPIN: SIM PIN2 required
    +CPIN: SIM PUK2 required
    +CPIN: PH-SIM PIN SIM.lock (phone-to-SIM) is required
    +CPIN: PH-NET PIN.....Network personnalisation is required
    +CME ERROR: <err> SIM failure (13) absent (10) etc..
    .important :if wrong pin is used 3 times then you will be sim locked , IE. device not accessible , ensure correct PIN Number or PUK code:
    best advice : disable the PIN and PUK code security : Try to do this By inserting sim in mobile phone

    EXIT the terminals when trying the connection with Network Manager

    There is a script called (python using dbus to communicate with modem-manager) it will do most of the above and more
    can use wget from the terminal if have alternate method of connecting
    Note: BCM and WADER-CORE the dbus spec is different to the modem-manager : hence the script may fail . will have to adapt code in dbus spec see post

    TESTING MODEM-MANAGER: need to get :: To do the test disable all networking on the Network Manager
    to call the script
    python ./

    or paste this in the browser
    then use copy and paste or save as. (name the script "")
    to test a device open up a terminal ,cd to the directory where the script resides then
    python ./
    To get this to work as it should can Look here :

    for rest of functions (argv's)
    Please read the script, Have fun

    Have also Written Bash Script (using dbus-send and modem-manager) to do Similar : SEE : POST #62

    Even if the device is { not recognised or problematic } , continue to make a new connection by the selecting VPN Connections ,it will help with some of the details if an alternate method of dial up needs to be used.

    Network manager failed to connect : Double check the Information and read the above with reference to NEW DEVICES APPEARING

    Device is Recognized and have double checked the information try the below methods of dial up

    Device not recognised in the Network Manager : follow the below .
    Also Checkout Post #16
    also look for in same post
    Modem-Modeswitch :
    setting the udev rules.d

    • If nothing happens , open up the terminal and enter this command

    this command may show the tty*port for the modem
    ls -al /dev/gsmmodem

    example reply
    lrwxrwxrwx 1 root root 7 2011-07-01 13:41 /dev/gsmmodem -> ttyUSB2

    or try
    dmesg | grep -e "modem" -e "tty"
    This will show if the modem has been identify and the lines { ttyx } and possible the driver
    [ 0.000000] console [tty0] enabled
    [ 0.262809] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A

    [ 0.263080] 00:08: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    [ 21.950573] USB Serial support registered for GSM modem (1-port)
    [ 21.950756] option 1-10:1.0: GSM modem (1-port) converter detected
    [ 21.950893] usb 1-10: GSM modem (1-port) converter now attached to
    [ 21.950911] option 1-10:1.1: GSM modem (1-port) converter detected
    [ 21.951003] usb 1-10: GSM modem (1-port) converter now attached to
    [ 21.951025] option 1-10:1.3: GSM modem (1-port) converter detected
    [ 21.951130] usb 1-10: GSM modem (1-port) converter now attached to
    [ 21.951157] option: v0.7.2:USB Driver for GSM modems
    For serial legacy devices:
    [17179575.588000] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    [17179575.588000] serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
    [17179575.592000] 00:07: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
    [17179575.592000] 00:08: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
    If only shows the 2 lines highlighted in blue then there is a problem

    If the the output looks similar to the above then the Problem is a configuration one / make a note of the ttyx as this will help to configure PPP , wvdial or Gnome-ppp

    One thing is for sure :
    if the modem is recognized then there is no reason a connection can't be made { other than no signal , poor quality reception(signal strength),network busy (you can,t get a slot) < = > sometimes your operator may drop the connection if you are leaving your network connection unattended.}

    Note that the debian package is not 100% compatible with recent Ubuntu version

    • For USB Devices ;If nothing shows enter this command from the terminal

    this will give the
    ID's of the device
    Look to see if your device is listed in the latest

    Natty users :read this before committing
    #30 (same rules now apply with Ubuntu 10.10) : if in doubt check the details in synaptic (usb-modeswitch properties)

    Check :

    • DefaultVendor = 0xN where n is the number in hex
    • DefaultProduct = 0xN where n is the number in hex
    • If the device is listed then there is a good chance it will work
    • use a computer with Internet access for any downloads and save to usb stick , also you will always have the necessary tools to get connected ; if you are a novice use links to the Debian sites as the files will self install when in Ubuntu
    • if you install the latest package then the device should work without any further configuration of the usb modeswitch
    • read all the info at the site thoroughly and note any areas of problems and the fixes and the links
    • modeswitch compilation errors RE libusb, possible lib has no link, read
    • Note that the debian package is not 100% compatible with recent Ubuntu version
    • whilst at the site , note indicating , device can be broken if wrong msg content sent "for me , I would take it back for a refund"

    Dial up :Methods

    • Gnome Network Manager { Should already be installed } Also has a list of predefined connections
    • Gnomeppp this is a front end tool to wvdial so both need to be down loaded {Also check post #6 by George Vita }
    • Sakis3g refer to the post #5
    • PPP { should already be installed. set up use the terminal and enter the command : sudo pppconfig { Example at Post #7}
    • Mozilla Firefox ,if the browser is not working check the "Work Off line" is unchecked
    • Tip for the Mozzila Firefox fix ,After opening Firefox, try opening page "about:config"... Filter for "toolkit.networkmanager.disable"
    • Change the line to ....." toolkit.networkmanager.disable;true "

    Downloads :

    Network Manager:
    ISP failing to return the
    NS1 and NS2 IE :the modem connects but the Browser and updates etc fail to connect

    From the terminal try these
    sudo gedit /etc/ppp/options
    Add this line and save:

    Here I have change the IPCP configure-NAKs returned before starting , remove the # and set the number to 30 ( or any thing above the default value till there is a constant connection ) Tip try 30 then work down
    sudo gedit /etc/ppp/options
    Place a # in front of the replacedefaultroute so it looks like
    # replacedefaultroute
    Then look for the lines :
    # Set the maximum number of IPCP configure-NAKs returned before starting
    # to send configure-Rejects instead to <n> (default 10).
    # ipcp-max-failure <n>
    edit to look like :
    # Set the maximum number of IPCP configure-NAKs returned before starting
    # to send configure-Rejects instead to <n> (default 10).
    ipcp-max-failure 30
    Hopefully I can now leave the NM IPv4 settings to Automatic (PPP) instead of Setting the NM to IPv4 settings to Automatic (PPP) address only and having to enter the numerical addresses in the DNS servers text box.

    replacedefaultroute has failed a few times after a fresh boot , but has proved quite successful.

    Alternatively you can use the Network Manager to use the address of your

    get the Numerical address or addresses from your
    ISP commonly known as NS1 and NS2, or DNS1 and DNS2.

    Open up the connection via the Network Manager . Select Mobile Broadband . Select Edit Connection .Select Ipv4 settings select the Automatic(PPP) address only then enter the addresses of your
    ISP in the DNS servers box separated by a “ , “ comma without the quotes so it will look something like
    Making back up files:

    Networking and wireless software "configuration files" use the home directory and the "/etc/" directory for configurations, so I recommend backing up any file you are attempting to edit

    Making back up files:
    sudo cp "file path"/"file path_bak"
    sudo cp /etc/ppp/options /etc/ppp/options_bak

    for files which would be stored in the home directory I recommend backing up the actual "home" directory it's self. ,know a few people that deleted all the contents ,even deleted the home directory to make a new one ? . If you have plenty of storage , backup the whole of the "/etc/" as well . if your asking why " Some hidden " . { also advise backing up if upgrading to different versions of Ubuntu}

    • Every Thing I have tried Failed: Search the forums with your Model or start new Thread at
    • Networking & Wireless

    check to see if usb-devices are on system
    which usb-devices
    if on system :reply
    it is installed

    to find details of device

    Notes :
    Modem Port recognition :

    Gobi chipset problems
    ... {Maverick Meerkat should now have the gobi-loader in the repo's Check Synaptic Package Manager }
    also look here

    Ubuntu 10.04
    :Some devices may load and configure on boot and not visible from the desk top
    also not available from the network manager as the pppd has self initiated . Check this out from the log file viewer , also see if you can browse. I suggest installing netspeed as any connection will show in the netspeed. reason { reports of devices previously available before upgrading to 10.04 }{added 6 june 2010}

    Connecting the modem on the main hub {on the motherboard back plane}can lead to device recognition errors

    Noticeable with USB harddrives , boot from USB stick , Keyboard or Mouse
    To check for conflicts use the “ lsusb -t and lsusb –v “ command and monitor the outputs

    Modem Firmware upgrades:

    Some Manufactures and Providers are providing firmware updates to meet requirements of win7 , if you accept these updates be prepared for some devices to be no longer recognized in Linux .
    Also checkout Posts#29 and 30

    I can only suggest this , if the device is working , leave as is , or ask the question " If I upgrade the firmware , will it still work with linux “.

    Some devices need time to settle
    : if there is sporadic identification of the device or the ports been registered this may more notable in 10.04 , try connecting the device after boot

    Add in /etc/modprobe.conf a delay for the usb-storage

    sudo gedit /etc/modprobe.conf
    add the following line
    options usb-storage delay_use=1
    (or 10, or other) 5 is a good bench mark To start

    Save and exit

    here is an interesting Solve for a Toshiba with built in modem
    "Apparently the 3g modem Radio is by default set to OFF ." [SOLVED] Toshiba built-in 3g Modem (F3507g)

    A site worth reading............

    Stubborn devices; look at the screen shots
    This device was ejected from the desktop it sometimes was not recognized as a modem , but had habit of remounting

    to find were these devices goto , open up the disk utility in the system administration

    REF: INFO possible 4g LTE DEVICE . manufacture data suppressed
    I: If#= 0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm
    I: If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
    I: If#= 2 Alt= 0 #EPs= 1 Cls=02(commc) Sub=02 Prot=01 Driver=cdc_acm
    I: If#= 3 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
    I: If#= 4 Alt= 0 #EPs= 1 Cls=02(commc) Sub=06 Prot=00 Driver=cdc_ether
    I: If#= 5 Alt= 1 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_ether
    I: If#= 6 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage
    I: If#= 7 Alt= 0 #EPs= 0 Cls=02(commc) Sub=0b Prot=00 Driver=(none)
    /usr/bin/usb-devices: line 79: printf: 08: invalid octal number
    I: If#= 0 Alt= 0 #EPs= 0 Cls=0a(data ) Sub=00 Prot=00 Driver=(none)

    the screen shots should be self explanatory: try using eject or safely remove , as mentioned near top of post . " There is a difference between Ejecting the device and Safely removing ", Monitor the results

    Last edited by alexfish; February 26th, 2012 at 03:28 PM. Reason: Modem Manager test Pyhon script ( BCM dbus spec see post #54
    Two tin cans are better than an iphone


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts