Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: Bugfixing the eeepc for Lucid

  1. #1
    Join Date
    Jan 2005
    United States
    Ubuntu 10.04 Lucid Lynx

    Lightbulb Bugfixing the eeepc for Lucid

    ...because it feels so good when I stop...

    This time you can play along at home!

    Click thumbnail for larger version of the stress reduction kit which can be used over and over again!

    This is Bugfixing and Working Around Ubuntu 10.4 LTS Lucid Lynx Guide v.004

    Now with 90% more sarcasm! If you act now we'll double your bitterness! But wait there's more! I can't stop using exclamation marks!!!1111

    I've begun to think Linus' law ("given enough eyeballs, all bugs are shallow") is like Godwin's Law--it doesn't work when invoked directly. I'm sorry, my bad.

    Lucid reinstalls now totaling 00399, but who's counting? Things I have learned so far...

    The default kernel will not consistently give eeepc users a wifi signal. Sometimes it is possible to get a short lived connection by toggling the WiFi on and off, but you will need a wired connection to update and fix your Lucid install. Once you get your system updated to the latest default kernel this actually gets worse ninety nine percent of the time.

    Powermanagement is still broken and there are strange run away processes that hide in the background and ramp up your processor usage. For some reason this mysteriously goes away or stops happening so frequently after a few days time. I don't know why. At first it was thought that UbuntuOne was the culprit, or that the kernel had an issue with the ext4 filesystem, but although removing UbuntuOne and changing to a different filesystem seemed to have helped some neither really fixed things a hundred percent.

    How Lucid Lynx was allowed out the door with these and so many other bugs is beyond me.

    Before proceeding I should warn you that I am not an expert and that many if not all of the tips and tweaks that follow are "dirty hacks" which could cause your eeepc to spontaneously turn into yogurt, make your significant other start chasing after moving vehicles in the street, cause your vision to go dim, etc etc etc. Proceed with caution. I am not responsible if things go awry. I will try to credit the sources of my information when at all possible, but no guarantees.

    NOTE: I am performing all these operations using the EeePC 901 2103 BIOS with SLIC and a changed OEM image. Using a different bios will have different results in some cases. Your mileage may vary.

    Installing Ubuntu...

    Speed up your Lucid Lynx (re)installs

    There are several things you can do to help speed along the process of doing your Ubuntu (re)installs.

    Do not connect to the internet during install time

    Do not connect to the WiFi or the Ethernet during install and you won't sit there for an additional hour staring at the screen while the overloaded default servers download unneeded language packs.

    I've seen install times drop down to almost nothing just by not connecting. If Canonical wants to install language packs it can include them on the ISOs, and not waste our time downloading them during installation. 'Almost done installing' my ***...

    Backup your debs

    When planning on doing a reinstall of Ubuntu make it a practice to navigate to the apt directory and copy all the *.debs over to a flash drive or SD card before doing the install. Believe it or not but there are now over five hundred megabytes of updates to do after Ubuntu is installed. If you back up the previous updates you've done you'll be able to apply many of them without having to wait for them to download again. This can shave off hours depending on your download speeds!

    Where you want to go is:

    Select all the files (minus the one named lock) and copy them to a safe place on an external drive.

    Once you have Ubuntu installed you can copy them back by opening the terminal and getting a root nautilus session::

    sudo nautilus
    Now copy your backed up .debs from your portable drive back to the archives directory path listed above. Now once you connect to the internet and run update manager, you won't have as many files to download from the internet.

    Technically the above is really more for post installation, but I've moved it up so that people don't blow away their previous installs and then wish they'd saved their debs.

    The file system

    Previously I recommended not to install using ext4 because there is a kernel process that is calling constantly and needing to check the disk if you do and will be one of many many processes that will screw up your power management. This issue seems to be fixed in the recommended kernel I list below. You can still read about the issue people were having on the ArchLinux Forums, home to tons of good information for eeepc owners. In particular, user lagagnon explains the issue as follows:

    Quote Originally Posted by lagagnon
    More info: using "iotop" the culprit appears to be "jbd2/sda1-8", which appears to be a kernel process associated with journaling on the ext4 filesystem, if my googling around is correct. And yes it is an Atom processor here also. Strange, guess will just have to wait and see if future updates fixes it. Does not seem correct that it has to access the disc so often.
    Just for fun it appears this issue did not get seem to be fixable by noatime so simply disabling journaling was not a fix. The only fix appeared to be in not using ext4. So we had to ask ourselves whether the speed in boot times is worth the random processor overruns, the overheating that seems to result, and the inability to use many commercial backup imaging programs? Thankfully this no longer seems to be an issue and the trade offs are no longer necessary if you use the kernel recommended further down below.

    Still, there are some situations where ext3 is better in Lucid than ext4, so you'll have to do some homework. I do not recommend reiserfs, because you will find yourself doing disk checks nearly every other day and it is an unsupported filesystem with a very limited future.


    User Ceno reports that there is a way to use ext4 and disable journaling thus fixing the jbd2/sda1-8 bug, but it is a bit involved, so your mileage may vary! Personally I intend to stick with the kernel mentioned above and explained below, but for those who might be interested, here is that fixed:

    Quote Originally Posted by Ceno
    Regarding the jbd2/sda1-8 "bug", if you will, mentioned in the File System section of the 1st post, disabling journaling does indeed solve it.
    First thing's first, we can confirm that our ext4 partition is running a journal with

    $sudo dumpe2fs /dev/sdaX | grep has_journal
    Disabling journaling is rather easy, the only drag is that to make structural changes to a filesystem, the filesystem cannot be mounted with read/write privileges. So, run a live cd and hit

    $sudo tune2fs -O ^has_journal /dev/sdaX
    And it's done. Now when you boot, the change will be noted and the disk will be checked for errors. When the system is finally up we can run this again to confirm that in fact ext4 is running without a journal

    $sudo dumpe2fs /dev/sdaX | grep has_journal
    should now return nothing.

    With this quick fix, no more constant IO peaks. I can now watch youtube videos without constant freezes.
    Thanks for sharing this with us!


    Everyone has their own preferences on this, but this is what I do:

    4GB SSD
    ---/efi 8mbs

    /----swap 1GB
    /-------/usr/share 4GB
    /---------data 11GB

    I find that my system slows down dramatically when I partition the 16GB SSD (the slower one) as my /home so what I do now is partition /usr/share on the slower SSD and that not only saves me some space for applications it also frees up space for those configuration files and themes in /home. I get around the limitations of the User Folders for media (Music, Videos, Public, etc) with symbolic links.

    I will continue to add more preinstall tips as they become available, so please feel free to share any you come across that you know work!

    After the installation...

    You now have Ubuntu Lucid Lynx installed—now what? You're just getting started! Read on to see how much more tweaking there is to do.

    Fix Plymouth...

    First things first. When booting up you might notice the speed of the boot, this is Plymouth and it makes the boot really really FAST! Unfortunately it doesn't seem to work and we have an ugly blinking cursor then suddenly a login screen. We don't get to see any animations or any indicators that the system is doing something. rayraven from the UbuntuForums has a possible fix:

    Quote Originally Posted by rayraven
    Try this, as root: [sudo su]

    echo FRAMEBUFFER=y > /etc/initramfs-tools/conf.d/splash
    update-initramfs -u
    That should make plymouth appear. But, it might delay your boot a tad-bit.
    Considering how fast things can boot on our eeepcs already I don't think we'll miss the few seconds it takes, and at least now we know that the system is booting! You'll need to reboot to see the changes take effect.

    Reduce writes to your SSDs

    These used to be tips that fell under the category of stuff "everyone knows" but as new people come in and the information gets bitrots as wikis get ignored in favor of forum posts (like this one,) people forget. So here they are all in one place because not everyone does know about these and because I notice a major reduction in heat with them enabled and a major speed up in Firefox using them.

    From the EasyPeasy Wiki and Fedora-netbook HOWTO:

    sudo gedit /etc/fstab
    For each of your partitions (/, /usr/share, /data) add ",noatime" after "defaults".

    For example (from desktop, not eeepc do not copy exactly):

    # / was on /dev/sda1 during installation
    UUID=6079da5f-faef-4c8a-b5c1-2685cd47fa8a /               ext3    noatime,errors=remount-ro 0       1
    # /home was on /dev/sda3 during installation
    UUID=51a9de0a-fdfc-47f7-a96e-9b705edd2e8f /home           ext3    defaults,noatime        0       2
    Then add the following to the end of the file:

    # reduce the number of writes
    tmpfs /tmp tmpfs defaults,noatime,mode=1777 0 0
    tmpfs /var/tmp tmpfs defaults,noatime,mode=1777 0 0
    Save the file and close the editor.

    Now let's do something about the swap!

    sudo gedit /etc/sysctl.conf
    Scroll down to the end of the file and copy the following:

    # reduces the likelihood of the system using the swap partition as swap
    vm.swappiness = 1
    vm.vfs_cache_pressure = 50
    Save this and close the editor. Now open Firefox.

    In the URL bar enter the following and type enter:

    Ignore the warning about voiding your warranty and hit the button with the text "I'll be careful, I promise!"

    Right click and select New --> String --> Paste the following:

    as the name and as the string value type in:

    This will instead store the cache in RAM if you created the tmpfs entries in fstab as described above. You did didn't you? Other wise skip this last step altogether as it will slow down your browser! Only do this step if you've aded tmpfs to your fstab!

    Now save the file close the editor and go on to the next step. Settings won't take effect until rebooting.

    The broken theme support:

    Some people like the new themes, because finally they're getting the dark themes they've always wanted in workable fashion! Except, the themes have this sense of being unfinished about them for some strange reason...

    I couldn't imagine why it looks unfinished! Seriously, does this look finished to you? Unfortunately there's nothing we can do about it, since as far as Canonical is concerned everyone else needs to fix their programs to accommodate Ubuntu...what was that about tribalism again Mark?

    Of course these issues are no big deal right? It's only a few apps that break this way, right? Not so much...

    Obviously Ubuntu is perfect and all 337 people who took the time to join Launchpad and report this bug (not to mention how many duplicates are all nuts. Oh and pointing out these facts and the way so many bugs are being ignored so Shuttleworth can play retro skin designer is "pointless bashing" and totally not a reflection of anger at seeing bugs ignored for so long...

    Then again this is the same guy who thinks that 'windicators' are a good idea, so I guess some stupidity is to be expected.

    Hey Mark, here's a clue—this type of thing was tried by almost everyone back in the early days of GUI skinning and there's a reason why it didn't make it as a default theme anywhere, and that's because it sucks as a work environment! But hey if you really want to go back to 1998, it's your dime...

    Those $#&% buttons...

    If by this point you've found yourself suffering from disorientation due to muscle memory constantly having you mouse to the wrong location for the window buttons, maybe this would be a good time to change them back to the defaults?

    In terminal:

    gconftool-2 --set /apps/metacity/general/button_layout --type string menu:minimize,maximize,close
    You could also just get Ubuntu-Tweak and move them around to your heart's content...

    Personally after some time I've gotten used to the window controls being on the left and use the "Black Fruit" emerald theme because it complements the default theme so well. Your mileage may vary.

    Make the default themes more compact...

    Okay, you've rebooted and hopefully everything has gone smoothly and you've logged into your desktop without issue. You should be seeing the new Ambiance and Radiance themes... Unfortunately these new themes are slightly larger than any of us would like to see on the small screens of our eepcs. Elwood, a blogger has a tip for us to make the theme look a bit more compact:

    Quote Originally Posted by Elwood
    Just add this line to the theme’s gtkrc and all the stuff became more compact and finally suitable for the small eeepc display.

    gtk-icon-sizes = "panel-menu=14,14:gtk-button=12,12"
    Have a nice day, even with 1280×600.

    PS: To have all the changes working I had to reboot in order to reload the gnome-settings-daemon
    Personally I find that I like my icons smaller than this on my eeepc, so I've amended that slightly by copying the sizes from one of the older HumanCompact themes to this:

    gtk-icon-sizes = "panel-menu=16,16 : gtk-menu=16,16 : gtk-button=16,16 : gtk-small-toolbar=16,16 : gtk-large-toolbar=16,16 : gtk-dialog=32,32 : gtk-dnd=32,32"
    You'll need to run sudo when you open the gtkrc:

    sudo gedit /usr/share/themes/Ambiance/gtk-2.0/gtkrc
    sudo gedit /usr/share/themes/Radiance/gtk-2.0/gtkrc
    Find the line that says:

    gtk-icon-sizes = "panel-menu=22,22:gtk-button=16,16"
    change the line so it reads to:
    # gtk-icon-sizes = "panel-menu=22,22:gtk-button=16,16"
    and paste the above lines directly under the now blocked off lines of text. Save the theme and reboot to refresh the system and reload gnome-settings-daemon.

    If the above seems too daunting you could also try just downloading the "AmbianceCompact" theme from, which can be found here. Of course if you're having troubles with the above then the rest of this guide will probably be a nightmare for you! Still I recommend doing something with your themes to make them more compact!

    It really makes a difference!

    Remove unused panel applets...

    Here's another annoyance. Shuttleworth in his brilliance surpassing mortal men has decided to break the system tra^^^notification area because it was inconsistent by...wait for it--making it even more inconsistent!

    Just to make things more fun, if you try removing items the way it worked in previous versions of Ubuntu you can end up "losing" items completely unrelated to the one you removed!

    Thankfully there is a way to remove stuff selectively if you follow the advice given by Didius Falco...

    Quote Originally Posted by Didius Falco
    If you want the "envelope" gone, remove the indicator-messages package, and keep indicator-sound (which is for the volume) and indicator-application installed. Don't remove indicator-applet, which is the host applet that all of the above plug into.

    sudo aptitude purge indicator-messages
    You may have to log out to make things show up or go away the way you want them to.

    NOTE: This does not fix the spacing issues or the random movement of icons which seems to happen once in a while.

    make panels customizable again!

    One of the better features in previous versions of Ubuntu was the ability to set your own panel backgrounds. Then mysteriously the feature disappeared around the release of Jaunty or Karmic. Thanks to stinkeye you can customize your panels again:

    Quote Originally Posted by stinkeye View Post
    In your theme's gtkrc file search for panel
    and look for a line that looks similar to
    bg_pixmap[NORMAL] = "panel.png"
    bg_pixmap[NORMAL] = "panel_bg.png"
    Put a hash mark(#) in front of that line.

    Your theme will be in ~/.themes or /usr/share/themes

    If it's in /usr/share/themes you will need to edit as root.
    gksu nautilus /usr/share/themes
    Log out and Log in for changes to work.
    Thank you very much stinkeye! You have no idea how much I missed being able to do this!

    Now that we've gotten the GUI worked out a bit, let's move on to other things. We'll come back to making the mouse work as it did in previous versions of Ubuntu further on down...


    Apparently there are all kinds of issues in Lucid still being worked out and fixed. Who knew? Now is the time to try to connect to your WiFi or plug in your ethernet cable. If using WiFi, you'll probably have to reconnect a few times by toggling the Fn + F2 key a few times if it doesn't connect right away. Keep enabling and disabling until you get somewhere, it'll happen eventually. (You're reading this somehow, aren't you?)

    You'll notice there is a kernel updated listed in the update manager. When you install it WiFi becomes even more flaky. Oh joy! maybe we should try installing something else? I hear Red Hat Fedora works pretty good...LOL just kidding!

    If you are doing this guide and reinstalling from a previous installation of Ubuntu Lucid Lynx you should have backed up your *.debs as recommended up above, otherwise you're going to be waiting quite a bit as Ubuntu downloads and installs updates...

    Assuming that you have already copied the *.debs over to the proper directory or are prepared to download them all now, let's open Software Sources and add a repository which will fix our WiFi issues.

    System-->Administration-->Software Sources
    You will be asked for your password, enter it and the Software Sources applet will load, you want the tab that is named Updates.

    You should see a screen like this one:

    See how the Unsupported updates (lucid-backports) list box is checked? You need to check it also. Now click close and reload the repositories as instructed.

    Once you've reloaded the repositories open the terminal and type in the following:

    sudo apt-get install linux-backports-modules-wireless-lucid-generic-pae
    The above package is a metapackage pointing towards the latest version of the wireless modules for the PAE kernel. Installing it will automatically add the linux-image-generic-pae package, another metapackage which will install the latest version of the kernel with PAE support. You'll notice this kernel is intended for systems with more than 4GB RAM according to Synaptic, yet strangely enough this is the only default kernel that has good WiFi support for my eeepc and I only have the stock 1GB RAM installed.

    Before rebooting the eeepc you should probably add the wireless card to the modules list, so you'll want to run the following commands:

    sudo gedit /etc/modules
    At the end of the file add this:

    Save and reboot. Your wireless should be working again without issues.

    It works. That's all I know. And much much easier than the older method endorsed by this guide, included below for completeness sake:

    Quote Originally Posted by bornagainpenguin
    WiFi doesn't work? Install the modules from Ralink!

    For whatever reason the drivers for the RT2860sta WiFi card found in many netbooks was broken in the last few kernels. There are all sorts of reasons for this, but as far as I can see the chief one seems to be politics. Whatever. The fact is drivers do exist and the manufacturer has provided them, unfortunately you'll have to compile these yourself.

    I am aware that an alternate kernel is available from Ricardo Salveti that works for some people. I never had any success with it though and there were reports of bad side effects. Also suggested as a possible fix is to update to the latest bleeding edge kernel possible. errr...yeah, I think I'll stick with the manufacturer's drivers even if I have to redo them every kernel release...

    Fortunately there are guides for working around this long standing bug, including one from Fass over at Ubuntu Forums who walks you through installing the module on Intrepid. Sheesh! This bug really has been around for awhile, hasn't it? Thankfully there are more updated guides available we can follow...

    Sven6210 (also from UbuntuForums) updates the instructions given by Chris Barker and fills in some of the information he glossed over. Namely what to do when one of the files mentioned by Barker gets a character encoding error! Thankfully Sven6210 walks us through it:

    Quote Originally Posted by Sven6210
    Here the description step by step:

    Step 1
    Download latest RT2860 driver source code from Ralink

    Go to
    Click on Software
    Click on Linux

    Download the driver "RT2860PCI/mPCI/CB/PCIe(RT2760/RT2790/RT2860/RT2890)“ dated 01/29/2010, version

    You need to enter a name and an email and press accept to download

    Step 2
    Open and extract the downloaded file to your Home directory. Accept the standard folder and to not change the name

    Open a terminal window
    cd 2010*
    Step 3
    gedit ./os/linux/
    Use the find command to locate HAS_WPA_SUPPLICANT and make sure it is set to y for yes. It should look like this when finished:

    Use the find command to locate HAS_NATIVE_WPA_SUPPLICANT_SUPPORT and make sure it is set to y for yes. It should look like this when finished:

    Close and save this file.

    Step 4
    gedit ./common/cmm_wpa.c
    You will get a message that the character encoding was not recognised, choose "Western“ and press "Retry“

    Use the find command to locate MIX_CIPHER_NOTUSE. Replace with this code:

    Step 5
    Now we need to compile a new module, in order to do so we first need to install gcc and we need a network connection for that. So now you either need a wired or 3G connection to the internet.

    Go to System
    Go to Administration
    Click Synaptic Package Manager
    Look for "gcc“ and choose it to be installed

    After successfully installing gcc please execute the following commands step by step in a terminal window.

    sudo su
    make && make install
    sudo ifconfig wlan0 down
    sudo rmmod rt2860sta
    Step 6
    Rename the old rt2860sta.ko driver file to rt2860sta.ko.dist using:

    sudo mv /lib/modules/2.6.32-24-generic/kernel/drivers/staging/rt2860/rt2860sta.ko rt2860sta.ko.dist
    Attention: If you are not for whatever reason using the 2.6.32-24-generic kernel you need to replace the 2.6.32-24-generic with the actual directory name of your kernel, please check the folder name with Nautilus.

    Step 7
    sudo depmod -a
    sudo modprobe rt2860sta
    After you issue the previous command you should see the Desktop top panel wireless icon come to life as it tries to connect. You will be prompted for a WPA password. Give it a little while and it should connect.

    Not sure this command is necessary but you can use if the Wireless isn’t started automatically.

    sudo ifconfig wlan0 up
    Step 8
    Okay at this point you have made a lot of progress and should be happily surfing.

    But, and this is a biggie, what happens if you reboot? Unfortunately, you are back at square one without the RT2860 driver being loaded after a reboot. To remedy this situation, continue with step 9.

    Step 9

    Open a terminal window

    cd 2010*
    cd os
    cd linux
    sudo cp rt2860sta.ko /lib/modules/2.6.32-24-generic/kernel/drivers/staging/rt2860/
    Attention: you need to replace the 2.6.32-24-generic with the actual directory name of your kernel if not using the one listed, same as step 6

    Step 10

    Update your modules boot file with the following command:

    gksudo gedit /etc/modules
    Add the rt2860sta on a line at the end of the file and close and save the file.

    Step 11

    Reboot and check to see that you are now automatically connecting to your wireless network!

    I hope it works for you as well
    As do I. I made some modifications from the original directions as listed, mostly by adding the exact kernel name as of this writing. If you updated like you were supposed to then there shouldn't be any issues here. You did update, didn't you? Otherwise as it says in the instructions, you'll have to navigate to the directory and see which kernel you're running.
    Again, please note that this is no longer the way I recommend to get WiFi working; it is only included for the sake of completeness.

    Make the mouse work right again!
    Restoring the previous handling of middle-clicking links in Firefox

    Randomly upon the release of Karmic 9.10 Canonical developers decided to change the two finger middle click that had been the default for well over two years and three releases of Ubuntu. Worse they removed any way to revert the changes. The only solution for many people on Karmic was to drop in a replacement module compiled by people on the Italian eeepc forums and hope an update didn't break things. Thankfully there is an easier way on Lucid, using a PPA.

    Just add Yuri Khan's PPA to your system in terminal:

    sudo add-apt-repository ppa:yurivkhan/proposed
    Now update for the system to find the fixed gnome-settings-daemon...

    sudo apt-get update
    sudo apt-get upgrade
    Hit y to allow the update to download and install then reboot for the changes to take effect.

    Back? Now you need to change an entry in the gconf-editor. Get the run box by hitting Alt+F2, then type in "gconf-editor" no quotes and navigate your way to:

    Then you will need to change the keys to your preferred handling:

    Quote Originally Posted by Yuri Khan
    Edit values tap_button_rt, tap_button_rb, tap_button_lt, tap_button_lb, tap_button_1, tap_button_2 and tap_button_3 as desired. These are, respectively: right top, right bottom, left top, left bottom, one-finger, two-finger and three-finger taps. (Corner tap settings are in Lucid version only. In Karmic, gnome-settings-daemon didn’t control corners.)

    The values meaning is:
    0: disabled
    1: left click
    2: middle click
    3: right click

    (If you feel adventurous, you might try 4, 5, 6, 7 (scrolling), 8, 9 (browser Back/Forward) but you don’t really want these on taps.)

    If this works for you, please post feedback in the bug #563276. If it doesn’t… well, give feedback anyway, we’ll try to work it out somehow.
    Thank you very much! This has been a life saver on my eeepc!

    While we're configuring the mouse, now might be a good time to enable two finger scrolling again too.

    On the Touchpad tab there will be an option to allow this click it and your mouse will function again like it had under the last several versions of Ubuntu.

    Depending on your personal preferences you can also go to the General tab and enable the Locate Pointer option which will show the mouse position when the control key is pressed.


    NOTICE: There have been reports of problems with this next tweak. I haven't had any issues with it on my eeepc 901L, but DavAlan reported having some trouble on his eeepc 900 after using this. Your mileage may vary...

    Quote Originally Posted by DavAlan
    Just brought my raid lvm install down earlier when the updater installed HAL for some weird reason (warning - the added "nohal download" line did not work out so well :S )
    The following may be removed in an update unless I hear confirmation that the errors caused by HAL being installed despite the --no-install-recommends flag being used were a one time thing. I am including it for now for completeness sake.

    Quote Originally Posted by bornagainpenguin
    Thanks to the removal of HAL it is a bit tricker to get Laptop_Mode_Tools installed. Also there will be a warning about removing the ""pm-utils-powersave-policy" package" which so far as I can tell can safely be ignored unless you were planning on writing your own power management scripts...

    The command you want is:

    sudo apt-get install --no-install-recommends laptop-mode-tools sdparm ethtool
    The --no-install-recommends should prevent installation of HAL. All credit (and blame) can be given to the Doesn't Not Compute blog, where I saw this.
    Power savings? Kind of...


    Previously I had posted here a list of scripts by Axx83 from the Ubuntu Forums, but many of them were reported to be less than useful in Lucid and I didn't even enable them at all in the last few installs I did. If you still want them or feel that they make more of a difference than I think feel free to post and explain why and what your results are. For now these are no longer included directly into this increasingly large post. You can still find the original posting here. Bear in mind they were originally written for Karmic and may behave wildly differently on Lucid.


    Since the posting of this guide in its previous form, marx (Grigori Goronzy) has surfaced again with a new release of his application:

    Quote Originally Posted by marx
    2010-05-23 Version 0.9.6
    Hi, I'm still alive!
    Version 0.9.6 contains various bugfixes plus support for newer DBus APIs and Linux kernels. The deb package is designed for Ubuntu Lucid. A few rough edges remain, but everything works fine for me.
    What's new:
    * Disabled hotkey-setup/hotkey handling - now handled correctly out of the box
    * Use upstart instead of sysv init
    * Switched to UDisks and UPower DBus APIs
    * Cleaned up eee-control-setup
    * Misc fixes
    Ubuntu package: Lucid (10.04)
    Get the source code from Git: git clone git:// && cd eee-control && git checkout 0.9.6

    PS: Version 0.9.5 was supposed to introduce compatibility for Ubuntu Karmic, but was never released.
    So now we know. I've installed the application and it works perfectly for me, triggering the WiFi, setting the powersaving mode automatically when the eeepc is taken off the power supply. If you're tied to Ubuntu this is an application you want installed!

    Other power management options...

    Since the last posting of this guide there have been updates to Fewt's Jupiter applet, which while no longer supported on Ubuntu is not explictedly hostile to it either. Packages and information can be found here. In case you were thinking of switching to Fedora, the good news is that Fedora is offcially listed as a supported distro by fewt! Just saying...

    There is also a new one called entwjne written by member Arvigeus. Unfortunately it is a command line only application for the time being, but people wishing to help speed development along can help by beta testing. See entwjne here.

    BatteryStatus vs ye olde battstat

    One of the more grievous removals in Lucid was the battstat applet which was more accurate an indicator on eeepcs than the default gnome-powermanager battery applet. In previous versions of Ubuntu this was only a few clicks away and could easily be added to your system tr^^^notification area. In Lucid Canonical decided to simply make it impossible to launch the applet despite it still being listed as present. If you were to open Synaptic and do a search for "battstat" (no quotes) you would discover it still listed in the information panel under the gnome-applets package.

    Despite there being 192 people who went through the effort to create a Launchpad account, never mind the twelve duplicate threads on this issue this guy has decided it is unnecessary.

    Thanks alot Mark. You're a brick, a real... $#&* brick, pal!

    Thankfully there are still options available:

    Quote Originally Posted by perky
    To install: Save and extract to a temporary directory, then cd to where you extracted the files and type:

    sudo sh
    GNOME Panel will reload and the applet should now appear in the 'Add to Panel' list as 'Battery Status Applet'.

    Known bugs:

    Most bugs are caused by conflicting gconf settings from older versions and can be fixed by:
    1. Removing the applet
    2. Running as regular user: gconftool-2 --recursive-unset '/apps/battery-status-applet'
    3. Re-adding the applet

    The error: ...OAFIID:GNOME_PythonPanelApplet... means that the OAFIID in the .server file does not match the last line in the .py file.
    Installing the latest version fixes this.

    Other distros display a default icon unless Humanity icon theme is installed (will be fixed when I get around to making my own icons)

    Thanks to all that have helped identify bugs

    Uninstall instructions:
    sudo rm /usr/lib/bonobo/servers/battery_status.server
    sudo rm /usr/local/bin/
    If you do not have an account at the UbuntuForums you will not be able to download the applet. Here's a mirror:

    Otherwise if you really prefer to use the old battstat that was included with every previous version of Ubuntu you can try this dirty hack:

    Quote Originally Posted by bornagainpenguin
    I was able to "cheat" by going to the nearest Debian mirror and installing the appropriate gnome-applets AND gnome-applets-data for my version of Gnome. I ignored warnings that I was installing newer versions of the software than what was in the channel and after some dependencies were installed and I did a quick logout I was able to add back the battstat icon to my panel.

    Here's a heads up for any Canonical developers: If you want to remove or "depreciate" a piece of system software, it's usually a good idea to make sure that the replacement works just as well as what is being removed...

    What I did was go to:

    Then download these two files:

    Ubuntu Lucid demands that you have a later version of gconf2 and libnotify1 installed, so you'll have to grab those too.

    Go to:

    download this file:

    Go to:

    download this file:

    Now from within the terminal navigate to the directory where you downloaded these files and enter this command:

    sudo dpkg -i *deb
    Do a restart and the battstat applet will be available again right where it used to be before developer stupidity caused Canonical to remove it from the distro. Just add it to the panel and disable the gnome powermanager battery icon in preferences.

    Personally I prefer the older battstat applet, but am happy to see Perky's battery status applet being devloped and I have high hopes for it still being around even after Canonical manages to completely cripple battstat from working even with this typs of dirty hack.

    NOTICE: Canoncial could invalidate this dirty hack at any time so if you are nervous you are best to just use Perky's applet.

    Curb the heat by using the latest video drivers

    Personally I'm still not convinced it is any one thing that causes the eeepc to no longer overheat, but a combination of little things that each reduce the heat bit by bit. Nevertheless I've been using this PPA also and have definitely seen improvements in both heat reduction and video playing.

    Quote Originally Posted by Vredley
    Oh, and one other thing - my 4G seems to be running a bit cooler since I installed the latest stable video driver from the X-swat PPA:
    To do this you need to add the repository:

    sudo add-apt-repository ppa:ubuntu-x-swat/x-updates
    Then you'll need to refresh and upgrade your packages:

    sudo apt-get update
    sudo apt-get upgrade
    If for some reason the xserver-xorg-video-intel package gets held back, you can install it manually:

    sudo apt-get install xserver-xorg-video-intel
    This will pull in the missing packages holding you back and allow everything to install. To see things take effect, reboot the eeepc.


    A few tips for improving battery via passing along options to the kernel in Grub2. Fair warning: the acpi_osi option may not apply to all eeepcs, although they have been very helpful to many users with eeepc 1xxx models! Your mileage may vary.

    Any text editor will work at reading the below files. nano, kate, gedit, etc. You will have to be root or use sudo before the commands.

    $ sudo gedit /etc/default/grub

    1. Change IO scheduler:
    2. Use the integrated HPET timer (saves about 30 CPU wake ups per second)
    3. Make sure the eeepc-laptop kernel module is loaded properly (does not load correctly with kernel 2.6.32):
    $ lsmod | grep eee # if nothing is listed, it isn't loaded

    How to load the above in grub2:

    GRUB_CMDLINE_LINUX_DEFAULT="acpi_osi=Linux elevator=deadline hpet=force quiet"
    # update-grub2
    I've also seen reports that elevator=noop is a good option to use instead of elevator=deadline.

    I recommend changing the grub2 configuration to wait a few seconds while testing these tweaks to allow you to edit them out if they prevent booting. to do that simply make the following changes:

    Where it says GRUB_HIDDEN_TIMEOUT=0 add a "#" in front of it to allow the count down to work again.

    Then change the count down from ten seconds to something smaller, like three or two if you're fast enough to hit the keys before it starts. You can do that by changing the number here:

    Save the file and as instructed above don't forget to update the configuration!

     sudo update-grub
    Reboot to see the changes.

    Still to do and errata...

    I'd like to add a small section on what can be removed for space saving reasons and lack of usefulness to the average user. Things to include here are fspot, brasero, tomboy etc. Usually I just use the guide here, but it is sadly out of date and much much care needs to be taken with this or users will find themselves without a network manager installed!

    More tweaks and something on the benefits of using Nautilus Elementary:

    Next version...

    I want to investigate adding Konstantinos Natsakis' repository as a possible solution to the theming issues mentioned above. Depends on whethe ror not it actually solves the problem.

    I'd still like to explain how I set up my /data with symbolic links and hopefully have a better way to do it than I currently use. I had a thread open on UbuntuForums on the subject, and the guy responding was great about trying to help me figure things out, but unfortunately much of what was posted went waaaaay over my head. Maybe someone from the forums can take it and run with it?

    Would like to know if there is a good way to back up and restore a music collection and podcast directory like can be done in iTunes, but using Banshee or Rhythmbox? If there is it should definitely be added to the guide for those of us who distro hop!

    Feel free to suggest items to add for future versions!

    Hopefully this will be of use to someone. Considering it has taken me nearly an entire day to do, I certainly plan on using it myself in the future... Nice to have all the information in one place, you know?


    EDIT -- added tip to customize panel backgrounds
    Last edited by bornagainpenguin; August 1st, 2010 at 05:34 AM. Reason: New version posted; also really UbuntuForums, you're going to count smilies as images? REALLY?
    Have a Virgin Mobile USA smartphone?
    Check these guys out!

  2. #2
    Join Date
    Jan 2005
    United States
    Ubuntu 10.04 Lucid Lynx

    Re: Bugfixing the eeepc for Lucid

    RESERVED for future posting
    Last edited by bornagainpenguin; April 30th, 2010 at 08:05 AM. Reason: future-proofing--2013 is a long ways off!
    Have a Virgin Mobile USA smartphone?
    Check these guys out!

  3. #3
    Join Date
    Feb 2006
    Stockholm, Sweden
    Ubuntu 10.04 Lucid Lynx

    Re: Bugfixing the eeepc for Lucid

    PS: Anyone know how to get eee-control to do cpu scaling? I installed this package, but my eeepc is still running hot..
    I am also interested in a solution. Our EEEPC 701 with Lucid is running very hot, no fan nor CPU scaling! I fear the risk for hardware damage if overheated.

    Actually we have two similar EEEs in the family, a 701 and a 900. (Its one laptop per child!)
    Sad to say, but both netbooks are having similar problems with Ubuntu 10.04 Lucid, namely:

    * The fan is not activated and the EEE 701 runs HOT.
    * No processor scaling, thus battery time is shorter than it could be.
    * Wrong indication of the last full capacity of the battery (EEE battery uses percentage and not mA )
    * No animated splash on boot (solution in earlier posts of this thread)
    * Microphone works barely and is very noisy
    * Evolution and Rhythmbox do not work well with a limited screen of 800x480 of the EEE 701
    * Default theme has to be adjusted (solution in earlier posts of this thread)
    * Trackpads are dead after returning from suspend
    * Multi-touch trackpad of the EEE 900 does not work.
    * The package usb-modeswitch has to be installed manually if using a wide range of mobile broadband modems (this is a generic problem for all Ubuntu 10.04 systems)

    Regarding the EEEs, the 9.04 release was easier to live with than the original Xandros. Unfortunately the number of new and old bugs on the 10.04 LTS is alarming. The problem is that the convergence of Ubuntu is very slow, and when everything ever becomes "perfect" then the machines will certainly be more than obsolete! Actually these EEEs were already obsolete a year ago!

    PS: As a reference I would like to mention that I have been using GNU/Linux since 2002 and Ubuntu since Hoary 5.04. Now I have started to feel very concerned about the practical future of GNU/Linux for business applications. I am not into systems development anymore and I would describe myself as a conceptual systems integrator, looking for integrated open software solutions for small and medium organizations. I usually test a dozen of netbooks, laptops, workstations and servers with different distros and releases.

  4. #4
    Join Date
    Mar 2009

    Re: Bugfixing the eeepc for Lucid

    Ive mostly been seeing performance issues while clicking and dragging files around. Nautilus runs at 100% cpu usage for a few seconds. No errors in logfiles.

    Also, compiz doesn't work right with an external monitor.

    Running this:
    'xrandr --output LVDS1 --off --output VGA1 --auto'
    allows me to turn off my internal screen, leaving only my external one on. But if I then run totem, it switches on my internal screen, makes that primary, and then sets up my external screen as an extended desktop.

    Running 'xrandr' with no other options does the same.
    So those are the issues I am seeing.

  5. #5
    Join Date
    Dec 2009

    Re: Bugfixing the eeepc for Lucid

    Fix the backlight on 1005p (probably other similar models too): edit /etc/default/grub, add acpi_osi=Linux acpi_backlight=vendor to GRUB_CMDLINE_LINUX_DEFAULT and run update-grub

    Also you can try to add fastboot to boot parameters (too lazy to check if it is still not default, in older kernels it improved the boot time by a few secs by parralel initializing of some subsystems like ata, usb)

    If you have a ssd, add elevator=deadline (later edit: typo fixed, thanks bornagainpenguin)
    Last edited by danb1974; May 3rd, 2010 at 07:22 AM.

  6. #6
    Join Date
    Jan 2005
    United States
    Ubuntu 10.04 Lucid Lynx

    Re: Bugfixing the eeepc for Lucid

    Quote Originally Posted by danb1974 View Post
    If you have a ssd, add elevator=dealine
    I think you meant elevator=deadline, right?


    PS: Those other tips are new to me and I'll have to see if they do anything good for me on my eeepc 901L when I get a chance to try Lucid on my eeepc again later. Right now I have to get ready for Church, will try to add those tips to the first post once I've had a chance to test them out and organize the information. Thanks for contributing!
    Have a Virgin Mobile USA smartphone?
    Check these guys out!

  7. #7
    Join Date
    Jan 2005
    United States
    Ubuntu 10.04 Lucid Lynx

    Exclamation Re: Bugfixing the eeepc for Lucid

    Just saw this mentioned in the comments on

    Quote Originally Posted by Jesse
    Lovely. So what you are saying is that it looks like *buntu regularly calls home, just like the rest of the corporate shovelware OSes. How "helpful".

    No, I'm not saying that. What I said was the service is doing something in the background. It could be checking for folders to sync, it could be monitoring file system changes, it could be aggressively polling for status changes. Or, maybe it is contacting the One servers. What I was saying is it was doing something when I felt it should be idle. I'm not certain the One service was accessing the network, but it was churning on the CPU.
    Could someone with Lucid on their eeepc try disabling\removing UbuntuOne and report back if this makes any difference with CPU scaling or with how hot the handrest gets? I seem to recall similar issues with Tracker when it was first introduced in Gutsy or around-there-abouts and people reported the service was constantly polling and causing issues. Could this be a similar issue with UbuntuOne? The fix then was in removing the application and services, it could be again for this...

    Have a Virgin Mobile USA smartphone?
    Check these guys out!

  8. #8
    Join Date
    Jan 2005
    United States
    Ubuntu 10.04 Lucid Lynx

    Re: Bugfixing the eeepc for Lucid

    Bump for update
    Have a Virgin Mobile USA smartphone?
    Check these guys out!

  9. #9
    Join Date
    Aug 2006
    Ubuntu 11.04 Natty Narwhal

    Re: Bugfixing the eeepc for Lucid

    I tried installing the RAlink driver, and at first, it worked. Now since about two days ago, wireless is back to failing to authentication failure.

    I even tried to install the 2.6.33 kernel, but that was a real disaster, as the touchpad didn't work anymore and the grafics were also borked.

    Has anybody got a working hibernate? If my eeePC goes into hibernate, it refuses to switch off.

    This whole mess is really a big regression in comparission with Karmi and at the moment I'm really pondering on downgrading again. Come on, Lucid should be a LTS version...This isn't up to the usual quality of LTS versions.

  10. #10
    Join Date
    Jan 2005
    United States
    Ubuntu 10.04 Lucid Lynx

    Re: Bugfixing the eeepc for Lucid


    /me off to eat now. Food good...brain tired...

    Have a Virgin Mobile USA smartphone?
    Check these guys out!

Page 1 of 4 123 ... LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts