Page 1 of 5 123 ... LastLast
Results 1 to 10 of 44

Thread: Plymouth low res boot screen.

  1. #1
    Join Date
    Sep 2008
    Location
    luxembourg
    Beans
    47
    Distro
    Ubuntu 11.04 Natty Narwhal

    Plymouth low res boot screen.

    I have searched the forums on this problem and I am still not really clear on the fix for this or even if I should wait for final release.
    I am running Lucid 64bit and have upgraded through the cycle from Karmic. I am using nvidia proprietary drivers. All the time that the Plymouth boot screen has been available it has been in low resolution. As we are now at beta 2 I am torn between searching a fix or waiting for the final release...

    So, from what I have read I need the 'nouveau' driver to fix this issue.
    1. How do I install this in place of my existing nvidia proprietary driver?
    2. I am a little bit confused by the hardware drivers selection panel telling me that I have an nvidia driver installed but that it is not in use-I read that this might be a bug??

    A clear step by step fix would make a busy guy very happy
    Ubuntu 11.04(amd64)
    |Abit FP-IN9 SLI | Intel(R) Core(TM)2 Duo CPU E8200@2.66GHz | GeForce 9800 GT |

  2. #2
    Join Date
    Oct 2006
    Location
    Minnesota, USA
    Beans
    198
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Plymouth low res boot screen.

    Take a look at /etc/default/grub and change 'GRUB_GFXMODE'. For example, mine is 'GRUB_GFXMODE=1024x768'. After saving the changes, run 'sudo update-grub'. Reboot and enjoy a nice plymouth and the proprietary nvidia driver. I don't give step-by-step fixes in development.
    Last edited by Kow; April 11th, 2010 at 08:11 AM.

  3. #3
    Join Date
    Apr 2009
    Beans
    865

    Re: Plymouth low res boot screen.

    I posted a similar query yesterday.
    I can't comment on 'nouveau' as I have never had any experience but I have found something that seems to be working for me with nvidia:

    Edit /etc/grub.d/00_header
    Then look for the line "set gfxmode=${GRUB_GFXMODE}" (line 103 in my case).
    Add a line right beneath it like this:
    set gfxpayload=1280x1024 (with your desired resolution).

    Though the strange thing is this will only allow me to use the dmicode resolution so the aspect ratio is slightly off for me.
    My monitor res is 1680x1050 but in grub and plymouth it won't work with that or other resolutions with the same ratio.

    I also found this page: http://www.webupd8.org/2010/03/how-t...th-nvidia.html
    With those instructions, using gfxpayload=keep instead of the actual resolution, I found I was often left with a black screen without it reaching the desktop for some reason.
    Last edited by x-shaney-x; April 11th, 2010 at 08:20 AM.

  4. #4
    Join Date
    Feb 2007
    Beans
    778
    Distro
    Ubuntu Development Release

    Re: Plymouth low res boot screen.

    I have found
    Code:
    set gfxpayload=keep
    works fine for me ( I don't have the probs x-shaney mentions above)
    To err is human, but not uniquely so.

  5. #5
    Join Date
    Sep 2008
    Location
    luxembourg
    Beans
    47
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Plymouth low res boot screen.

    @ubername @x-shaney-x @kow thanks for your input.
    I will try this fix when I get back to my home machine...
    Ubuntu 11.04(amd64)
    |Abit FP-IN9 SLI | Intel(R) Core(TM)2 Duo CPU E8200@2.66GHz | GeForce 9800 GT |

  6. #6
    Join Date
    Apr 2009
    Beans
    865

    Re: Plymouth low res boot screen.

    Quote Originally Posted by ubername View Post
    works fine for me ( I don't have the probs x-shaney mentions above)
    I have since seen that solution posted in a lot of places and it seems to work for other people.
    It seems to be when my res switches from the boot res to my desktop res something goes wrong but not if I set the boot res for gfxpayload.
    Wish I could get the same res for my desktop and for boot.

  7. #7
    Join Date
    Mar 2007
    Beans
    649
    Distro
    Ubuntu Development Release

    Re: Plymouth low res boot screen.

    that solution breaks tty which could be bad if you get the wrong kind of testing breakage. there is a monumentally long thread+bug report. its being worked on and i'm sure it will be fixed by release.
    Repair:dpkg --configure -a Reconfigure:dpkg-reconfigure pkg (-a) Fix:apt-get -f install (pkg) Nuke:dpkg --force-remove-reinstreq -r pkg Corrupt deb:rm /var/cache/apt/archives/pkg Hack dpkg:rm /var/lib/dpkg/info/pkg* Chroot unbootable ubuntu

  8. #8
    Join Date
    Apr 2009
    Beans
    865

    Re: Plymouth low res boot screen.

    I found this information in /usr/share/doc/plymouth/README.Debian:

    Code:
    High-color graphics on nVidia, ATI and other cards
    --------------------------------------------------
    
    Our default configuration uses low-color graphics on cards or drivers
    for which "Kernel Mode Setting" (in-kernel graphics drivers) are not
    available.
    
    This is because the driver that permits high-color graphics tends to
    cause issues with suspend and resume, and we opted to prefer that
    working.
    
        For nVidia and ATI users, the default "nouveau" and "radeon"
        drivers are Kernel Mode Setting enabled, but do not always
        provide 3D capability at the current time.  By switching to
        using the restricted/non-free nvidia-glx or fglrx drivers,
        you will gain 3D capability at the loss of a high-color
        splash screen.
    
    You can however chose to enable high-color (and resolution) console
    if you find it doesn't affect suspend/resume for you, or you don't
    use that feature.
    
    There are various methods of doing this, the most robust is the
    following four steps:
    
     Append video=vesafb to the GRUB_CMDLINE_LINUX_DEFAULT in
       /etc/default/grub
     sudo update-grub
    
     echo FRAMEBUFFER=y | sudo tee /etc/initramfs-tools/conf.d/splash
     sudo update-initramfs -u
    Tried it and it did nothing for me and looking at dmesg it wasn't using vesafb anyway.

  9. #9
    Join Date
    Jul 2007
    Location
    UK
    Beans
    17,063
    Distro
    Ubuntu Development Release

    Re: Plymouth low res boot screen.

    Quote Originally Posted by Kow View Post
    Take a look at /etc/default/grub and change 'GRUB_GFXMODE'. For example, mine is 'GRUB_GFXMODE=1024x768'. After saving the changes, run 'sudo update-grub'. Reboot and enjoy a nice plymouth and the proprietary nvidia driver. I don't give step-by-step fixes in development.
    I'm getting a rather large ugly ubuntu logo. Basically it res is too low on my 22" lcd its ugly.

    Change the res as above only changes the grub menu res for me.

    nVidia 8600

  10. #10
    Join Date
    Jan 2009
    Location
    UK
    Beans
    247
    Distro
    Ubuntu 11.10 Oneiric Ocelot

    Re: Plymouth low res boot screen.

    I am experiencing similar problem when ati opensource driver was in use the boot screen was high res. Since using the closedsource ati driver (from hardware wizard) I have a low res boot screen & hi-res desktop.
    Linux Mint 12 (11.10 Based) Gnome 3.0 User

Page 1 of 5 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •