Results 1 to 9 of 9

Thread: Still .htaccess not working

  1. #1
    Join Date
    Mar 2010
    Beans
    27

    Still .htaccess not working

    i have followed the tutorial from this site

    https://help.ubuntu.com/community/En...eHtaccessFiles

    i have changed this file /etc/apache2/sites-available/default

    and in this file i have changed AllowOverride None to AllowOverride All

    but still i get

    Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, webmaster@localhost and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.


    Plz some one help i have installed and reinstalled apache 2 time already and now i am fedup

    plz help............

  2. #2
    Join Date
    Jun 2007
    Location
    Porirua, New Zealand
    Beans
    Hidden!
    Distro
    Ubuntu

    Re: Still .htaccess not working

    Moved to "Server Platforms"

    Did you remember to do this: ?
    Code:
    sudo /etc/init.d/apache2 reload
    Any clues in the server log?
    Last edited by lisati; April 6th, 2010 at 08:03 AM.
    Forum DOs and DON'Ts
    Please use CODE tags
    Including your email address in a post is not recommended


  3. #3
    Join Date
    Dec 2006
    Location
    Chicago
    Beans
    3,839

    Re: Still .htaccess not working

    Code:
    tail /var/log/apache2/error.log
    Where is the .htaccess file, and what are the permissions on it?

  4. #4
    Join Date
    Apr 2009
    Location
    California
    Beans
    72
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Still .htaccess not working

    Quote Originally Posted by @mir View Post
    i have changed this file /etc/apache2/sites-available/default

    and in this file i have changed AllowOverride None to AllowOverride All
    At a super quick glance:

    Did you do it in both places in the default file?

    By default it is in there twice.

    -Pnuts

  5. #5
    Join Date
    Mar 2010
    Beans
    27

    Red face Re: Still .htaccess not working

    Quote Originally Posted by Pnuts View Post
    At a super quick glance:

    Did you do it in both places in the default file?

    By default it is in there twice.

    -Pnuts
    Wait u mean default-ssl i have to change in that too

  6. #6
    Join Date
    Mar 2010
    Beans
    27

    Re: Still .htaccess not working

    Quote Originally Posted by cdenley View Post
    Code:
    tail /var/log/apache2/error.log
    Where is the .htaccess file, and what are the permissions on it?

    this is what i get when i write

    Code:
    tail /var/log/apache2/error.log
    Code:
    [Wed Apr 07 00:52:05 2010] [notice] caught SIGTERM, shutting down
    [Wed Apr 07 09:36:01 2010] [notice] Apache/2.2.11 (Ubuntu) PHP/5.2.6-3ubuntu4.5 with Suhosin-Patch configured -- resuming normal operations
    [Wed Apr 07 09:48:29 2010] [error] [client 127.0.0.1] File does not exist: /var/www/favicon.ico, referer: http://localhost/test/bbb/123
    [Wed Apr 07 10:00:39 2010] [notice] caught SIGTERM, shutting down
    [Wed Apr 07 10:00:40 2010] [notice] Apache/2.2.11 (Ubuntu) PHP/5.2.6-3ubuntu4.5 with Suhosin-Patch configured -- resuming normal operations
    [Wed Apr 07 10:00:54 2010] [notice] Graceful restart requested, doing restart
    apache2: Could not reliably determine the server's fully qualified domain name, using 127.0.1.1 for ServerName
    [Wed Apr 07 10:00:54 2010] [notice] Apache/2.2.11 (Ubuntu) PHP/5.2.6-3ubuntu4.5 with Suhosin-Patch configured -- resuming normal operations
    [Wed Apr 07 10:01:18 2010] [error] [client 127.0.0.1] File does not exist: /var/www/favicon.ico
    [Wed Apr 07 10:01:21 2010] [error] [client 127.0.0.1] File does not exist: /var/www/favicon.ico

  7. #7
    Join Date
    Mar 2010
    Beans
    27

    Re: Still .htaccess not working

    Quote Originally Posted by lisati View Post
    Moved to "Server Platforms"

    Did you remember to do this: ?
    Code:
    sudo /etc/init.d/apache2 reload
    Any clues in the server log?

    yes is did write this

    Code:
    sudo /etc/init.d/apache2 reload
    and also this

    Code:
    sudo /etc/init.d/apache2 restart

  8. #8
    Join Date
    May 2009
    Beans
    121
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Still .htaccess not working

    The AllowOverride directive is set twice in the default site.
    In <Directory /> it should be set to AllowOverride None
    And in <Directory /var/www> to AllowOverride All

    You should only allow the overrides you need. If you only need to rewrite url use
    AllowOverride FileInfo
    If you also need autherization use
    AllowOverride FileInfo AuthConfig

    You need to post the error.log from when you get the internal server error.
    If it says somthing about syntax error you need to check your .htaccess syntax.

  9. #9
    Join Date
    Mar 2010
    Beans
    27

    Re: Still .htaccess not working

    Thankx guys

    i just restarted my system it started to work


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •