Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Cannot delete file

  1. #1
    Join Date
    Jun 2007
    Location
    Guadalajara, Mexico
    Beans
    35
    Distro
    Kubuntu 10.04 Lucid Lynx

    Cannot delete file

    Hi guys, I have a folder that is hard (impossible) to delete, it's not about permissions, what happens is that the system tells me this file does not exist at all, but I see the icon there.

    Something curious is that this file has a little black square with a "?" inside, I have another file (in the trash can) with this questionmark and guess what.. I cannot delete it either.

    I tried logging in directly to the terminal and tried to rm -R and same thing happens, it says file does not exist.

    I am using kubuntu 9.10, this is a screenshot of the problem, hope you got a solution for this.

    Thanks!


  2. #2
    Join Date
    Feb 2009
    Location
    USA
    Beans
    3,187

    Re: Cannot delete file

    I had this happen to me once, but I don't remember what exactly fixed the problem. If terminal doesn't help, you can try:

    - switching off the graphics (Ctr + Alt + F1, but save everything that you are doing). Try deleting this in pule console mode.

    - install Nautilus and/or Thunar, those are the default file managers for XFCE and Gnome and they may do what Dolphin cannot. You can also try Krusader and other such options.

    - You can try booting from a live CD and use KDE or Gnome directly from the disk. This should do the trick.

    I hope one of those works for you.

  3. #3
    Join Date
    Jul 2005
    Location
    England
    Beans
    Hidden!

    Re: Cannot delete file

    Is this a mount folder of an iso file, or something similar?

    If it might be, try right clicking and unmounting. I may be quite wrong, but it is a possibility, and something that I had happen to me as long time ago.

    You could also just reboot, and if it's a mounted file or folder it should disappear.

  4. #4
    Join Date
    May 2008
    Beans
    2,526

    Re: Cannot delete file

    Looks like it may be an invalid name. Might try renaming it first then try deleting it.
    Ultimate Edition Links

  5. #5
    Join Date
    Jan 2007
    Location
    Bonn, Germany
    Beans
    37
    Distro
    Ubuntu

    Re: Cannot delete file

    The problem seems to be the unknown character in the filename (encoding problem). You can remove the file by its inode number. Here's a nice howto:

    http://www.cyberciti.biz/tips/delete...de-number.html
    A witty saying proves nothing. -- Voltaire

  6. #6
    Join Date
    May 2008
    Beans
    2,526

    Re: Cannot delete file

    Quote Originally Posted by nem75 View Post
    The problem seems to be the unknown character in the filename (encoding problem). You can remove the file by its inode number. Here's a nice howto:

    http://www.cyberciti.biz/tips/delete...de-number.html
    Nice find. Bookmarked for future reference.
    Ultimate Edition Links

  7. #7
    Join Date
    Jun 2007
    Location
    Guadalajara, Mexico
    Beans
    35
    Distro
    Kubuntu 10.04 Lucid Lynx

    Re: Cannot delete file

    I tried to remove it using the inode number, but it replies that it cannot be deleted because it is a folder and not a file.

    Note: renaming, replacing, copying, moving, changing permissions, properties or whatever I want to do with this folder is impossible.

  8. #8
    Join Date
    Mar 2006
    Location
    Spain
    Beans
    134
    Distro
    Kubuntu 9.04 Jaunty Jackalope

    Re: Cannot delete file

    Hi!
    This has happened to me too. I guess something is wrong with the original file encoding. Anyway, what I do when this happens is go to the folder (Descargas in this case) and press f4. That'll bring the terminal window.
    In the terminal window :

    1 - write "rm -rf" - but don't press enter yet!!!! Now write "Adam" and press Tab button for auto-completion of the folder name.

    2 - Double check that's the folder you want to delete. Once you press Enter there's no (easy) going back. Press Enter and (hopefully) the folder is gone.

    As to where the problem lies, I cannot really tell, it's only happened to me with some downloaded files.

  9. #9
    Join Date
    Dec 2008
    Beans
    369

    Re: Cannot delete file

    What is the type of filesystem that the files you can't delete are on? I've run into this exact same problem before on a JFS volume. You may need to specify to use UTF-8 character encoding in the mount options. Once you do, the problem will be gone.

    Open up kterm and enter "man mount". Then press / and type in the name of the filesystem type to search the man page for mount options specific to it. Look for something like "utf8" or "iocharset=utf8". Then, put that in the "mount options" column of your /etc/fstab entry that corresponds to the volume that the files you can't delete are on.

  10. #10
    Join Date
    Apr 2010
    Beans
    2

    Re: Cannot delete file

    Change the name ur using special character that mean something to the shell or use root privileges by issuing nautilus.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •