Page 2 of 10 FirstFirst 1234 ... LastLast
Results 11 to 20 of 100

Thread: Cannot suspend or hibernate Asus N61J Laptop

  1. #11
    Join Date
    Sep 2008

    Re: Cannot suspend or hibernate Asus N61J Laptop

    Just a drive-by FYI: this worked for me, even though I'm not running Ubuntu. I have PCLinuxOS 2010 on an Asus U30jc-A1. I had the same problem, and this solution (word-for-word, substituting my own device values where necessary, but without changing anything else) seems to have worked. Thanks, John Dias (and ipsi)!

  2. #12
    Join Date
    Apr 2009

    Re: Cannot suspend or hibernate Asus N61J Laptop

    I was having the same problems, and followed what is said in this thread. But, my suspend/hibernate moved on from a USB8 problem, to a new problem.

    Now, in my syslog, I get:
    wl 0000:06:07.0: PCI INT A disabled
    pci_legacy_suspend(): wl_suspend+0x0/0x70 [wl] returns -5
    pci_pm_suspend+0x0/0xf0 returns -5
    Device 0000:06:07.0 failed to suspend: error -5
    Some devices failed to suspend
    After removing the wireless driver(Broadcom STA) and rebooting, it worked just fine.

    So I guess I either need to run wired network only, or figure another solution for this driver. Is there a similar way to just disable the wireless, like the usb?
    Last edited by Speedwagon; June 1st, 2010 at 04:56 AM.

  3. #13
    Join Date
    Feb 2010

    Re: Cannot suspend or hibernate Asus N61J Laptop

    Your solution worked for my ASUS N61J as well. Much thanks sir.

  4. #14
    Join Date
    Apr 2005
    Phnom Penh
    Ubuntu 12.04 Precise Pangolin

    Re: Cannot suspend or hibernate Asus N61J Laptop

    And also on a G60JX, though, like Greeble in this thread, I have a craaaaazy flashing keyboard backlight when the laptop's suspended. Anybody else seen this?
    Mr. Flibble's very cross.

  5. #15
    Join Date
    Jan 2010

    Re: Cannot suspend or hibernate Asus N61J Laptop

    I have laptop HP dv4 -1241 . I am using ubuntu 10.04 and having problem while suspending and hibernating my laptop . I am a beginner in linux , so someone please guide me in a simple way , how to sort it out


  6. #16
    Join Date
    Oct 2008
    Ubuntu 10.10 Maverick Meerkat

    Re: Cannot suspend or hibernate Asus N61J Laptop

    Quote Originally Posted by nuage6 View Post
    On my HP 8540w I have created the following script


    The content of this file is
    # Fix some issues with USB3
    if [ "$1" = "suspend" ]
            modprobe -r xhci
    if [ "$1" = "resume" ]
            modprobe xhci
    chmod 755 /etc/pm/sleep.d/05_xhci

    And now I can use my USB3 devices and go in suspend mode.
    (Perhaps you need to change the script to hibernate)

    Note that I use Lucid, version 10.4 beta 2
    Perhaps you'll need to store this file on a folder called suspend.d
    Thank you for the tips helping me to understand the issue.

    i just tried this out for my machine (Envy 17) and it worked, went into suspend/sleep fine. but upon wake up, it was stuck at the screensaver. esc key and mouse click paused/resumed the screensaver, but i couldn't get back in to ubuntu ....

    don't know how to fix this ...
    HP Envy 17
    ubuntu 10.10 kernel 2.6.37
    windows 7

  7. #17
    Join Date
    Jan 2007

    Re: Cannot suspend or hibernate Asus N61J Laptop

    I got suspend to work using John Dias's method (thanks!), but hibernate still doesn't work. Looking at the logs, it just hibernates and then thaws immediately without any reason.

    Here is the relevant part of the logs:

    [ 1617.111123] ACPI: Preparing to enter system sleep state S4
    [ 1617.191752] PM: Saving platform NVS memory
    [ 1617.214333] Disabling non-boot CPUs ...
    [ 1617.214357] CPU0 attaching NULL sched-domain.
    [ 1617.214361] CPU1 attaching NULL sched-domain.
    [ 1617.214364] CPU2 attaching NULL sched-domain.
    [ 1617.214367] CPU3 attaching NULL sched-domain.
    [ 1617.214370] CPU4 attaching NULL sched-domain.
    [ 1617.214373] CPU5 attaching NULL sched-domain.
    [ 1617.214376] CPU6 attaching NULL sched-domain.
    [ 1617.214379] CPU7 attaching NULL sched-domain.
    [ 1617.278247] CPU0 attaching NULL sched-domain.
    [ 1617.279455] Breaking affinity for irq 25
    [ 1617.280575] CPU 1 is now offline
    [ 1617.282407] Breaking affinity for irq 26
    [ 1617.283516] CPU 2 is now offline
    [ 1617.285267] Breaking affinity for irq 27
    [ 1617.286380] CPU 3 is now offline
    [ 1617.288119] Breaking affinity for irq 28
    [ 1617.289217] CPU 4 is now offline
    [ 1617.290986] Breaking affinity for irq 12
    [ 1617.291013] Breaking affinity for irq 23
    [ 1617.292089] CPU 5 is now offline
    [ 1617.293578] Breaking affinity for irq 1
    [ 1617.293617] Breaking affinity for irq 17
    [ 1617.294713] CPU 6 is now offline
    [ 1617.296237] Breaking affinity for irq 9
    [ 1617.296259] Breaking affinity for irq 16
    [ 1617.397336] CPU 7 is now offline
    [ 1617.397338] SMP alternatives: switching to UP code
    [ 1617.403294] Extended CMOS year: 2000
    [ 1617.403381] PM: Creating hibernation image:
    [ 1617.523005] PM: Need to copy 125533 pages
    [ 1617.523008] PM: Normal pages needed: 36996 + 1024, available pages: 190642
    [ 1617.867600] PM: Hibernation image created (125533 pages copied)
    [ 1617.868366] CPU0: Thermal monitoring enabled (TM1)
    [ 1617.868431] Extended CMOS year: 2000
    [ 1617.868491] Enabling non-boot CPUs ...
    [ 1617.868645] SMP alternatives: switching to SMP code
    [ 1617.874210] Booting processor 1 APIC 0x2 ip 0x6000
    [ 1617.884369] Initializing CPU#1

    And then it continues turning on all the CPUs again.

  8. #18
    Join Date
    Jan 2007

    Re: Cannot suspend or hibernate Asus N61J Laptop

  9. #19
    Join Date
    Jan 2010
    Saint Paul, MN
    Ubuntu 9.10 Karmic Koala

    Re: Cannot suspend or hibernate Asus N61J Laptop

    Hi, I modified this to automatically pull (and save, is that necessary?) the device IDs:

    # File: "/etc/pm/sleep.d/20_custom-ehci_hcd".
    case "${1}" in
        echo -n '' > $TMPLIST
              for i in `ls /sys/bus/pci/drivers/ehci_hcd/ | egrep '[0-9a-z]+\:[0-9a-z]+\:.*$'`; do
                  # Unbind ehci_hcd for first device XXXX:XX:XX.X:
                   echo -n "$i" | tee /sys/bus/pci/drivers/ehci_hcd/unbind
               echo "$i" >> $TMPLIST
        for i in `cat $TMPLIST`; do
                  # Bind ehci_hcd for first device XXXX:XX:XX.X:
                  echo -n "$i" | tee /sys/bus/pci/drivers/ehci_hcd/bind
        rm $TMPLIST
    This seems to work fine. Should this be submitted somewhere for inclusion in Ubuntu? Is the tmplist thing ok? Should that be somehow changed?

  10. #20
    Join Date
    Feb 2006
    Ubuntu 10.04 Lucid Lynx

    Re: Cannot suspend or hibernate Asus N61J Laptop

    Works on U35JC too.

Page 2 of 10 FirstFirst 1234 ... LastLast

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts