Results 1 to 1 of 1

Thread: Ubuntu 9.04 - Apache/PHP broken after recent updates

  1. #1
    Join Date
    Sep 2007
    Beans
    37

    Ubuntu 9.04 - Apache/PHP broken after recent updates

    My PHP got broken after recent updates I applied.

    The error I was getting was:
    Starting web server apache2
    apache2: Syntax error on line 185 of /etc/apache2/apache2.conf: Syntax error on line 1 of /etc/apache2/mods-enabled/php5.load: Cannot load /usr/lib/apache2/modules/libphp5.so into server: /usr/lib/apache2/modules/libphp5.so: cannot open shared object file: No such file or directory
    ...fail!


    When I checked libphp5.so was indeed missing.

    What I did to fix it was to simply reinstall the PHP Apache module and then start Apache.

    sudo aptitude install php5 libapache2-mod-php5


    Hope this helps someone who also runs into this problem.

    I "think" the problem may have been caused by Webmin as I ran all the package updates from Webmin and not from the console as I normally do. I've never had aproblem with any package updates so I suspect Webmin did not do something correctly.
    Last edited by ravingmad; March 26th, 2010 at 01:44 PM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •