Results 1 to 5 of 5

Thread: Webdav Access

  1. #1
    Join Date
    Feb 2007
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Webdav Access

    Hello all. I'm having a problem with my webdav share. I've read countless sites and threads to try to resolve my problem, but I've yet to find a solution.

    I have a secure webdav folder that gets accessed via a non-standard port and requires basic authentication. I can connect and interact with it fine via cadaver. However, when I try to connect from nautilus, it says "Access was denied." To make it even stranger, sometimes I can click on the folder in nautilus (it still mounts) and access it. Sometimes not (just repeats the error message and won't show me the contents). I may not even un-mount it, but just look at other folder, then click it again and be able to access it, but again - only rarely.

    I asked a friend to try connecting from his windows vista computer and it would not work. It would not work from my windows XP virtual computer either. However, it mounts and works just find from my work computer (also Windows XP).

    So it seems to be a 50/50 chance that the drive will mount on any given computer/system and work. Do anyone know what the problem may be? I'm guessing user permissions, but I can't figure out what.

    I've made sure the webdav folder is owned by www-data and www-data has read access to the password file as well.

    When I try connecting from nautilus, I get this in the log file:
    Code:
    ... "OPTIONS /webdav HTTP/1.1" 401 1264 "-" "gvfs/1.4.1"
    ... "OPTIONS /webdav HTTP/1.1" 200 - "-" "gvfs/1.4.1"
    ... "PROPFIND /webdav HTTP/1.1" 207 310 "-" "gvfs/1.4.1"
    ... "OPTIONS / HTTP/1.1" 200 - "-" "gvfs/1.4.1"
    ... "PROPFIND /webdav HTTP/1.1" 403 1021 "-" "gvfs/1.4.1"
    ... "PROPFIND /webdav HTTP/1.1" 403 1021 "-" "gvfs/1.4.1"
    Here is one of the (many) sites I've tried looking at:
    http://www.howtoforge.com/how-to-set...on-ubuntu-8.10
    Last edited by Spectre5; March 26th, 2010 at 07:26 AM.

  2. #2
    Join Date
    Feb 2007
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Webdav Access

    Any ideas?

  3. #3
    Join Date
    May 2007
    Location
    NY's first capital
    Beans
    2,711
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Webdav Access

    Sorry I don't recognise those exact logs.

    I do recall while playing with WebDav myself there is some sort of bug in Nautilus.

    Try connecting from your desktop using the "connect to server" under the "places" shortcut.

    Select WebDav as the service type, try variations using ip address, port, user name and also no user name(wait for prompt).

    Sorry can't be more help.

    Good luck.
    Nothing is ever easy, but if it is difficult you must be doing it wrong.

  4. #4
    Join Date
    Feb 2007
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Webdav Access

    Ya, I've tried it like that as well as several others ways! I think it may be a problem in nautilus, but the reason I also considered the permissions is because windows seems to have problems as well, so it isn't just nautilus.

    Also, it doesn't seem to allow any connections to edit files I place. I have to copy the file to the local hard drive, edit it, then delete the file on the webdav server, then copy the edited file to webdav.

    It won't let me just copy over the old one either, I have to actually delete the copy on webdav, then upload the new one.

  5. #5
    Join Date
    May 2007
    Location
    NY's first capital
    Beans
    2,711
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Webdav Access

    Where are your WebDav directives located?

    Have you seen my thread?

    I believe the how to we both used is not correct on the directive location for apache2 and Ubuntu.
    Nothing is ever easy, but if it is difficult you must be doing it wrong.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •