Results 1 to 3 of 3

Thread: Wired network connected, but no internet access

  1. #1
    Join Date
    Mar 2010
    Ubuntu 9.10 Karmic Koala

    Wired network connected, but no internet access

    Good day,

    The Problem

    Cannot connect to internet through Firefox or download updates from online repositories

    Background info

    My laptop (MySN MG6.c) is dual-booted with Windows 7 and Ubuntu 9.10, and connected to the internet through a router (Digitus DN-11004-O), which is set-up to use DHCP. The internet connection works fine under Windows, and my previous laptop, which also ran Ubuntu 9.10, had no problems connecting to the internet through that router. The network adapter is an Atheros AR8131 PCI-E (also detected as Attansic under Ubuntu).

    System info

    Results from running various diagnostics (I have removed the output that relate to the wireless connection, as I don't use it):

    $ uname -a
    Linux valyria 2.6.31-14-generic-pae #48-Ubuntu SMP Fri Oct 16 15:22:42 UTC 2009 i686 GNU/Linux
    $ lspci -vvnn | grep Ethernet
    04:00.0 Ethernet controller [0200]: Attansic Technology Corp. Device [1969:1063] (rev c0)
    $ sudo lshw -C network
           description: Ethernet interface
           product: Attansic Technology Corp.
           vendor: Attansic Technology Corp.
           physical id: 0
           bus info: pci@0000:04:00.0
           logical name: eth0
           version: c0
           serial: 70:5a:b6:3e:c0:02
           size: 100MB/s
           capacity: 1GB/s
           width: 64 bits
           clock: 33MHz
           capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
           configuration: autonegotiation=on broadcast=yes driver=ATL1C driverversion= duplex=full firmware=L1e ip= latency=0 link=yes multicast=yes port=twisted pair speed=100MB/s
           resources: irq:36 memory:d5000000-d503ffff ioport:3000(size=128)
    $ cat /etc/network/interfaces 
    auto lo
    iface lo inet loopback
    $ ifconfig
    eth0      Link encap:Ethernet  HWaddr 70:5a:b6:3e:c0:02  
              inet addr:  Bcast:  Mask:
              inet6 addr: fe80::725a:b6ff:fe3e:c002/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1320  Metric:1
              RX packets:16 errors:0 dropped:0 overruns:0 frame:0
              TX packets:40 errors:0 dropped:0 overruns:0 carrier:1
              collisions:0 txqueuelen:1000 
              RX bytes:1814 (1.8 KB)  TX bytes:5322 (5.3 KB)
    lo        Link encap:Local Loopback  
              inet addr:  Mask:
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
              RX packets:4 errors:0 dropped:0 overruns:0 frame:0
              TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0 
              RX bytes:240 (240.0 B)  TX bytes:240 (240.0 B)
    $ route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface     *        U     1      0        0 eth0
    link-local      *          U     1000   0        0 eth0
    default         UG    0      0        0 eth0
    $ cat /etc/resolv.conf
    # Generated by NetworkManager
    Network Manager is set to use DHCP and indicates:
    Wired network connection 'Auto eth0' active
    What I've tried

    a) My first thought was to update the network driver; I downloaded the newest driver (AR81Family-linux-v1.0.1.6.tar.gz) from here, and installed it (including using the build-essential package).

    Diagnostics afterward show:

    $ dmesg | grep Atheros 
    [    4.962753] Atheros(R) AR8121/AR8113/AR8114/AR8131/AR8132 PCI-E Ethernet Network Driver - version
    [    4.962757] Copyright (c) 2007 - 2009 Atheros Corporation.
    $ dmesg | grep eth
    [    4.962797] atheros_eth 0000:04:00.0: PCI INT A -> GSI 18 (level, low) -> IRQ 18
    [    4.962808] atheros_eth 0000:04:00.0: setting latency timer to 64
    [   30.373610] atheros_eth 0000:04:00.0: irq 36 for MSI/MSI-X
    [   30.373710] atheros_eth 0000:04:00.0: ATL1C: eth0 NIC Link is Up<100 Mbps Full Duplex>
    [   35.335740] atheros_eth 0000:04:00.0: irq 36 for MSI/MSI-X
    [   35.335817] atheros_eth 0000:04:00.0: ATL1C: eth0 NIC Link is Up<100 Mbps Full Duplex>
    [   40.997108] eth0: no IPv6 routers present
    $ lsmod | grep atl1e
    atl1e                  62840  0
    It looks like it installed correctly; unfortunately the driver update had no effect on the problem.

    NOTE: There is an atl1c module, which came with the original Ubuntu installation, listed in lsmod as well. Whether removing it or leaving it there, it seems to have no effect.

    b) Next I ran some tests to check the connectivity:

    $ ping -n -c50
    PING ( 56(84) bytes of data.
    64 bytes from icmp_seq=1 ttl=44 time=30.2 ms
    64 bytes from icmp_seq=2 ttl=44 time=28.4 ms
    64 bytes from icmp_seq=3 ttl=44 time=28.4 ms
    64 bytes from icmp_seq=4 ttl=44 time=30.9 ms
    64 bytes from icmp_seq=5 ttl=44 time=30.0 ms
    64 bytes from icmp_seq=49 ttl=44 time=29.1 ms
    64 bytes from icmp_seq=50 ttl=44 time=29.7 ms
    --- ping statistics ---
    50 packets transmitted, 50 received, 0% packet loss, time 49074ms
    rtt min/avg/max/mdev = 26.606/29.188/31.606/1.295 ms
    No problem pinging internet sites, or with DNS (works without the -n option too).

    $ tracepath -n
     1:       0.132ms pmtu 1320
     1:  no reply
     2:     11.863ms asymm  1 
     3:  no reply
     4:  no reply
     5:  no reply
    30:  no reply
    31:  no reply
         Too many hops: pmtu 1320
         Resume: pmtu 1320
    $ mtr -n -c3 -r
    HOST: valyria                     Loss%   Snt   Last   Avg  Best  Wrst StDev
      1.                   0.0%     3    0.3   0.4   0.3   0.4   0.0
      2.                  0.0%     3    9.1   8.5   7.4   9.1   0.9
      3.                   0.0%     3    6.7   7.6   6.7   8.8   1.1
      4.                  0.0%     3    8.5   8.2   7.7   8.5   0.5
      5.                   0.0%     3    9.6  11.0   9.6  12.0   1.2
     19.                  0.0%     3   26.7  29.7  26.7  31.6   2.6
     20.                 0.0%     3   29.1  29.4  29.0  30.3   0.7
    Tracepath seems to give a problem, but mtr works fine, so it might be peculiar to tracepath. All in all there seems to be connectivity, yet no internet access.

    The DHCP seems to be working fine as well:

    $ sudo dhclient
    Internet Systems Consortium DHCP Client V3.1.2
    Copyright 2004-2008 Internet Systems Consortium.
    All rights reserved.
    For info, please visit
    Listening on LPF/pan0/ce:5c:ba:80:d8:c6
    Sending on   LPF/pan0/ce:5c:ba:80:d8:c6
    Listening on LPF/wlan0/00:1e:64:4c:5b:2e
    Sending on   LPF/wlan0/00:1e:64:4c:5b:2e
    Listening on LPF/eth0/70:5a:b6:3e:c0:02
    Sending on   LPF/eth0/70:5a:b6:3e:c0:02
    Sending on   Socket/fallback
    DHCPDISCOVER on pan0 to port 67 interval 3
    DHCPDISCOVER on wlan0 to port 67 interval 4
    DHCPDISCOVER on eth0 to port 67 interval 5
    DHCPDISCOVER on pan0 to port 67 interval 5
    DHCPOFFER of from
    DHCPREQUEST of on eth0 to port 67
    DHCPDISCOVER on wlan0 to port 67 interval 11
    DHCPACK of from
    bound to -- renewal in 814497 seconds.
    c) After many hours of perusing online forums and such, I tried a motley of possible solutions.

    -- Disabling IPv6 in Firefox (setting network.dns.disableIPv6=true) and across the system (setting GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 quiet splash" in /etc/default/grub). Result: no effect

    -- Setting GRUB_CMDLINE_LINUX_DEFAULT="acpi=off quiet splash" in /etc/default/grub. Result: no effect

    -- Uninstalling and reinstalling Network Manager. Result: no effect

    -- Adding new DNS servers to /etc/dhcp3/dhclient.conf (inserting prepend domain-name-servers,;). Result: no effect

    -- Installing different kernels:
    2.6.31-14-generic and 2.6.31-14-i386 successfully installed from Live DVD;
    2.6.32 installed from deb packages according to this site (I suspect they weren't configured properly);
    2.6.33-1 built from source, according to the instructions found here (but compilation failed).
    Result: no effect

    d) I also reinstalled ubuntu from my Live DVD three times already, with no effect on the problem.

    In conclusion

    I have spent a week now trying to get the internet to work on the Ubuntu side of my new laptop with what I know, without success. I would really appreciate it if someone here could shed some light on the problem, since I am out of ideas and wary of further forum crawling. Thank you.

  2. #2
    Join Date
    Jan 2006
    Not heaven... Iowa

    Re: Wired network connected, but no internet access

    Everything looks like it should work. The only thing I noticed is that MTU is not 1500 (which it needn't necessarily be). Did you change that value, or did it magically appear? Here is a thread that discusses MTU configuration. That may not be it either, but you appear to have turned most of the other stones...
    Linux User #415691 Ubuntu User #8629
    Iowa Team (LoCo): [Wiki] [Launchpad]
    IRC channel: #ubuntu-us-ia on

  3. #3
    Join Date
    Mar 2010
    Ubuntu 9.10 Karmic Koala

    Re: Wired network connected, but no internet access

    Hi Iowan. I followed the thread you suggested and am now able to reply to your answer from within Ubuntu ! The MTU was indeed the problem. Thank you for the prompt help.

    Here's what I did:

    First I checked the given MTU (1320), which was detected automatically by Network Manager (MTU set to automatic in the settings).

    $ ping -c1 -s 1320 -M do
    PING ( 1320(1348) bytes of data.
    From icmp_seq=1 Frag needed and DF set (mtu = 1320)
    --- ping statistics ---
    0 packets transmitted, 0 received, +1 errors
    Then I proceeded pinging the router with smaller packages until one got transmitted.

    $ ping -c1 -s 1292 -M do
    PING ( 1292(1320) bytes of data.
    1300 bytes from icmp_seq=1 ttl=30 time=1.19 ms
    --- ping statistics ---
    1 packets transmitted, 1 received, 0% packet loss, time 0ms
    rtt min/avg/max/mdev = 1.194/1.194/1.194/0.000 ms
    I then changed the MTU to 1292 in Network Manager and ifconfig.

    $ sudo ifconfig eth0 mtu 1292
    $ ifconfig | grep MTU
              UP BROADCAST RUNNING MULTICAST  MTU:1292  Metric:1
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
    This did not have the desired effect. Then I remembered having seen MTU 1500 somewhere, so I logged into the router from Windows again. On the router MTU was set to 1500, so I went back to Ubuntu, and set MTU to 1500 in both ifconfig and Network Manager.

    $ sudo ifconfig eth0 mtu 1500
    $ ifconfig | grep MTU
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              UP LOOPBACK RUNNING  MTU:16436  Metric:1
    And that was the end of the problem.

    PS: At first I had only changed the value in ifconfig, but when I rebooted, the problem was back again, and MTU was again detected as 1320. Curiously Network Manager keeps detecting a MTU of 1320 when set to automatic.

Tags for this Thread


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts