Page 2 of 2 FirstFirst 12
Results 11 to 15 of 15

Thread: ffmpeg when ./configure, can't --enable-libamr-nb and libamr-wb

  1. #11
    Join Date
    Sep 2006
    Beans
    3,713

    Re: ffmpeg when ./configure, can't --enable-libamr-nb and libamr-wb

    Quote Originally Posted by sushant.d84 View Post
    Can you please help me out
    Remove --enable-cross-compile and it will work.

  2. #12
    Join Date
    Dec 2006
    Beans
    7,317

    Re: ffmpeg when ./configure, can't --enable-libamr-nb and libamr-wb

    I guess this is the problem option:

    Code:
    --enable-cross-compile
    You have not mentioned why you are using this?

    Andrew
    You think that's air you're breathing now?

  3. #13
    Join Date
    Mar 2011
    Beans
    10

    Re: ffmpeg when ./configure, can't --enable-libamr-nb and libamr-wb

    Hey
    Thanks for your reply ..

    I remove the options and now I got a new message..



    root@user-desktop:/opt/lampp/htdocs/ffmpeg-0.6.0-old# ./configure --enable-gpl --enable-libfaac --enable-nonfree --enable-libopencore-amrnb --enable-version3 --enable-libopencore-amrwb --enable-libmp3lame
    gcc is unable to create an executable file.
    If gcc is a cross-compiler, use the --enable-cross-compile option.
    Only do this if you know what cross compiling means.
    C compiler test failed.

    If you think configure made a mistake, make sure you are using the latest
    version from SVN. If the latest version fails, report the problem to the
    ffmpeg-user@mplayerhq.hu mailing list or IRC #ffmpeg on irc.freenode.net.
    Include the log file "config.err" produced by configure as this will help
    solving the problem.

  4. #14
    Join Date
    Dec 2006
    Beans
    7,317

    Re: ffmpeg when ./configure, can't --enable-libamr-nb and libamr-wb

    Quote Originally Posted by sushant.d84 View Post
    I remove the options and now I got a new message...
    I suspect that rather than continuing your attempts to build FFmpeg in this way you might be better to follow this guide:

    HOWTO: Install and use the latest FFmpeg and x264
    http://ubuntuforums.org/showthread.php?t=786095

    This might make life a little easier for you .

    Andrew
    You think that's air you're breathing now?

  5. #15
    Join Date
    Dec 2006
    Beans
    7,317

    Re: ffmpeg when ./configure, can't --enable-libamr-nb and libamr-wb

    Quote Originally Posted by andrew.46 View Post
    FFmpeg does not have an encoder for amrwb, only amrnb .
    How quickly my words turn to dust in my mouth . This link shows some details of the new amr-wb encoder now possible with FFmpeg:

    http://ubuntuforums.org/showpost.php...postcount=1606
    You think that's air you're breathing now?

Page 2 of 2 FirstFirst 12

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •