Hello, I am trying to run/install Netlogo simulation tool that I have to use on my Open University course.

I have downloaded & untarred the program in my home directory. What do I do next?

I tried this: http://ubuntuforums.org/showthread.php?t=573176
which tells to run the NetLogo.jar file using Sun Java 6 Runtime (I went to right-click - run). Nothing happened.


I also saw this: http://ubuntuforums.org/showthread.php?t=116441
which says that even I have Sun Java 6, Netlogo tries to use gcj java. I tried the same command on the terminal:
Code:
tuisku@Frog:~$ sudo update-java-alternatives -l
java-6-sun 63 /usr/lib/jvm/java-6-sun
tuisku@Frog:~$ cd /home/tuisku/Applications/Netlogo
tuisku@Frog:~/Applications/Netlogo$ java -jar NetLogo.jar
Exception in thread "main" java.lang.NoClassDefFoundError: org.nlogo.app.App
   at java.lang.Class.initializeClass(libgcj.so.10)
Caused by: java.lang.ClassNotFoundException: org.picocontainer.Parameter not found in gnu.gcj.runtime.SystemClassLoader{urls=[file:NetLogo.jar], parent=gnu.gcj.runtime.ExtensionClassLoader{urls=[], parent=null}}
   at java.net.URLClassLoader.findClass(libgcj.so.10)
   at gnu.gcj.runtime.SystemClassLoader.findClass(libgcj.so.10)
   at java.lang.ClassLoader.loadClass(libgcj.so.10)
   at java.lang.ClassLoader.loadClass(libgcj.so.10)
   at java.lang.Class.initializeClass(libgcj.so.10)
tuisku@Frog:~/Applications/Netlogo$
Any ideas? You may need to spell them out as I am not that experienced on Linux. Thanks